Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox comes up a blank screen after update.

  • 3 replies
  • 14 have this problem
  • 4673 views
  • Last reply by cor-el

more options

I received an automatic update on Firefox. After the update I can no longer open Firefox. Just a black tab shows. I uninstalled it and re-installed and still nothing. I even did a reset and no success. I'm at the point of uininstalling for good.

Chosen solution

Try to start Firefox with the about:blank page by creating a copy of the current Firefox desktop shortcut. Add a space and -url "about:blank" to the target field in the Properties.

Read this answer in context 👍 1

All Replies (3)

more options

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

also: what security software are you using on your system?

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Chosen Solution

Try to start Firefox with the about:blank page by creating a copy of the current Firefox desktop shortcut. Add a space and -url "about:blank" to the target field in the Properties.