Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hangouts Plugin Will Not Install/Facebook Doesn't work.

  • 4 replies
  • 9 have this problem
  • 54 views
  • Last reply by Mr. News

more options

Hello. I am trying to use Hangouts in Firefox to communicate with my son at college. I have installed the plugin multiple times, yet it doesn't show up in the Firefox plugins list nor does it work. I am constantly redirected to install the plugin.

Also, video doesn't work on Messenger.com (Facebook Messenger). I am forced to use Chrome to communicate. I get the opportunity to share my cam and mic, however there is still an error saying I do not have a cam or mic installed.

I have 2 webcams and 3 mics. Both webcams and 2 mics are on my monitors, the third mic is my headset.

Video and audio do work at AppRTC.

Any help is much appreciated. I am old and set in my ways, and I prefer Firefox.

All Replies (4)

more options

Hi y0himba,

I understand that when you are chatting with your son with Google Hangouts in Firefox, that you are running into an issue where you have installed the Google Voice or Talk plugin and it does not show up in Firefox.

Are the permissions to share these devices shared on the website where hte plugin is loading. Check the permissions of the shared hardware in this setting:

Make sure that the plugin in about:addons is set to Always activate as well .

I made a screencast that should be helpful https://www.screencast.com/t/ztTLcbhp

more options

hi y0himba, you are using a win64-bit build of firefox - the only plugin it supports is adobe flash. we are working with google to move hangouts to model where it uses just basic html5 technologies like webrtc and works out of the box. we hope this is available soon...

more options

Would switching back to 32bit allow me to use the plugin? If so, can I migrate from 64bit to 32bit?

more options

Using FF ESR 52.2.0 (32-bit), I get a message in the left sidebar on the Gmail webmail page: "To use chat, upgrade your browser." Chat/Hangouts was working fine a few days ago, and still works perfectly in Chrome and IE. Why has Firefox become so incredibly annoying as a browser? There are just more and more reasons to use Chrome, as everything seems to just work there.