X
Tap here to go to the mobile version of the site.

Support Forum

Cannot delete history not matter what I try.

Posted

Cannot delete history not matter Had no problem in the past. what I try. Incognito does not respond either. Should I delete fireFox, and try to install it again?

Cannot delete history not matter Had no problem in the past. what I try. Incognito does not respond either. Should I delete fireFox, and try to install it again?

Chosen solution

To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu , choose History, and then "Clear Recent History...".
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.23.20053
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • 5.1.50901.0

Application

  • Firefox 50.1.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.1.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.8.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AdBlocker for YouTube™ 0.2.5 (jid1-q4sG8pYhq8KGHs@jetpack)
  • AOL One Click 1.1.33.1-signed.1-signed (homepage.extension@aol.com)
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Norton Identity Safe 2.0.65 (idsafe@norton.com)
  • Norton Security Toolbar 2016.8.1.9 ({C1A2A613-35F1-4FCF-B27F-2840527B6556})
  • Pocket 1.0.5 (firefox@getpocket.com)
  • URL Buttons Pack 1.0.1-signed.1-signed (urlbuttons@izohair.blogspot.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 08661025
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 1-6-2013
  • driverDate2:
  • driverVersion: 10.18.10.3383
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
innu 3 solutions 11 answers

Chosen Solution

To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu , choose History, and then "Clear Recent History...".
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

To clear cache and cookies do the following: #Click the menu button [[Image:New Fx Menu]], choose History, and then "Clear Recent History...". #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the "Clear Now" button. Further information can be found in the [[Delete browsing, search and download history on Firefox]] article. Did this fix your problems? Please report back to us! Thank you.

Question owner

It was just a matter of going into my FrirFox privacy settings for choices of clearing email.

It was just a matter of going into my FrirFox privacy settings for choices of clearing email.
malcpritch 0 solutions 15 answers

I have this problem. When I choose History, and then "Clear Recent History...". it is not available as it is greyed out

I have this problem. When I choose History, and then "Clear Recent History...". it is not available as it is greyed out
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

Hi malcpritch

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy -> Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
Hi malcpritch Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/Private+Browsing *Options/Preferences -> Privacy -> Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode"
malcpritch 0 solutions 15 answers

Thanks, but when I go TOOLS - OPTIONS - PRIVACY I do not get Use custom settings for history" Use custom settings for history"

Thanks, but when I go TOOLS - OPTIONS - PRIVACY I do not get Use custom settings for history" Use custom settings for history"
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

The screenshot shows that Private Browsing mode is active since it shows "Never Remember History". You need to click this line and select "Remember History" or "Use custom settings for history" if you want to make changes to some settings like (third-party) cookies or "Clear history when Firefox closes".

The screenshot shows that Private Browsing mode is active since it shows "Never Remember History". You need to click this line and select "Remember History" or "Use custom settings for history" if you want to make changes to some settings like (third-party) cookies or "Clear history when Firefox closes". *https://support.mozilla.org/en-US/kb/Options+window+-+Privacy+panel
malcpritch 0 solutions 15 answers

Is it possible to get a simple step by step gude

Is it possible to get a simple step by step gude
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

Click the line that shows "Never Remember History". That will open a drop-down list. From that drop-down list you can select "Use custom settings for history". Remove the checkmark on "Always use Private Browsing mode". Close and restart Firefox when prompted. You should be able to clear the history when Firefox is restarted.


  • Options/Preferences -> Privacy -> Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
Click the line that shows "Never Remember History". That will open a drop-down list. From that drop-down list you can select "Use custom settings for history". Remove the checkmark on "Always use Private Browsing mode". Close and restart Firefox when prompted. You should be able to clear the history when Firefox is restarted. ---- *Options/Preferences -> Privacy -> Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode"
malcpritch 0 solutions 15 answers

You say "Click the line that shows "Never Remember History". But there is no such option

You say "Click the line that shows "Never Remember History". But there is no such option
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

Hi malcpritch

With the settimgs that show in the screenshot you already have opened the custom settings. Since there is no checkmark on "Always use Private Browsing mode" this means the you are not in permanent Private Browsing mode and you shouldn't have the same issue that the OP (thread creator) described.

What kind of problems do you have with deleting history?

Hi malcpritch With the settimgs that show in the screenshot you already have opened the custom settings. Since there is no checkmark on "Always use Private Browsing mode" this means the you are not in permanent Private Browsing mode and you shouldn't have the same issue that the OP (thread creator) described. What kind of problems do you have with deleting history?
malcpritch 0 solutions 15 answers

Thank you, now I have been following these tips, I CAN now delete history BUT I wanted if possible to stop recording history which I cannot seem to achieve

Thank you, now I have been following these tips, I CAN now delete history BUT I wanted if possible to stop recording history which I cannot seem to achieve