X
Tap here to go to the mobile version of the site.

Support Forum

Can't get rid of Yahoo search default

Posted

Yahoo suddenly the default search engine after downloading something stupid I can't even remember anymore and can't find. Removed Yahoo in Firefox Preferences, trashed the application (Yahoo Powered Search), and STILL it comes up as the default. Firefox 48.0.2/ Mac OS10.8.5. Changing search engine in Preferences didn't work. Removing it entirely hasn't worked. Trashing it and emptying trash hasn't worked. Restarting Firefox and also restarting the computer after making the changes hasn't worked. Is there anything a non-geek can do that works?

This is the page that opens automatically: https://us.search.yahoo.com/yhs/web?hspart=rotz&hsimp=yhs-001&type=mdru7c6fb085c2¶m1=ArFaIWVoNqArQGMVInobADAevXFbMnMqQGMVEENoNqAdQGMVyDMly7IexrFbMnMpQGMVNos3wCoUwV5bDGUNNEU3wCoXvmo9JmIWNVRdJqYXNVM9I6IWvFE3vmIXwVw4IWYXwVVdJmISvmpdIWYVwVU9I6IWwVI4JaYXNVU4ICIYvmpdJmoVwVRdJmILNFdcIaUXNEBcGqQANFdcFCk8NoM3vGYVwVM4JmIVNVA9JaYYwVxdJGYVNVVdJCISvFE9JCIVvFM9IaYYwVU4ISoVwVw9JqYUNVM4IGYYvFNdJ6oXNVQ4J6k4vFNbFCILNEVbDmk8NUM9J6k3wVM3vCILNFdbDSk8wVU9ImoVwVA9JCoVwVA4J6ILNFdcJ6k8NFtcFGUWwVM9ImIVwVA4JmITvFI9GqUFNFo3wCoUwV5cJqQzNEBcEWUGNF43wHFbMnMbQGMVMqBbNWx9NGRcQGR7BHFaIT8pxo0aCaV7CaFcC78qvE0gB6EdASIuNGAuMWN%3D¶m2=¶m3=¶m4=

Yahoo suddenly the default search engine after downloading something stupid I can't even remember anymore and can't find. Removed Yahoo in Firefox Preferences, trashed the application (Yahoo Powered Search), and STILL it comes up as the default. Firefox 48.0.2/ Mac OS10.8.5. Changing search engine in Preferences didn't work. Removing it entirely hasn't worked. Trashing it and emptying trash hasn't worked. Restarting Firefox and also restarting the computer after making the changes hasn't worked. Is there anything a non-geek can do that works? This is the page that opens automatically: https://us.search.yahoo.com/yhs/web?hspart=rotz&hsimp=yhs-001&type=mdru7c6fb085c2&param1=ArFaIWVoNqArQGMVInobADAevXFbMnMqQGMVEENoNqAdQGMVyDMly7IexrFbMnMpQGMVNos3wCoUwV5bDGUNNEU3wCoXvmo9JmIWNVRdJqYXNVM9I6IWvFE3vmIXwVw4IWYXwVVdJmISvmpdIWYVwVU9I6IWwVI4JaYXNVU4ICIYvmpdJmoVwVRdJmILNFdcIaUXNEBcGqQANFdcFCk8NoM3vGYVwVM4JmIVNVA9JaYYwVxdJGYVNVVdJCISvFE9JCIVvFM9IaYYwVU4ISoVwVw9JqYUNVM4IGYYvFNdJ6oXNVQ4J6k4vFNbFCILNEVbDmk8NUM9J6k3wVM3vCILNFdbDSk8wVU9ImoVwVA9JCoVwVA4J6ILNFdcJ6k8NFtcFGUWwVM9ImIVwVA4JmITvFI9GqUFNFo3wCoUwV5cJqQzNEBcEWUGNF43wHFbMnMbQGMVMqBbNWx9NGRcQGR7BHFaIT8pxo0aCaV7CaFcC78qvE0gB6EdASIuNGAuMWN%3D&param2=&param3=&param4=

Chosen solution

AllisonDM said

The default page upon rebooting Firefox is Yahoo search.

That sounds like a different setting. Could you check whether that has been set as your home page? Either of these articles should point you to that part of the Preferences page:

If the change works (you can test by launching a new window, Command+n) but is reverted at the next startup, check this article: How to fix preferences that won't save.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 24.0 r0
  • 5.1.30514.0
  • zoom.us launcher plugin version 1.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi AllisonDM, is your default search setting changing to Yahoo, or is it being ignored?

One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, Disable. If it's something you don't remember installing, try to Remove.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Hi AllisonDM, is your default search setting changing to Yahoo, or is it being ignored? One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, Disable. If it's something you don't remember installing, try to Remove. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement?

Question owner

I did what you suggested but I only had Pinterest pin image add-on I've had for much longer than this problem and BlockSite I just downloaded today and can't figure out how to use so I removed it and restarted. No change. The default page upon rebooting Firefox is Yahoo search.

I did what you suggested but I only had Pinterest pin image add-on I've had for much longer than this problem and BlockSite I just downloaded today and can't figure out how to use so I removed it and restarted. No change. The default page upon rebooting Firefox is Yahoo search.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

AllisonDM said

The default page upon rebooting Firefox is Yahoo search.

That sounds like a different setting. Could you check whether that has been set as your home page? Either of these articles should point you to that part of the Preferences page:

If the change works (you can test by launching a new window, Command+n) but is reverted at the next startup, check this article: How to fix preferences that won't save.

''AllisonDM [[#answer-949187|said]]'' <blockquote> The default page upon rebooting Firefox is Yahoo search. </blockquote> That sounds like a different setting. Could you check whether that has been set as your home page? Either of these articles should point you to that part of the Preferences page: * [[How to set the home page]] * [[Startup, home page, tabs, and download settings]] If the change works (you can test by launching a new window, Command+n) but is reverted at the next startup, check this article: [[How to fix preferences that won't save]].

Question owner

You know, I'm already happily married so my budding love for you will have to remain right here on these pages. Yes, the darned page was set as the home page and I changed it, rebooted Firefox, and it worked.

Thanks so much. You have made an otherwise irritating morning so much less prickly. :-)

You know, I'm already happily married so my budding love for you will have to remain right here on these pages. Yes, the darned page was set as the home page and I changed it, rebooted Firefox, and it worked. Thanks so much. You have made an otherwise irritating morning so much less prickly. :-)