X
Tap here to go to the mobile version of the site.

Support Forum

have Outlook 2016 use Firefox to open links contained in emails

Posted

I have Windows 10 and FF 50.1.0 on my computer and want to have Outlook 2016 open links in FF instead of IE. FF has been set as my default browser for quite some time but Outlook always goes to IE. I read on one site that it as to do with mht files but have no idea how to change things or what to download. I had it set at one time but I think I deleted or changed something and have no clue what it was.

I have Windows 10 and FF 50.1.0 on my computer and want to have Outlook 2016 open links in FF instead of IE. FF has been set as my default browser for quite some time but Outlook always goes to IE. I read on one site that it as to do with mht files but have no idea how to change things or what to download. I had it set at one time but I think I deleted or changed something and have no clue what it was.

Chosen solution

I forgot to say they Firefox has been set as the default for a year without any problems. I did figure it out though. FF had to be able to read mht files so you have to download an extension such as unmht or an mht archive extension. I didn't change any options or settings in the extensions. AFTER you have the extensions in place, go to your Windows 10 settings and pull up default app settings. Look for an option to assign default apps associated with specific file types. Click on it and scroll down to mht files. Mine had 2 different mht files and to the right of each was a button that showed the IE icon. Double click on that and select FF as your default for BOTH types of mht files listed. After that, you should be all set. As a precaution, I would recommend creating a restore point before you start changing the Windows 10 settings in case something goes wrong or you tweak the wrong thing but have no clue as to what it was. I've done that so many times I've lost count!! 8~}

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 24.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157
  • WildTangent Games App V2 Presence Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

More Information

FredMcD
  • Top 10 Contributor
4272 solutions 59919 answers

Helpful Reply

Open Outlook settings and see if there is a default browser setting.

Open Outlook settings and see if there is a default browser setting.
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Windows 10 has proven more difficult than other operating systems. If the steps in the following article don't help, I'm not sure what to suggest next: How to change your default browser in Windows 10.

Windows 10 has proven more difficult than other operating systems. If the steps in the following article don't help, I'm not sure what to suggest next: [[How to change your default browser in Windows 10]].

Chosen Solution

I forgot to say they Firefox has been set as the default for a year without any problems. I did figure it out though. FF had to be able to read mht files so you have to download an extension such as unmht or an mht archive extension. I didn't change any options or settings in the extensions. AFTER you have the extensions in place, go to your Windows 10 settings and pull up default app settings. Look for an option to assign default apps associated with specific file types. Click on it and scroll down to mht files. Mine had 2 different mht files and to the right of each was a button that showed the IE icon. Double click on that and select FF as your default for BOTH types of mht files listed. After that, you should be all set. As a precaution, I would recommend creating a restore point before you start changing the Windows 10 settings in case something goes wrong or you tweak the wrong thing but have no clue as to what it was. I've done that so many times I've lost count!! 8~}

I forgot to say they Firefox has been set as the default for a year without any problems. I did figure it out though. FF had to be able to read mht files so you have to download an extension such as unmht or an mht archive extension. I didn't change any options or settings in the extensions. AFTER you have the extensions in place, go to your Windows 10 settings and pull up default app settings. Look for an option to assign default apps associated with specific file types. Click on it and scroll down to mht files. Mine had 2 different mht files and to the right of each was a button that showed the IE icon. Double click on that and select FF as your default for BOTH types of mht files listed. After that, you should be all set. As a precaution, I would recommend creating a restore point before you start changing the Windows 10 settings in case something goes wrong or you tweak the wrong thing but have no clue as to what it was. I've done that so many times I've lost count!! 8~}
FredMcD
  • Top 10 Contributor
4272 solutions 59919 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.

Question owner

Thank you! I'll take care of it right now!

Thank you! I'll take care of it right now!