X
Tap here to go to the mobile version of the site.

Support Forum

ff sux, will not resolve url, instead sends me to the search engine, fix it

Posted

So, I've had this problem in the past and went back to windows and chrome because of it. I no longer have that option and I am stuck with firefox. This time around I type in seventorrents.win press enter. One would expect seventorrents to be the next screen. NOPE, google.com is, treating my url like a search term. This is total bullshit, you know it, I know it. The problem lies in the browser, get the code writers to fix the goddamned thing. IF chrome worked on kali, you'd never hear from me again. Annoying as fuck. FIX IT NOW

So, I've had this problem in the past and went back to windows and chrome because of it. I no longer have that option and I am stuck with firefox. This time around I type in seventorrents.win press enter. One would expect seventorrents to be the next screen. NOPE, google.com is, treating my url like a search term. This is total bullshit, you know it, I know it. The problem lies in the browser, get the code writers to fix the goddamned thing. IF chrome worked on kali, you'd never hear from me again. Annoying as fuck. FIX IT NOW

Chosen solution

Your user agent shows that you use an older Firefox version based upon Iceweasel and not the official release from the Mozilla server.

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 Iceweasel/43.0.4

Maybe you can install the current Firefox 45.5.1 ESR version if you do not want to use the latest release.


the suffix .win as you wrote above: seventorrents.win isn't a recognized toplevel domain like .com and .org, so it is likely to trigger a search. You can disable keyword search by setting keyword.enabled to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 Iceweasel/43.0.4

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156810 answers

Chosen Solution

Your user agent shows that you use an older Firefox version based upon Iceweasel and not the official release from the Mozilla server.

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 Iceweasel/43.0.4

Maybe you can install the current Firefox 45.5.1 ESR version if you do not want to use the latest release.


the suffix .win as you wrote above: seventorrents.win isn't a recognized toplevel domain like .com and .org, so it is likely to trigger a search. You can disable keyword search by setting keyword.enabled to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Your user agent shows that you use an older Firefox version based upon Iceweasel and not the official release from the Mozilla server. *User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 Iceweasel/43.0.4 Maybe you can install the current Firefox 45.5.1 ESR version if you do not want to use the latest release. *https://www.mozilla.org/en-US/firefox/all/ *https://www.mozilla.org/en-US/firefox/organizations/all/ *https://www.mozilla.org/en-US/firefox/organizations/notes/ *https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ ----- the suffix .win as you wrote above: seventorrents.win isn't a recognized toplevel domain like .com and .org, so it is likely to trigger a search. You can disable keyword search by setting keyword.enabled to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

I liked cor-el's solution. It worked fine. That system crashed and in rebuilding Kali, I updated and upgraded and now have 45.5 and this fix doesn't seem to work. Yeah, I hadn't upgraded the OS or Firefox of the old installation.

I have set keyword.enabled false unchecked, search suggestions

Oh yeah, I haven't gotten the magnet handler to work, yet

I liked cor-el's solution. It worked fine. That system crashed and in rebuilding Kali, I updated and upgraded and now have 45.5 and this fix doesn't seem to work. Yeah, I hadn't upgraded the OS or Firefox of the old installation. I have set keyword.enabled false unchecked, search suggestions Oh yeah, I haven't gotten the magnet handler to work, yet
jscher2000
  • Top 10 Contributor
8582 solutions 70194 answers

DeadGirlRising said

I have set keyword.enabled false

So with that setting, Firefox should not display search results -- unless your DNS provider diverts you to an advertising page. Are you just getting "server not found" or what?

''DeadGirlRising [[#answer-942464|said]]'' <blockquote> I have set keyword.enabled false </blockquote> So with that setting, Firefox should not display search results -- unless your DNS provider diverts you to an advertising page. Are you just getting "server not found" or what?

Question owner

Still having the problem. It went away then came back. I think I'll have to do to Midori. Works on root because they aren't people who think they are better than the rest of us. Trying to protect people against themselves, how quaint, how .. ridiculous..

No, no message just straight to whatever .. search engine is default that day. It is NOT my DNS servers as this problem ONLY happens with this crap program.

Well have to go try Vivaldi, maybe IT will work. Chrome does, but it no longer works as root.

edited due to language.

Still having the problem. It went away then came back. I think I'll have to do to Midori. Works on root because they aren't people who think they are better than the rest of us. Trying to protect people against themselves, how quaint, how .. ridiculous.. No, no message just straight to whatever .. search engine is default that day. It is NOT my DNS servers as this problem ONLY happens with this crap program. Well have to go try Vivaldi, maybe IT will work. Chrome does, but it no longer works as root. edited due to language.

Modified by James

jscher2000
  • Top 10 Contributor
8582 solutions 70194 answers

Could you post some of the URLs of the unwanted result pages? The parameters in the URL may point to the culprit.

Could you post some of the URLs of the unwanted result pages? The parameters in the URL may point to the culprit.

Question owner

It is seventorrents.win.

So, I had to reinstall my OS. Somehow with your help I had it working right on the old OS.

I fixed it by setting:

Browser.urlbar.userMadeSearchSuggestionsChoice. toggled from 'true' to 'false'

Works fine until you need to search. Toggle back and I don't get search back, ugh. But further exploration of the configuration settings I saw:

extensions.omnibar.enabledefaultsearch was set to false, toggled it to true

I'm not entirely clear on what I did, but it seems to be working.

Thank you

It is seventorrents.win. So, I had to reinstall my OS. Somehow with your help I had it working right on the old OS. I fixed it by setting: Browser.urlbar.userMadeSearchSuggestionsChoice. toggled from 'true' to 'false' Works fine until you need to search. Toggle back and I don't get search back, ugh. But further exploration of the configuration settings I saw: extensions.omnibar.enabledefaultsearch was set to false, toggled it to true I'm not entirely clear on what I did, but it seems to be working. Thank you
jscher2000
  • Top 10 Contributor
8582 solutions 70194 answers

DeadGirlRising said

But further exploration of the configuration settings I saw:
extensions.omnibar.enabledefaultsearch was set to false, toggled it to true
I'm not entirely clear on what I did, but it seems to be working.

Omnibar is an extension that modifies the address bar, so that might explain its nonstandard behavior...

''DeadGirlRising [[#answer-947793|said]]'' <blockquote>But further exploration of the configuration settings I saw: <br> extensions.omnibar.enabledefaultsearch was set to false, toggled it to true <br> I'm not entirely clear on what I did, but it seems to be working. </blockquote> [https://addons.mozilla.org/firefox/addon/omnibar/ Omnibar] is an extension that modifies the address bar, so that might explain its nonstandard behavior...