X
Tap here to go to the mobile version of the site.

Support Forum

Javascript media elements not working

Posted

Any web site that has a Javascript media element isn't working through Firefox on one of my computers. Other computers are working fine, so it's clearly a problem with my machine.

For example, the play button on this site doesn't do anything: http://radiodeluxewithjohnpizzarelli.com/. There are no obvious errors in the console log. Also, when I test to see if Javascript is working at this site: http://www.javatester.org/javascript.html all seems fine. I'm running Javascript 1.5 with Firefox 50.0.

I tried restarting with add-ons disabled. I also tried doing a refresh of Firefox. Nothing has helped.

Can you suggest additional diagnostics that I can try?

Thanks.

Any web site that has a Javascript media element isn't working through Firefox on one of my computers. Other computers are working fine, so it's clearly a problem with my machine. For example, the play button on this site doesn't do anything: http://radiodeluxewithjohnpizzarelli.com/. There are no obvious errors in the console log. Also, when I test to see if Javascript is working at this site: http://www.javatester.org/javascript.html all seems fine. I'm running Javascript 1.5 with Firefox 50.0. I tried restarting with add-ons disabled. I also tried doing a refresh of Firefox. Nothing has helped. Can you suggest additional diagnostics that I can try? Thanks.

Additional System Details

Installed Plug-ins

  • Intel web components updater - Installs and updates the Intel web components
  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 23.0 r0

Application

  • Firefox 50.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Custom Tab Width 1.0.1.1-signed.1-signed (tab-width@design-noir.de)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • LoaderFF 5.3.23.0 (loaderff@nefsis.com) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • WebSlingPlayer 1.4.0.76 ({9EB34849-81D3-4841-939D-666D522B889A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 650 Ti BOOST
  • adapterDescription2:
  • adapterDeviceID: 0x11c2
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 8-25-2016
  • driverDate2:
  • driverVersion: 21.21.13.7270
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Ti BOOST Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4335 solutions 61002 answers

It plays okay for me. Did you post this from the 'sick' computer?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

It plays okay for me. Did you post this from the 'sick' computer? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Yes, I started in Safe Mode and the problem is still present.

Yes, I started in Safe Mode and the problem is still present.
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

Does the HTML5 audio player work for you on this test page:

http://hpr.dogphilosophy.net/test/

It uses the built-in player controls, which clearly are less attractive than the Radio Deluxe custom controls, but we should confirm that the player itself isn't broken.

Does the HTML5 audio player work for you on this test page: http://hpr.dogphilosophy.net/test/ It uses the built-in player controls, which clearly are less attractive than the Radio Deluxe custom controls, but we should confirm that the player itself isn't broken.

Question owner

When I click the mp3 link, the player button appears for a split second and then disappears. I get a warning stating the browser cannot decode the media. When I look at the console, it looks like I'm getting back the header of the page but nothing else.

The link works fine for mp3 files in IE11 on the same computer.

When I click the mp3 link, the player button appears for a split second and then disappears. I get a warning stating the browser cannot decode the media. When I look at the console, it looks like I'm getting back the header of the page but nothing else. The link works fine for mp3 files in IE11 on the same computer.
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

On Windows 7, Firefox usually uses the "Media Foundation" to decode MP3s. As a fallback, Firefox can use "DirectShow" (an older technology). But both of these are part of Windows and not included with Firefox itself.

If you use a version of Windows that did not bundle the Media components, you may need to download a separate installer from Microsoft. More info in this article: https://support.microsoft.com/en-us/kb/968211

Since you refreshed Firefox, it's unlikely that any previous settings to disable media foundation and DirectShow survived that process, unless they were in the Firefox program folder -- which is very unusual -- or unless an add-on changed them. One possible reason an add-on might disable the internal HTML5 players is if it needs to do that to intercept audio and video streams for recording or downloading. You can check for changed settings here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) If the media.directshow.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

(4) If the media.wmf.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

If you made a change, could you reload the test page and try it again?

If Firefox won't accept the change, does the preference indicate a status of Locked?

On Windows 7, Firefox usually uses the "Media Foundation" to decode MP3s. As a fallback, Firefox can use "DirectShow" (an older technology). But both of these are part of Windows and not included with Firefox itself. If you use a version of Windows that did not bundle the Media components, you may need to download a separate installer from Microsoft. More info in this article: https://support.microsoft.com/en-us/kb/968211 Since you refreshed Firefox, it's unlikely that any previous settings to disable media foundation and DirectShow survived that process, unless they were in the Firefox program folder -- which is very unusual -- or unless an add-on changed them. One possible reason an add-on might disable the internal HTML5 players is if it needs to do that to intercept audio and video streams for recording or downloading. You can check for changed settings here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media.''' and pause while the list is filtered (3) If the '''media.directshow.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true (4) If the '''media.wmf.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true If you made a change, could you reload the test page and try it again? If Firefox won't accept the change, does the preference indicate a status of Locked?

Question owner

I had previously tried the Windows 7 N solution but that didn't do anything for me. On the corrupt computer, Firefox was able to play mp3 files within a Javascript media element at one time. I believe the problem occurred when one of the following happened: (1) I installed Media Monkey; (2) I installed Google Hangouts; or (3) I upgraded Firefox.

Since the problem started happening, I uninstalled Media Monkey and Google Hangouts but the problem didn't resolve itself.

Both of the configuration items you referenced were still set to the default value.

I also checked the codec for mp3 in the Windows Media Player. The codec appears to be the same as on other machines where Firefox works as expected. Of course, this checks the codec on the machine and not what FIrefox is necessarily using.

For what it's worth, the corrupt computer is a Windows 7 Pro x64 machine with a US install, i.e.: Windows 7 N doesn't apply.

This feels like Firefox is using a bad codec but I don't know to how verify this hypothesis.

I had previously tried the Windows 7 N solution but that didn't do anything for me. On the corrupt computer, Firefox was able to play mp3 files within a Javascript media element at one time. I believe the problem occurred when one of the following happened: (1) I installed Media Monkey; (2) I installed Google Hangouts; or (3) I upgraded Firefox. Since the problem started happening, I uninstalled Media Monkey and Google Hangouts but the problem didn't resolve itself. Both of the configuration items you referenced were still set to the default value. I also checked the codec for mp3 in the Windows Media Player. The codec appears to be the same as on other machines where Firefox works as expected. Of course, this checks the codec on the machine and not what FIrefox is necessarily using. For what it's worth, the corrupt computer is a Windows 7 Pro x64 machine with a US install, i.e.: Windows 7 N doesn't apply. This feels like Firefox is using a bad codec but I don't know to how verify this hypothesis.
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

Firefox sends the MPEG to Windows to decode, so a codec problem is not likely to be something in your Firefox installation.

Could you try the System File Checker?

https://support.microsoft.com/en-us/kb/929833

(Scroll just past the Windows 8.1 screenshot to find the steps for Windows 7)


Also, if you have any unfamiliar or nonessential plugins enabled, you could try disabling those on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, set plugins you do not use to "Never Activate". That could help if one of those plugins was interfering with the normal playback.

Firefox sends the MPEG to Windows to decode, so a codec problem is not likely to be something in your Firefox installation. Could you try the System File Checker? https://support.microsoft.com/en-us/kb/929833 (Scroll just past the Windows 8.1 screenshot to find the steps for Windows 7) ---- Also, if you have any unfamiliar or nonessential plugins enabled, you could try disabling those on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, set plugins you do not use to "Never Activate". That could help if one of those plugins was interfering with the normal playback.

Question owner

I ran the System File Checker. No errors were found. The exact response I received was: "Windows Resource Protection did not find any integrity violations."

I have 2 add-ons that seem odd, but they've always been on the machine. The are Intel add-ons. I tried removing them but I was unable to do this. Both add-ons appears to be disabled. I've attached screen shots.

I also started Firefox in Safe Mode, but that didn't solve my problem either.

I ran the System File Checker. No errors were found. The exact response I received was: "Windows Resource Protection did not find any integrity violations." I have 2 add-ons that seem odd, but they've always been on the machine. The are Intel add-ons. I tried removing them but I was unable to do this. Both add-ons appears to be disabled. I've attached screen shots. I also started Firefox in Safe Mode, but that didn't solve my problem either.
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

Hi lostinqueens, Safe Mode doesn't disable plugins, just extensions.

Could you set those two Intel plugins to "Never Activate" so they are fully disabled?

Hi lostinqueens, Safe Mode doesn't disable plugins, just extensions. Could you set those two Intel plugins to "Never Activate" so they are fully disabled?
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

Is the non-playing media limited to MP3 audio or does it also affect MP4 video? There is a video on the following page that you can use for testing:

Note: ignore the top part and scroll down to H.264/MP4 and try the player just below it:

http://www.quirksmode.org/html5/tests/video.html

Is the non-playing media limited to MP3 audio or does it also affect MP4 video? There is a video on the following page that you can use for testing: Note: ignore the top part and scroll down to '''H.264/MP4''' and try the player just below it: http://www.quirksmode.org/html5/tests/video.html

Question owner

My problem is not limited to mp3 files. The issue also affects mp4 files. I couldn't play the mp4 on the site you sent. The link works perfectly on IE. Here's a screen snippet.

My problem is not limited to mp3 files. The issue also affects mp4 files. I couldn't play the mp4 on the site you sent. The link works perfectly on IE. Here's a screen snippet.

Question owner

I also disabled the two Intel add-ons. That had no impact on my problem.

I also disabled the two Intel add-ons. That had no impact on my problem.
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

I don't know why your Firefox isn't able to handle MPEG-encoded media on Windows 7 if you have the media features bundled in.

If you go back into about:config and look at the preferences starting with media. do any the bolded and "user set" preferences looks possibly relevant?

Note: I think the ones starting with media.gmp are only related to copy protected (DRM) content and don't affect either of the test pages I linked to.

I don't know why your Firefox isn't able to handle MPEG-encoded media on Windows 7 if you have the media features bundled in. If you go back into about:config and look at the preferences starting with '''media.''' do any the bolded and "user set" preferences looks possibly relevant? Note: I think the ones starting with media.gmp are only related to copy protected (DRM) content and don't affect either of the test pages I linked to.

Question owner

I have obsessed about the media configs convinced there must be something there. However, almost all the configs are the default. The only exception that looks odd is media.hardware-video-decoding.failed. This config was 'true'. When I switched it to 'false', it still showed as a user defined config. So, regardless of whether this config is true or false, it's considered a user defined override.

Attached are all the media. configs that are not the default setting.

I have obsessed about the media configs convinced there must be something there. However, almost all the configs are the default. The only exception that looks odd is media.hardware-video-decoding.failed. This config was 'true'. When I switched it to 'false', it still showed as a user defined config. So, regardless of whether this config is true or false, it's considered a user defined override. Attached are all the media. configs that are not the default setting.
jscher2000
  • Top 10 Contributor
8880 solutions 72665 answers

The media.hardware-video-decoding.failed = true preference usually indicates that Firefox isn't fully compatible with your graphics card/chipset driver software. That may impact the quality of decoding of videos, but shouldn't cause them not to be decoded, and shouldn't affect audio.

Have you shut down and restarted Windows since this problem began? Just in case there's some transient privileges/permissions issue that is blocking Firefox from accessing media components.

The '''media.hardware-video-decoding.failed = true''' preference usually indicates that Firefox isn't fully compatible with your graphics card/chipset driver software. That may impact the quality of decoding of videos, but shouldn't cause them not to be decoded, and shouldn't affect audio. Have you shut down and restarted Windows since this problem began? Just in case there's some transient privileges/permissions issue that is blocking Firefox from accessing media components.

Question owner

Yes, I've shut down Windows many times. The problem started in June of this year, roughly 5 months ago. The computer is almost 3 years old. No issues before June. In June, I installed Media Monkey, Google Hangouts and an updated Firefox. I then uninstalled Media Monkey and Google Hangouts thinking this may have contributed to my problem. But the issue has persisted. I've tried many things along the way, including the Windows 7 N patch, re-installing Firefox, do a Firefox repair. Nothing has helped.

I'm certain that Firefox is behaving correctly on all of the problem sites. There's clearly a conflict between my computer and Firefox but I don't know where to look any more.

Yes, I've shut down Windows many times. The problem started in June of this year, roughly 5 months ago. The computer is almost 3 years old. No issues before June. In June, I installed Media Monkey, Google Hangouts and an updated Firefox. I then uninstalled Media Monkey and Google Hangouts thinking this may have contributed to my problem. But the issue has persisted. I've tried many things along the way, including the Windows 7 N patch, re-installing Firefox, do a Firefox repair. Nothing has helped. I'm certain that Firefox is behaving correctly on all of the problem sites. There's clearly a conflict between my computer and Firefox but I don't know where to look any more.