X
Tap here to go to the mobile version of the site.

Support Forum

Firefox exhibiting extreme slow-down and sluginess

Posted

Hi. Been having an issue with Firefox this last week (though it's happened before, just not to this extent) in that's it's being incredibly slow and moves at the pace of a snail. To give some examples, when I try type (like right now) there's a delay for the words to show up instead of popping up as I type. Another is the browser seems to freeze up for a couple seconds when I try and scroll up or down, before doing at an quick and uneven pace.

I'm uninstalled and reinstalled Firefox (reinserting my profile after doing so), disable all themes, plugins and add-ons, restarted Firefox in safe mode, and none of these have made a positive difference (in some cases it actually made it worse).

Any way of fixing this? I've been using Firefox for years now and I don't relish the idea of having to transition to another browser if hte problem could just be solved on its own.

Hi. Been having an issue with Firefox this last week (though it's happened before, just not to this extent) in that's it's being incredibly slow and moves at the pace of a snail. To give some examples, when I try type (like right now) there's a delay for the words to show up instead of popping up as I type. Another is the browser seems to freeze up for a couple seconds when I try and scroll up or down, before doing at an quick and uneven pace. I'm uninstalled and reinstalled Firefox (reinserting my profile after doing so), disable all themes, plugins and add-ons, restarted Firefox in safe mode, and none of these have made a positive difference (in some cases it actually made it worse). Any way of fixing this? I've been using Firefox for years now and I don't relish the idea of having to transition to another browser if hte problem could just be solved on its own.

Modified by Filler

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0
  • VLC media player Web Plugin

Application

  • Firefox 49.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.8.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Asynchronous Plugin Rendering 2.0 (asyncrendering@mozilla.org)
  • Download YouTube Videos as MP4 1.8.8 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • Ebates Express Cash Back 6.4.0.0 (ebatesca@ebates.com)
  • Flash and Video Download 2.03 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • KeepVid Pro 4.10.0 (KVAllmytube@KeepVid.com)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Simple YouTube to MP3/MP4 Converter and Downloader 3.9.2 (jid0-SQnwtgW1b8BsMB5PLV5WScEDWOjw@jetpack)
  • uBlock Origin 1.9.16 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • YouTube mp3 1.0.9.1-signed.1-signed (info@youtube-mp3.org)
  • Youtube MP3 Downloader using youtube-mp3.org 0.1.1-signed.1-signed (jid1-xKH0EoS44u1a2w@jetpack)
  • iSkysoft Video Converter Ultimate 5.1.0 (ISVCU@iSkysoft.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 5800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6898
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 0b001002
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 8-3-2015
  • driverDate2:
  • driverVersion: 15.200.1062.1004
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}]}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 5800 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Security Issue: Update your Flash Player Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 23.0.0.207 Flash Player (Linux) Version 11.2. 202.643

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------------ Security Issue: Update your Flash Player '''Note: Windows users''' should download the '''active_x''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the '''plugin only.''' Not the '''active_x.''' Flash Player '''Version: 23.0.0.207''' Flash Player (Linux) '''Version 11.2. 202.643''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. ------------- See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
alan_r 127 solutions 1451 answers

Having both AdBlock Plus and uBlock Origin is not a good idea. They would essentially both be trying to do the same thing at the same time. I would expect Safe Mode to neutralise this conflict but I recommend that you try disabling one, and later removing one.

Having both AdBlock Plus and uBlock Origin is not a good idea. They would essentially both be trying to do the same thing at the same time. I would expect Safe Mode to neutralise this conflict but I recommend that you try disabling one, and later removing one.
alan_r 127 solutions 1451 answers

Response to the two answers?

Response to the two answers?

Helpful Reply

Alright, so I spent the last day or two trying the different solutions and seeing how they work (disabling extensions, run in Safe-mode, updating flash player and checking [my video card's driver's are as a recent as can get] for updates for my video card). The result, while somewhat mixed, all didn't manage to solve the issue.

I noticed no changes when updating my flash-player, or disabling ad-block or U-block (tried running them separately, and using neither, no noticeable difference). Despite already trying Safe Mode earlier, this time it seemed to have a longer effect than before. But after a couple hours of browsing sites, the effect came back.
Alright, so I spent the last day or two trying the different solutions and seeing how they work (disabling extensions, run in Safe-mode, updating flash player and checking [my video card's driver's are as a recent as can get] for updates for my video card). The result, while somewhat mixed, all didn't manage to solve the issue. I noticed no changes when updating my flash-player, or disabling ad-block or U-block (tried running them separately, and using neither, no noticeable difference). Despite already trying Safe Mode earlier, this time it seemed to have a longer effect than before. But after a couple hours of browsing sites, the effect came back.
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

^

I restarted the computer, and entered safe mode (with networking). Opened up a few (3 or 4) windows and a couple tabs between them. Browsed around a bit, seemed fine at the time. Left and came back a hour later, and the halting slow-down had begone anew (with all sites being safe/secure). Despite it just sitting there doing nothing, it still managed to consume up tons of memory.

The CPU cooler was running full throttle, too.

^ I restarted the computer, and entered safe mode (with networking). Opened up a few (3 or 4) windows and a couple tabs between them. Browsed around a bit, seemed fine at the time. Left and came back a hour later, and the halting slow-down had begone anew (with all sites being safe/secure). Despite it just sitting there doing nothing, it still managed to consume up tons of memory. The CPU cooler was running full throttle, too.

Modified by Filler

FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Filler said

Left and came back a hour later, and the halting slow-down had begone anew

Did you shut down and restart the computer, or just leave it running? If restarted, was it a normal start?

''Filler [[#answer-935766|said]]'' <blockquote> Left and came back a hour later, and the halting slow-down had begone anew </blockquote> Did you shut down and restart the computer, or just leave it running? If restarted, was it a normal start?

Question owner

^

I reset the computer using a button that resets it instantly. After this, I spammed the F8 key in the hopes of launching the safe mode menu, only to get impatient with the lack of progress while waiting a few minutes and shutting it down by holding in the power button. At this point I let it reboot and initiated safe mode through the menu.

After I'd rebooted it, I surfed the net and X-outed out of sites that weren't secure. Then I left it for an hour, and when I came back, the slow-down and throttling had returned with a vengeance.

^ I reset the computer using a button that resets it instantly. After this, I spammed the F8 key in the hopes of launching the safe mode menu, only to get impatient with the lack of progress while waiting a few minutes and shutting it down by holding in the power button. At this point I let it reboot and initiated safe mode through the menu. After I'd rebooted it, I surfed the net and X-outed out of sites that weren't secure. Then I left it for an hour, and when I came back, the slow-down and throttling had returned with a vengeance.
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

I called for more help.

I called for more help.

Question owner

^

Thank you.

^ Thank you.

Question owner

Any updates on this? Getting kind of tired with this repeated slow-down.

Any updates on this? Getting kind of tired with this repeated slow-down.
jscher2000
  • Top 10 Contributor
8772 solutions 71718 answers

Has Firefox 50 (currently 50.0.2) made any difference?

Multiprocess (e10s)

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. More and more users are gradually having this multiprocess feature switched on. The performance impact of this can vary a lot between systems: many users find it faster, some find it slower, for many it's neutral. I don't know whether this is relevant to your experience, so let's check.

Are you using e10s?

You can confirm you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Has Firefox 50 (currently 50.0.2) made any difference? '''Multiprocess (e10s)''' One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. More and more users are gradually having this multiprocess feature switched on. The performance impact of this can vary a lot between systems: many users find it faster, some find it slower, for many it's neutral. I don't know whether this is relevant to your experience, so let's check. ''Are you using e10s?'' You can confirm you have this feature turned on as follows. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart'' At your next Firefox startup, it should run in the traditional way. Any difference?

Question owner

^ Though I can't say with absolutely certain, I'd wager the new update (50.0.2) has made it worse; the slow down effect noticeably arrives with less time in-between than before

On a more interesting note, the Multiprocess Windows check displayed this: "0/7 (Disabled by add-ons)". After seeing this, I disabled all my add-ons manually, and refreshed the page (no results). After this, I launched Safe-Mode (no results). Finally, I disabled my theme and returned to the default one. None of this had any effect on the "Disabled by add-ons" message.

So no, I'm not using E10s and am presently unable to do so.

^ Though I can't say with absolutely certain, I'd wager the new update (50.0.2) has made it worse; the slow down effect noticeably arrives with less time in-between than before On a more interesting note, the Multiprocess Windows check displayed this: "0/7 (Disabled by add-ons)". After seeing this, I disabled all my add-ons manually, and refreshed the page (no results). After this, I launched Safe-Mode (no results). Finally, I disabled my theme and returned to the default one. None of this had any effect on the "Disabled by add-ons" message. So no, I'm not using E10s and am presently unable to do so.

Modified by Filler

jscher2000
  • Top 10 Contributor
8772 solutions 71718 answers

Helpful Reply

How's your hard drive? What I mean by that is, Firefox does a lot of disk writing with its cache, session history, and other updates. Disk writes are one of the slowest processes browsers experience. Some users report that Firefox runs faster if they reduce or eliminate caching, or extend the time between session history updates from 15 seconds to 60 seconds.

Perhaps one way to test that is to start Firefox and launch a private window and spend enough time using private browsing to see whether that makes any difference. See: Private Browsing - Use Firefox without saving history.

If you want to override the cache and make it smaller, see: Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox.

How's your hard drive? What I mean by that is, Firefox does a lot of disk writing with its cache, session history, and other updates. Disk writes are one of the slowest processes browsers experience. Some users report that Firefox runs faster if they reduce or eliminate caching, or extend the time between session history updates from 15 seconds to 60 seconds. Perhaps one way to test that is to start Firefox and launch a private window and spend enough time using private browsing to see whether that makes any difference. See: [[Private Browsing - Use Firefox without saving history]]. If you want to override the cache and make it smaller, see: [[Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox]].
sbunter 0 solutions 1 answers

Same problem here, since the last update it runs extremely sluggish in Firefox, have problems typing and very slow. Attached is a snapshot, I have the same pages open in Firefox as Chrome.

Same problem here, since the last update it runs extremely sluggish in Firefox, have problems typing and very slow. Attached is a snapshot, I have the same pages open in Firefox as Chrome.

Modified by sbunter

jscher2000
  • Top 10 Contributor
8772 solutions 71718 answers

Hi sbunter, 2.5 GB of memory use is pretty extreme. Do you spend a lot of time on Facebook or other sites that have "endless scrolling" pages with a lot of embedded media?

If you haven't already, please read through the rest of this thread for things to check and test. If you would like comments tailored to your system and your usage, please start a new question since this is someone else's thread. You can do that here:

https://support.mozilla.org/questions/new/desktop/fix-problems

Scroll down past suggested articles/threads -- if they do not have the solution you need -- to continue with the form. Thanks.

Hi sbunter, 2.5 GB of memory use is pretty extreme. Do you spend a lot of time on Facebook or other sites that have "endless scrolling" pages with a lot of embedded media? If you haven't already, please read through the rest of this thread for things to check and test. If you would like comments tailored to your system and your usage, please start a new question since this is someone else's thread. You can do that here: https://support.mozilla.org/questions/new/desktop/fix-problems Scroll down past suggested articles/threads -- if they do not have the solution you need -- to continue with the form. Thanks.

Question owner

Alright, I did the some testing over the last couple days. Results are null: Once you mentioned my hard drive situation (Firefox is installed on my Solid State Drive), I went and relocated some files on it and moved them to my actual hard drive (being used for less essential programs and data) since eighty-eight percent of it was being used. This actually made a huge difference and eliminated the slow-down effect, though only for a couple days.

After that, I launched a bunch of Private Browser Windows, and surfed around for a bit. The slow-down effect hit less than an hour later. A new record, as it would happen.

Also, Windows 7 Task Manger clocks the Memory Firefox consumes at 2.5 Million K’s (I’m guessing these are kilobytes). At a minimum, once the slow-down effect has kicked in, it’s at least two million.

Alright, I did the some testing over the last couple days. Results are null: Once you mentioned my hard drive situation (Firefox is installed on my Solid State Drive), I went and relocated some files on it and moved them to my actual hard drive (being used for less essential programs and data) since eighty-eight percent of it was being used. This actually made a huge difference and eliminated the slow-down effect, though only for a couple days. After that, I launched a bunch of Private Browser Windows, and surfed around for a bit. The slow-down effect hit less than an hour later. A new record, as it would happen. Also, Windows 7 Task Manger clocks the Memory Firefox consumes at 2.5 Million K’s (I’m guessing these are kilobytes). At a minimum, once the slow-down effect has kicked in, it’s at least two million.

Modified by Filler

jscher2000
  • Top 10 Contributor
8772 solutions 71718 answers

Hi Filler, unless you have dozens of tabs open, it sounds as though Firefox is using an unusual amount of memory for some sites. It's difficult to find a tool that helps diagnose that.

There is an internal page named about:performance (type or paste that in the address bar and press Enter to load it) which is a bit of a resource hog itself but shows tabs using a lot of CPU cycles. But there's not always a correlation between CPU usage and memory footprint.

I saw a reference to the extension Extended Statusbar to see how the size/weight of the page after it loaded, but since pages often pull in more material after loading, this might not answer the question, either: https://addons.mozilla.org/firefox/addon/extended-statusbar/

Hopefully another volunteer has a better suggestion.

Hi Filler, unless you have dozens of tabs open, it sounds as though Firefox is using an unusual amount of memory for some sites. It's difficult to find a tool that helps diagnose that. There is an internal page named '''about:performance''' (type or paste that in the address bar and press Enter to load it) which is a bit of a resource hog itself but shows tabs using a lot of CPU cycles. But there's not always a correlation between CPU usage and memory footprint. I saw a reference to the extension Extended Statusbar to see how the size/weight of the page after it loaded, but since pages often pull in more material after loading, this might not answer the question, either: https://addons.mozilla.org/firefox/addon/extended-statusbar/ Hopefully another volunteer has a better suggestion.