Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

dropdown

  • 3 replies
  • 4 have this problem
  • 325 views
  • Last reply by XziizX

more options

My dropdown menu does not display as it should, the "refresh firefox" solves the problem but after a boot of my PC or restarting FF the problem comes back. I'll provide a print screen with 4 pictures the 2 first on top is FF when the dropdown not working, the 2 others from Edge and how it should be displayed.

I also tried to unmark "use hardware acceleration when available" and restart of the browser, but thats not helping me either.

Attached screenshots

Chosen solution

Is this your site? The following isn't something webmasters can fix, unfortunately:

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

With e10s active, the "options" that display in the drop-down below a select control may be rendered using a default font instead of the one assigned by the page. However, I haven't seen enough examples to know the pattern of what font is used.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

What I think is happening:

When you first install or after you refresh Firefox, it starts up traditionally and then performs a check to see whether it can use the new e10s feature starting with the next startup. That's why you see the change when you see it.

Read this answer in context 👍 1

All Replies (3)

more options

hi, i think you are seeing an unintentional byproduct of the new firefox multiprocess architecture being enabled for more users on firefox release - this issue is tracked in bug 910022...

more options

Chosen Solution

Is this your site? The following isn't something webmasters can fix, unfortunately:

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

With e10s active, the "options" that display in the drop-down below a select control may be rendered using a default font instead of the one assigned by the page. However, I haven't seen enough examples to know the pattern of what font is used.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

What I think is happening:

When you first install or after you refresh Firefox, it starts up traditionally and then performs a check to see whether it can use the new e10s feature starting with the next startup. That's why you see the change when you see it.

more options

Thank you jscher2000, did as you explained and it worked out fine :)