X
Tap here to go to the mobile version of the site.

Support Forum

Firefox goes non-responsive, lags, wont let me search or go to websites just constantly loads. Safe mode fixed it but i cant figure out why.

Posted

Details all in question, I load it up it freezes and says non-responsive for a bit then rights itself, I tr to type it goes non responsive again, I try to open the options area, not responsive. If i use the adress bar for a search, it just sits there and loads, if i use a bookmark or something the furthest it gets is saying the website name on the tab while constantly loading.

I loaded it in safe mode, worked perfectly but I kinda need some of those add-on's.

I updated the ones out of date. Java deployment toolkit was there and it said it was vulnerable so i set it to never activate, that didn't fix it.

I currently have: Extensions AdBlock Plus Avast online security Avast safe price (disabled) Grammarly for firefox

Appearance: Default

Plugins: OpenH264 video codec provided by cisco systems inc. (Always active) Primetime content decryption Module provided by Adobe Systems Incorperated (Always active) Shockwave Flash (Always active) VLC Web Plugin (Always active) Widevine Content Decryption Module Provided by Google inc (Always Active) Adobe Acrobat (Ask to activate) Java(TM) Platform SE 8 U101 (Ask to activate) Nvidia 3D Vision (Ask to activate) WacomTabletPlugin (Ask to activate) Java Deployment toolkit 8.0.1010.13 (set to never activate)

Services: None

(ps) I'm posting this on a different computer then the one with issues but i have changed the version and such to match properly)

Details all in question, I load it up it freezes and says non-responsive for a bit then rights itself, I tr to type it goes non responsive again, I try to open the options area, not responsive. If i use the adress bar for a search, it just sits there and loads, if i use a bookmark or something the furthest it gets is saying the website name on the tab while constantly loading. I loaded it in safe mode, worked perfectly but I kinda need some of those add-on's. I updated the ones out of date. Java deployment toolkit was there and it said it was vulnerable so i set it to never activate, that didn't fix it. I currently have: Extensions AdBlock Plus Avast online security Avast safe price (disabled) Grammarly for firefox Appearance: Default Plugins: OpenH264 video codec provided by cisco systems inc. (Always active) Primetime content decryption Module provided by Adobe Systems Incorperated (Always active) Shockwave Flash (Always active) VLC Web Plugin (Always active) Widevine Content Decryption Module Provided by Google inc (Always Active) Adobe Acrobat (Ask to activate) Java(TM) Platform SE 8 U101 (Ask to activate) Nvidia 3D Vision (Ask to activate) WacomTabletPlugin (Ask to activate) Java Deployment toolkit 8.0.1010.13 (set to never activate) Services: None (ps) I'm posting this on a different computer then the one with issues but i have changed the version and such to match properly)

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
4334 solutions 60966 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Question owner

Disabled everything, problem persists sir. no change at all from what i can tell.

Disabled everything, problem persists sir. no change at all from what i can tell.
FredMcD
  • Top 10 Contributor
4334 solutions 60966 answers

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.
svobrps 0 solutions 1 answers

Same problems, becoming worse with each new vs. Waste more time on non-responsive screens and script problems. Moving to Chrome or Opera at least they work 100% of the time and I don't loose lots of time waiting to screen to become responsive or to logout and then start over again. Sorry to see Firefox go downhill in the past year or so.

Same problems, becoming worse with each new vs. Waste more time on non-responsive screens and script problems. Moving to Chrome or Opera at least they work 100% of the time and I don't loose lots of time waiting to screen to become responsive or to logout and then start over again. Sorry to see Firefox go downhill in the past year or so.
FredMcD
  • Top 10 Contributor
4334 solutions 60966 answers

svobrps have you tried the above?

'''svobrps''' have you tried the above?