Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does my theme disappear from any tab except the customization tab?

more options

I had previously added the Firefox theme "Framed Chuckanut Sunset" and it had worked fine for at least a year. After a crash, I lost this theme, but when I re-added it, the theme no longer appeared above the address bar like it used to, but only within that bar, with one exception: The theme appears correctly _only_ on the Customize Firefox tab. This detail is simpler to see in the attached screen shots than to describe. All shots taken during the same session.

I've already tried turning off hardware acceleration, resetting, and safe mode, to no avail.

Attached screenshots

Chosen solution

As an experiment, try disabling OMTC. This feature was added in Firefox 33, but seemed to be acting up with Nvidia cards in Firefox 48 for some users. I think of this as only affecting the content area, but who knows?

(0) Select and copy the following new preference name:

layers.offmainthreadcomposition.force-disabled

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers.off and pause while the list is filtered

(3) Right-click a blank area of the page, click New, then Boolean

(4) Paste the preference name, then click OK

(5) Select true, then click OK

The preference should appear in the list, bolded, and user set to true. If you need to remove this later, right-click > Reset it

I think you probably need to restart Firefox before that takes effect. Any difference??

Read this answer in context 👍 1

All Replies (9)

more options

Your whole top bar looks odd to me -- where are the usual three buttons that appear on the right side (minimize, restore/maximize, close)? Did those disappear around the same time this problem started?

more options

Good catch jscher2k. I hadn't noticed that yet, but those must have disappeared at the same time since I often use them. I just checked, and the buttons apparently are there but hidden: The screen tips pop up when I hover where the buttons should appear, and if I click where "X" should be Firefox asks me whether I really want to close multiple tabs.

more options

From now on every time I see my esteemed fellow-contributor's name   (jscher2000)   I'll immediately think:   '2k'   ......

more options

Does your Windows 7 have an unusual theme? Is this problem only in Firefox?

more options

If you mean my Win7 desktop, it's just a slideshow of jpegs, but yes, Win7 sometimes forgets it when _it_ crashes and just shows the first one, but in that case I can re-customize it.

By the way, the close-button showed up. I then tried to restore down and maximize to see if that would make that button re-appear too, but no, instead the close button disappeared.

I should mention I have been having some unresolved trouble with my monitor not being recognized on boot; that might, might be due to the monitor itself.

Modified by Basil_Fawlty

more options

I'm baffled. In looking at your original system information, it seems hardware acceleration is disabled. Do you know whether there are any updates for your Intel graphics in case that helps? This article suggest safe ways to check on that: Upgrade your graphics drivers to use hardware acceleration and WebGL.

more options

Before this all occurred, when I was merely having the monitor-recognition problem, I updated the graphics card (nvidea quadro 4000 on PCIe) that my monitor is plugged into. I did not find a pertinent update for the onboard Intel graphics (asrock z77 extreme4 board), but didn't think it mattered so I will look again. That link you provided is what led me to disable acceleration in Firefox; I've since re-enabled; made no difference.

Noticed another odd but intermittent behavior: if I open a new tab, and go to a new site, [site name-Mozilla Firefox] _sometimes_ appears where the menu bar should be. If I then hover over that area, each part of the menu bar appears and the [site name-Mozilla Firefox] disappears as I pass over, unless the site name is longer, in which the excess persists until I dismiss it by unchecking and re-checking the menu-bar option in the context menu. Same row of page as the three missing buttons. No obvious pattern to when this happens, or I'd include a screen shot. Baffled, you say? Me too.

more options

Chosen Solution

As an experiment, try disabling OMTC. This feature was added in Firefox 33, but seemed to be acting up with Nvidia cards in Firefox 48 for some users. I think of this as only affecting the content area, but who knows?

(0) Select and copy the following new preference name:

layers.offmainthreadcomposition.force-disabled

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers.off and pause while the list is filtered

(3) Right-click a blank area of the page, click New, then Boolean

(4) Paste the preference name, then click OK

(5) Select true, then click OK

The preference should appear in the list, bolded, and user set to true. If you need to remove this later, right-click > Reset it

I think you probably need to restart Firefox before that takes effect. Any difference??

more options

Okay, did that and restarted Firefox - no difference. But then I rebooted, and now it works, yaaay! Thank you.