Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

when i open a new tab it is over and over again my home page - I cannot get my multiple tab page to open

  • 3 replies
  • 1 has this problem
  • 11 views
  • Last reply by Scribe

more options

My home page opens with every new tab I open. I can get a blank page first but then all the others are my home page. I want my page of favorites or frequently used to open and it will not and can find no place to tell it to in my preferences. What to do!

All Replies (3)

more options

You have two extensions installed that may be affected your New Tab Page setting.

This extension - New Tab by Yahoo - is disabled but it may still be affecting your New Tab page. https://addons.mozilla.org/en-US/firefox/addon/new-tab-by-yahoo/ Check the User Reviews for that extension.

Or maybe this one - Yahoo Homepage 1.0.8 - has things messed up?

more options

every new tab only will open My Yahoo - I get no favorite page - I only get one page - Yahoo!

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!