X
Tap here to go to the mobile version of the site.

Support Forum

How can I suppress web push requests for all websites?

Posted

I would like to specify that I never want to be asked to allow web push access. Web push is disruptive as is the request to allow it! I have currently given not websites push permission and I never will! I want the popup request for web push permission to be suppressed and the request denied or ignored!

I would like to specify that I never want to be asked to allow web push access. Web push is disruptive as is the request to allow it! I have currently given not websites push permission and I never will! I want the popup request for web push permission to be suppressed and the request denied or ignored!

Chosen solution

Hi   !
Let's see if we can help you get rid off this annoying problem:

  • Go to   about:config
  • Look for:   dom.webnotifications.enabled

and set it's value to   'false'.
This will completely disable push notifications and Firefox won't ask your permission again.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • MediaPlguin-v-3.3.1.266589
  • Shockwave Flash 23.0 r0
  • 5.1.50709.0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

Happy112 561 solutions 5694 answers

Chosen Solution

Hi   !
Let's see if we can help you get rid off this annoying problem:

  • Go to   about:config
  • Look for:   dom.webnotifications.enabled

and set it's value to   'false'.
This will completely disable push notifications and Firefox won't ask your permission again.

Hi &nbsp; !<BR> Let's see if we can help you get rid off this annoying problem:<BR> * Go to &nbsp; '''about:config''' * Look for: &nbsp; '''dom.webnotifications.enabled''' and set it's value to &nbsp; 'false'.<BR> This will completely disable push notifications and Firefox won't ask your permission again.
jscher2000
  • Top 10 Contributor
7869 solutions 64155 answers

As a footnote, this post has background on the different settings for regular desktop notifications -- which only appear while a site is open -- and web push notifications -- which can appear after you close a site:

https://support.mozilla.org/questions/1140700#answer-921090

As a footnote, this post has background on the different settings for regular desktop notifications -- which only appear while a site is open -- and web push notifications -- which can appear after you close a site: https://support.mozilla.org/questions/1140700#answer-921090
mr.msb 0 solutions 21 answers

I am running Linux Mint 17.3. For one website I receive the 'permission to allow this site to send me push notifications' drop down dialog box. I do not want any push notifications, and I do not want to have to click 'not now' each time I go to this web site. How can I tweak LM 17.3 Mozilla 49.0.2 ?

I am running Linux Mint 17.3. For one website I receive the 'permission to allow this site to send me push notifications' drop down dialog box. I do not want any push notifications, and I do not want to have to click 'not now' each time I go to this web site. How can I tweak LM 17.3 Mozilla 49.0.2 ?

Modified by mr.msb

jscher2000
  • Top 10 Contributor
7869 solutions 64155 answers

Hi mr.msb, there is a little triangle next to the button on the permission panel that gives the option to permanently refuse notifications from the site. Or try one of the methods in this thread: https://support.mozilla.org/questions/1148178

Added screenshot

Hi mr.msb, there is a little triangle next to the button on the permission panel that gives the option to permanently refuse notifications from the site. Or try one of the methods in this thread: https://support.mozilla.org/questions/1148178 ''Added screenshot''

Modified by jscher2000