X
Tap here to go to the mobile version of the site.

Support Forum

how to turn off HTML5 autoplay

Posted

Just want to know how to turn off HTML5 autoplay videos. Also need to know how to allow them when wanted just as Firefox now does with Adobe Flash.

Thanks!

Just want to know how to turn off HTML5 autoplay videos. Also need to know how to allow them when wanted just as Firefox now does with Adobe Flash. Thanks!

Chosen solution

Video can be played using either:

  • built-in HTML5 video player (for example, on YouTube)
  • a plugin such as Flash (I think you already have this set, but just in case)

The HTML5 Player

Firefox has an internal setting to stop videos from autoplaying. This sometimes leads to the strange appearance of a pause button on a stopped video. In that case, to play the video, click the pause button then click the play button. Here's where you set this feature:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch the value from true to false

Some users are looking for something a bit different which is for tabs opened in the background not to start autoplaying until you activate them. There's another preference for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste visible and pause while the list is filtered

(3) Double-click the media.block-play-until-visible preference to switch the value from false to true

Note: it doesn't turn off automatically when you switch away from the tab.

Plugin players

Try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

If you want finer control: This extension addresses the issue of only wanting some videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it myself)

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • Coupons, Inc. Coupon Printer 5.0.2.8
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 23.0 r0
  • 5.1.50709.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

jscher2000
  • Top 10 Contributor
7867 solutions 64110 answers

Chosen Solution

Video can be played using either:

  • built-in HTML5 video player (for example, on YouTube)
  • a plugin such as Flash (I think you already have this set, but just in case)

The HTML5 Player

Firefox has an internal setting to stop videos from autoplaying. This sometimes leads to the strange appearance of a pause button on a stopped video. In that case, to play the video, click the pause button then click the play button. Here's where you set this feature:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch the value from true to false

Some users are looking for something a bit different which is for tabs opened in the background not to start autoplaying until you activate them. There's another preference for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste visible and pause while the list is filtered

(3) Double-click the media.block-play-until-visible preference to switch the value from false to true

Note: it doesn't turn off automatically when you switch away from the tab.

Plugin players

Try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

If you want finer control: This extension addresses the issue of only wanting some videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it myself)

Video can be played using either: * built-in HTML5 video player (for example, on YouTube) * a plugin such as Flash (I think you already have this set, but just in case) '''''The HTML5 Player''''' Firefox has an internal setting to stop videos from autoplaying. This sometimes leads to the strange appearance of a pause button on a stopped video. In that case, to play the video, click the pause button then click the play button. Here's where you set this feature: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch the value from true to false Some users are looking for something a bit different which is for tabs opened in the background not to start autoplaying until you activate them. There's another preference for that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''visible''' and pause while the list is filtered (3) Double-click the '''media.block-play-until-visible''' preference to switch the value from false to true Note: it doesn't turn off automatically when you switch away from the tab. '''''Plugin players''''' Try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. Open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. ''If you want finer control:'' This extension addresses the issue of only wanting ''some'' videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it myself)

Modified by jscher2000

Question owner

Worked. Thanks jscher2000. Very through answer that will help me and others.

Best wishes.

Rich

Worked. Thanks jscher2000. Very through answer that will help me and others. Best wishes. Rich