Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

in content-how do i make "do not disturb me" fixed

  • 3 replies
  • 3 have this problem
  • 914 views
  • Last reply by Happy112

more options

at the next restart of foxfire it resets.

Chosen solution

I think you are referring to desktop notifications from websites.

By way of background: regular notifications end when you close the last tab for a site. Web push notifications keep a connection to the site in the background so you can get notifications even after the last tab for the site is closed (until you exit Firefox).

Site-Specific Permissions/Blocks

While viewing the problem site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Does that work for you?

Read this answer in context 👍 0

All Replies (3)

more options

Please explain the problem in detail.

more options

Chosen Solution

I think you are referring to desktop notifications from websites.

By way of background: regular notifications end when you close the last tab for a site. Web push notifications keep a connection to the site in the background so you can get notifications even after the last tab for the site is closed (until you exit Firefox).

Site-Specific Permissions/Blocks

While viewing the problem site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Does that work for you?

more options

Hi   ! Jscher2000's   reply should fix your problem,   but just in case:
While in   'Content',  in addition to checking the   'do not disturb'-button,   you will undoubtedly have clicked   'more info',   which took you to the article   'Web Push notifications in Firefox' :     http://mzl.la/20jwSoU