X
Tap here to go to the mobile version of the site.

Support Forum

disable web notifications

Posted

On a forum website, every thread pops up a notice from Firefox asking if I want update notifications. The option "NOT NOW" is the only option and it does not work. I click another thread and it pops up again. I want an option of "NOT NOW, NOT EVER". I looked for a way to disable this pop up, so I clicked the link that says Learn More. That link tells me how to turn off Web Push Notifications. None of those options work. The small i icon > control panel does not give me the option to Allow or Block as the website claims. Going into Firefox Options settings, and Remove Site, Remove All Sites are grayed out. There are no sites listed, and no way to add any to a Block List. User comments on the Firefox "Learn More" webpage indicate that this is not a Web Push Notification. So what is it and how do I permanently turn it off. It is very annoying popping up on every thread on the same website, whether I tell it NOT NOW or ignore it.

On a forum website, every thread pops up a notice from Firefox asking if I want update notifications. The option "NOT NOW" is the only option and it does not work. I click another thread and it pops up again. I want an option of "NOT NOW, NOT EVER". I looked for a way to disable this pop up, so I clicked the link that says Learn More. That link tells me how to turn off Web Push Notifications. None of those options work. The small i icon > control panel does not give me the option to Allow or Block as the website claims. Going into Firefox Options settings, and Remove Site, Remove All Sites are grayed out. There are no sites listed, and no way to add any to a Block List. User comments on the Firefox "Learn More" webpage indicate that this is not a Web Push Notification. So what is it and how do I permanently turn it off. It is very annoying popping up on every thread on the same website, whether I tell it NOT NOW or ignore it.

Chosen solution

Hmm, normally you should have all of the options, as shown in the attached screenshot.

While viewing the forum site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Does this method work any better?

Note: This permission is part of a category of data called Site Preferences. If you have Firefox set to clear your history at shutdown, that feature has a checkbox for whether to clear the Site Preferences along with the other data. Don't clear the site preferences or Firefox will forget your setting.


Are you using automatic private browsing? That would have been set up on the Options page, Privacy panel, by setting Firefox to "Never remember history" or checking the box for "Always use private browsing mode". Fully private sessions sometimes have different behaviors than regular sessions.

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 23.0 r0
  • VLC media player Web Plugin

Application

  • Firefox 49.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.1/WINNT/en-US/

Extensions

  • Ghostery 7.0.1.4 (firefox@ghostery.com)
  • High Definition Video 1.0.3.1.1-signed.1-signed (hdv@vovcacik.addons.mozilla.org)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 750 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1380
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_674733509ab83d72\nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 37513842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400 ]
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.0
  • driverDate: 9-16-2016
  • driverDate2:
  • driverVersion: 21.21.13.7290
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 750 Ti Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

Here are the screenshots.

Here are the screenshots.
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Chosen Solution

Hmm, normally you should have all of the options, as shown in the attached screenshot.

While viewing the forum site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Does this method work any better?

Note: This permission is part of a category of data called Site Preferences. If you have Firefox set to clear your history at shutdown, that feature has a checkbox for whether to clear the Site Preferences along with the other data. Don't clear the site preferences or Firefox will forget your setting.


Are you using automatic private browsing? That would have been set up on the Options page, Privacy panel, by setting Firefox to "Never remember history" or checking the box for "Always use private browsing mode". Fully private sessions sometimes have different behaviors than regular sessions.

Hmm, normally you should have all of the options, as shown in the attached screenshot. While viewing the forum site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either: * right-click a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. ''Does this method work any better?'' Note: This permission is part of a category of data called Site Preferences. If you have Firefox set to clear your history at shutdown, that feature has a checkbox for whether to clear the Site Preferences along with the other data. Don't clear the site preferences or Firefox will forget your setting. ---- Are you using automatic private browsing? That would have been set up on the Options page, Privacy panel, by setting Firefox to "Never remember history" or checking the box for "Always use private browsing mode". Fully private sessions sometimes have different behaviors than regular sessions.
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Helpful Reply

Regular notifications end when you close the last tab for a site. Web push notifications keep a connection to the site in the background so you can get notifications even after the last tab for the site is closed (until you exit Firefox).

If the site-by-site management isn't working, perhaps you would prefer to turn off notifications:

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

All-Site Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Does that work for you?

Regular notifications end when you close the last tab for a site. Web push notifications keep a connection to the site in the background so you can get notifications even after the last tab for the site is closed (until you exit Firefox). If the site-by-site management isn't working, perhaps you would prefer to turn off notifications: '''''Session Do Not Disturb''''' To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either: * Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content * Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content * Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content * Anyone: Type or paste '''about:preferences#content''' in the address bar and press Enter/Return (you can bookmark this for faster future access) On the right side, under "Notifications", check the "Do not disturb me" box. '''''All-Site Disable''''' There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webno''' and pause while the list is filtered (3) To disable PUSH NOTIFICATIONS, double-click the '''dom.webnotifications.serviceworker.enabled''' preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site (4) To disable ALL NOTIFICATIONS, double-click the '''dom.webnotifications.enabled''' preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites Does that work for you?

Question owner

jscher2000 said

Hmm, normally you should have all of the options, as shown in the attached screenshot. While viewing the forum site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:
  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions
Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. Does this method work any better?

This did it. Thank you, jscher2000!

''jscher2000 [[#answer-921087|said]]'' <blockquote> Hmm, normally you should have all of the options, as shown in the attached screenshot. While viewing the forum site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either: * right-click a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. ''Does this method work any better?'' </blockquote> This did it. Thank you, jscher2000!
Happy112
  • Top 10 Contributor
562 solutions 5694 answers

lwsugden said

This did it. Thank you, jscher2000!

Hi   !

Good to know that your problem is solved  !
Would you be a dear and mark   'jscher2000's'  answer as   Chosen Solution,   so others will know and might benefit from it   ?

Thank you   !

''lwsugden [[#answer-921141|said]]'' <blockquote> This did it. Thank you, jscher2000! </blockquote> Hi &nbsp; !<BR> Good to know that your problem is solved&nbsp; !<BR> Would you be a dear and mark &nbsp; 'jscher2000's'&nbsp; answer as &nbsp; '''Chosen Solution''', &nbsp; so others will know and might benefit from it &nbsp; ?<BR> Thank you &nbsp; !
status1 0 solutions 7 answers

None of these things work or stop the notifications permanently Both of those notifications links you mentioned are set to false and I am still getting the notifications The only thing that works is the "do not disturb" but that is only for the current session As soon as I restart firefox the box resets so I start getting the notifications I have my privacy set to clear history when firefox closes but the site preferences box is not checked

Is there a permanent solution to turn the notifications off and stay off even after I restart Firedox
None of these things work or stop the notifications permanently Both of those notifications links you mentioned are set to false and I am still getting the notifications The only thing that works is the "do not disturb" but that is only for the current session As soon as I restart firefox the box resets so I start getting the notifications I have my privacy set to clear history when firefox closes but the site preferences box is not checked Is there a permanent solution to turn the notifications off and stay off even after I restart Firedox
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Hi status1, about two months after the above was written, we discovered that Firefox may display the notification permission for a different kind of request from a site: permission to provide background updates for previously visited pages without a visible notification. That's a little confusing!

This is a copy/paste of the info from that thread:

I realize this is more than you asked for, but since there are several related kinds of notifications and settings, I'm pasting in a detailed summary.

Websites can ask you to accept several different kinds of communications and updates:

  • Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site.
  • Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox).
  • Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing.

Site-Specific Permissions/Blocks

If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Hopefully that gives you a technique for managing notifications to fit your needs.

Background updates can be totally blocked with the preference dom.push.enabled but that may block actually useful services from sites you trust, so I don't recommend it at this point.


Troubleshooting: Site-Specific Permissions Are Forgotten?

Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page.

If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.

Hi status1, about two months after the above was written, we discovered that Firefox may display the notification permission for a different kind of request from a site: permission to provide background updates for previously visited pages ''without'' a visible notification. That's a little confusing! This is a copy/paste of the info from that thread: I realize this is more than you asked for, but since there are several related kinds of notifications and settings, I'm pasting in a detailed summary. Websites can ask you to accept several different kinds of communications and updates: * '''Desktop notifications''' - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site. * '''Web push notifications''' - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen ''even after'' the last tab for the site is closed (until you exit Firefox). * '''Web push updates''' - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing. '''''Site-Specific Permissions/Blocks''''' If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either: * right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. '''''Session Do Not Disturb''''' To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either: * Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content * Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content * Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content * Anyone: Type or paste '''about:preferences#content''' in the address bar and press Enter/Return (you can bookmark this for faster future access) On the right side, under "Notifications", check the "Do not disturb me" box. '''''All-Site Persistent Disable''''' There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webno''' and pause while the list is filtered (3) To disable PUSH NOTIFICATIONS, double-click the '''dom.webnotifications.serviceworker.enabled''' preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site (4) To disable ALL NOTIFICATIONS, double-click the '''dom.webnotifications.enabled''' preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites Hopefully that gives you a technique for managing notifications to fit your needs. '''Background updates''' can be totally blocked with the preference '''dom.push.enabled''' but that may block actually useful services from sites you trust, so I don't recommend it at this point. ---- '''''Troubleshooting: Site-Specific Permissions Are Forgotten?''''' Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page. If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.
status1 0 solutions 7 answers

Hello, As I mentioned I have the "site preferences" not checked but I also don't have any site specific permissions and the "do not disturb" box will always reset when I turn off Firefox I even set the privacy to remember history and the "do not disturb " box still resets

All I want is for the "do not disturb" box to stay checked at all times even if I restart Firefox I want the "do not disturb' box to do exactly what it says permanently not just for the current session I don't want any notifications EVER I attached the offending notification in case that helps

Does the privacy setting have any effect on the "do not disturb" box which is in the content section ?

Hello, As I mentioned I have the "site preferences" not checked but I also don't have any site specific permissions and the "do not disturb" box will always reset when I turn off Firefox I even set the privacy to remember history and the "do not disturb " box still resets All I want is for the "do not disturb" box to stay checked at all times even if I restart Firefox I want the "do not disturb' box to do exactly what it says permanently not just for the current session I don't want any notifications EVER I attached the offending notification in case that helps Does the privacy setting have any effect on the "do not disturb" box which is in the content section ?
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Hi status1, that screenshot does not look like Firefox's built-in permission panel. I think it's something generated by a script on that website. What's the URL?

Regarding --

All I want is for the "do not disturb" box to stay checked at all times even if I restart Firefox

-- I'm not aware of any easy way to do that because unlike many other checkboxes, it doesn't change a preference in about:config. You would need an add-on for that.

Unless you want the option to uncheck the checkbox to get alerts, why not make the settings changes I outlined earlier under "All-Site Persistent Disable"?

Hi status1, that screenshot does not look like Firefox's built-in permission panel. I think it's something generated by a script on that website. What's the URL? Regarding -- <blockquote>All I want is for the "do not disturb" box to stay checked at all times even if I restart Firefox</blockquote> -- I'm not aware of any easy way to do that because unlike many other checkboxes, it doesn't change a preference in about:config. You would need an add-on for that. Unless you want the option to uncheck the checkbox to get alerts, why not make the settings changes I outlined earlier under "All-Site Persistent Disable"?
status1 0 solutions 7 answers

Hello, Here is the URL for that website https://forums.capitaldiscussions.com/

I pasted that same URL into Explorer and I am not having the notifications pop up at all so I am not sure why that same script would not generate the same problem in Explorer as it does in Firefox

The settings you mentioned for the all site persistent is that just for that session or is that a permanent setting  ?

Hello, Here is the URL for that website https://forums.capitaldiscussions.com/ I pasted that same URL into Explorer and I am not having the notifications pop up at all so I am not sure why that same script would not generate the same problem in Explorer as it does in Firefox The settings you mentioned for the all site persistent is that just for that session or is that a permanent setting ?
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

status1 said

https://forums.capitaldiscussions.com/

The first dialog seems to be a pre-permission request generated by a script in the site. (Screen shot.) I don't know whether changing Firefox preferences will stop that pre-permission dialog.

I pasted that same URL into Explorer and I am not having the notifications pop up at all so I am not sure why that same script would not generate the same problem in Explorer as it does in Firefox

Does IE support push notifications? Maybe they don't even bother trying in IE. Or maybe they don't need permission.

The settings you mentioned for the all site persistent is that just for that session or is that a permanent setting  ?

Permanent.

''status1 [[#answer-947386|said]]'' <blockquote> https://forums.capitaldiscussions.com/ </blockquote> The first dialog seems to be a pre-permission request generated by a script in the site. (Screen shot.) I don't know whether changing Firefox preferences will stop that pre-permission dialog. <blockquote>I pasted that same URL into Explorer and I am not having the notifications pop up at all so I am not sure why that same script would not generate the same problem in Explorer as it does in Firefox </blockquote> Does IE support push notifications? Maybe they don't even bother trying in IE. Or maybe they don't need permission. <blockquote>The settings you mentioned for the all site persistent is that just for that session or is that a permanent setting ? </blockquote> Permanent.
status1 0 solutions 7 answers

Well whatever it is the Explorer does not have this issue so I am not sure why Firefox is even bothering with this

The more annoying part is that it doesn't matter whether I allow it or not because it pops up again when I click on another thread in the forum so whether it's pre permission or not it's not responding to either choice of allow or not allow

So do you think this site persistent setting is going to work on this pre permission request ? Could you tell me again how to set up this site persistent setting so I can try it out ?

Well whatever it is the Explorer does not have this issue so I am not sure why Firefox is even bothering with this The more annoying part is that it doesn't matter whether I allow it or not because it pops up again when I click on another thread in the forum so whether it's pre permission or not it's not responding to either choice of allow or not allow So do you think this site persistent setting is going to work on this pre permission request ? Could you tell me again how to set up this site persistent setting so I can try it out ?
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

If you click the Don't Allow button, the page sets a cookie which should prevent the pre-permission dialog from appearing again. That seems not to be working on your Firefox for some reason.

Possibly an ad blocker could resolve this. You might try uBlock Origin with the hope that PushCrew is already on its block list. If not, there likely is a way to block it, or at least to hide the dialog.

If you click the Don't Allow button, the page sets a cookie which should prevent the pre-permission dialog from appearing again. That seems not to be working on your Firefox for some reason. Possibly an ad blocker could resolve this. You might try [https://addons.mozilla.org/firefox/addon/ublock-origin/ uBlock Origin] with the hope that PushCrew is already on its block list. If not, there likely is a way to block it, or at least to hide the dialog.
status1 0 solutions 7 answers

Thanks that finally worked

The reason it did not work before was because I had Firefox delete all history when I close it which included the cookies But now that I changed it to remember history it works If I knew this was based on cookies I probably would have realized this earlier


Is it possible to delete history when closing Firefox and make an exception or somehow keep this one cookie from getting deleted ?

Thanks that finally worked The reason it did not work before was because I had Firefox delete all history when I close it which included the cookies But now that I changed it to remember history it works If I knew this was based on cookies I probably would have realized this earlier Is it possible to delete history when closing Firefox and make an exception or somehow keep this one cookie from getting deleted ?
status1 0 solutions 7 answers

Quick update I found a better and easier solution After playing with the different privacy settings I found that if I set it to "Always use private browsing mode" it works Since it's not storing any cookies there is no need to block them and there is no need to delete browsing history when closing Firefox since no browsing history is stored Thanks for your help

Quick update I found a better and easier solution After playing with the different privacy settings I found that if I set it to "Always use private browsing mode" it works Since it's not storing any cookies there is no need to block them and there is no need to delete browsing history when closing Firefox since no browsing history is stored Thanks for your help
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Hi status1, just as a footnote, this part is not quite right --

Since it's not storing any cookies there is no need to block them and there is no need to delete browsing history when closing Firefox since no browsing history is stored

In a private window, Firefox accepts cookies for the duration of the private session only. They are in a separate "cookie jar" from regular windows. The private session lasts until you close ALL private windows, and then the cookies (and history) are dumped.

Hi status1, just as a footnote, this part is not quite right -- <blockquote> Since it's not storing any cookies there is no need to block them and there is no need to delete browsing history when closing Firefox since no browsing history is stored</blockquote> In a private window, Firefox accepts cookies for the duration of the private session only. They are in a separate "cookie jar" from regular windows. The private session lasts until you close ALL private windows, and then the cookies (and history) are dumped.