Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

New spinning loading icon when a page in a new tab is loading in the background after updating to 49.0

more options

I just updated to 49.0

When I typed "googlemail.com" into a tab and hit enter, then immediately switch to another tab to load something or browse something else - I waited for the "googlemail.com" tab to finish loading and then clicked back on it - the page showed a small spinning loading icon in the middle of the page before all the content appeared

Does this have any impact on page loading performance?

I checked the release notes and had a quick look through my FF settings and about:config but I couldn't find any way to disable this

Attached screenshots

Chosen solution

It sounds like your browser was a candidate to qualify for the new Electrolysis project (e10s). This feature is new and supposed to improve performance and security.

To see if e10s is enabled on your system, open the about:support page on Firefox. if the Multiprocess Windows section is higher than 0, then e10s is on your system.

Of course, if you feel that it is impacting performance or simply wish not to use this feature, you can opt out. To do so, go to the Firefox option page and uncheck the Enable Multi-process option.

Alternatively, you can enter about:config in the Firefox address bar and change the value of the browser.tabs.remote.autostart boolean to false.

Please let us know if this fixes the issue.

Read this answer in context 👍 6

All Replies (4)

more options

Chosen Solution

It sounds like your browser was a candidate to qualify for the new Electrolysis project (e10s). This feature is new and supposed to improve performance and security.

To see if e10s is enabled on your system, open the about:support page on Firefox. if the Multiprocess Windows section is higher than 0, then e10s is on your system.

Of course, if you feel that it is impacting performance or simply wish not to use this feature, you can opt out. To do so, go to the Firefox option page and uncheck the Enable Multi-process option.

Alternatively, you can enter about:config in the Firefox address bar and change the value of the browser.tabs.remote.autostart boolean to false.

Please let us know if this fixes the issue.

more options

I set it to false an it loads quicker now, no more loading icon

Thanks!

more options

Oh and just to note, I had to disable this via about:config as I couldn't find the Enable Multi-process option

more options

MyPCHatesMe said

Oh and just to note, I had to disable this via about:config as I couldn't find the Enable Multi-process option

Yes, I was mistaken. There is not an option in the Firefox options yet because this feature has not yet reached every user.

Nevertheless, glad to hear that the issue is solved. Thanks for contacting the Mozilla support team.