Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to change background color of a site opening in a tab

  • 4 replies
  • 4 have this problem
  • 3934 views
  • Last reply by Daniel

more options

So, whenever I click a link that will open in a new tab, the whole firefox background will flash in bright white color for a second until the page is loading. How can I change this background color?

Chosen solution

The above style rule covers the time before Firefox starts painting the default page background color (or the page's own background color). To soften that a bit you could change the default page background from pure white to light gray:

(0) Select and copy the following color value:

#F8F8F8

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste color and pause while the list is filtered

(3) Double-click the browser.display.background_color preference, delete the existing value, and paste the value for light gray

This color will show on pages that do not specify a background color, such as

https://www.jeffersonscher.com/res/jstest.php

Read this answer in context 👍 2

All Replies (4)

more options

It's simplest to use an add-on or custom style rule.

For example, I use this rule, which replaces the white background behind the page with a slate bluegray color:

@-moz-document url(chrome://browser/content/browser.xul) {
  browser[type="content-primary"] {background: #778899 !important}
}

To install that rule (or another custom style rule) into Firefox, you can use either:

more options

It doesn't work, I added "5CACEE" instead of that number (in the window where that code already was), but still white background...

more options

Chosen Solution

The above style rule covers the time before Firefox starts painting the default page background color (or the page's own background color). To soften that a bit you could change the default page background from pure white to light gray:

(0) Select and copy the following color value:

#F8F8F8

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste color and pause while the list is filtered

(3) Double-click the browser.display.background_color preference, delete the existing value, and paste the value for light gray

This color will show on pages that do not specify a background color, such as

https://www.jeffersonscher.com/res/jstest.php

more options

Found the bug, I had "use system color" ticked in the firefox color settings... disabled, now working as expected! :D (And following your steps!)