Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I change Margins from millimeters to inches?

  • 4 replies
  • 1 has this problem
  • 4036 views
  • Last reply by stanstr

more options

I'm using Firefox 48.x on Windows 10. The margins (Page Setup > Margins) used to show in inches, but now they're in millimeters.

For each printer I have, their Printing Preferences in say I'm using either 'Letter' size or 8½ x 11 inch paper. Any other program with measurements shows in inches.

Thunderbird, Office (Word, Excel...), Corel Designer, and Photoshop all are in inches.

How do I get it back in Firefox?

Chosen solution

There was a bug in Firefox 47 that should have been fixed for you in the Firefox 48 update: https://support.mozilla.org/questions/1126411. However, if you have more than one printer, it might only have been fixed for the printer that was set as your default printer in Firefox at the time of the update.

To manually switch your printers from mm to in:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste size_u and pause while the list is filtered

(3) For each printer that has its print_paper_size_unit set to 1 (millimeters), double-click it and edit the value to 0 (inches) and click OK.

Read this answer in context 👍 0

All Replies (4)

more options

Hello stanstr, you can try the following steps:

  • (Ctrl + P) then select correct printer.
  • Open Properties
  • Look at the type of paper is selected.

Letter + Legal will have inch measurements for margins. A4 + other "A" papers will have metric measurements appear for margins.

more options

Been there. Done that. I even said so in my post.

The second paragraph of my post says that for each printer I have, their Printing Preferences say I'm using either 'Letter' size or 8½ x 11 inch paper. Excuse me for saying Printer Preferences instead of Printer Properties.

My computer at work has this problem, my home PC does, so does my wife's and a netbook we use. Does yours?

All these computers have their printers set to use Letter size paper (in inches), and in all of them Firefox has Page Setup > Margins in millimeters.

See the screenshot. It shows the two printers I use most set to use letter size paper, and the Firefox Margins in millimeters.

If you or someone else here can't help me with a fix, I'm going to assume this is a Firefox problem, that we're not alone, and that it will probably be fixed in the next release. As it is, it's not a major problem. It doesn't affect browsing or even printing.

more options

Chosen Solution

There was a bug in Firefox 47 that should have been fixed for you in the Firefox 48 update: https://support.mozilla.org/questions/1126411. However, if you have more than one printer, it might only have been fixed for the printer that was set as your default printer in Firefox at the time of the update.

To manually switch your printers from mm to in:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste size_u and pause while the list is filtered

(3) For each printer that has its print_paper_size_unit set to 1 (millimeters), double-click it and edit the value to 0 (inches) and click OK.

more options

Thanks Jefferson, that did it!