X
Tap here to go to the mobile version of the site.

Support Forum

Have a Javascript:viod(nul) problem that I cannot fix

Posted

Tried to follow in Firefox tool>options then click on "enable Javascript" check box but this check box wasn't there - how do I enable this?

Tried to follow in Firefox tool>options then click on "enable Javascript" check box but this check box wasn't there - how do I enable this?
Quote

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • 5.1.50428.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

jscher2000
  • Top 10 Contributor
5899 solutions 48488 answers

Helpful Reply

Hi Robert, JavaScript is enabled by default. If it were not enabled, half the sites on the web would be blaring out messages to you about it, so most likely you have it enabled. If you want to double-check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste javas and pause while the list is filtered

(3) If the javascript.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

If that is already set to true, could you provide more information about the circumstances of the problem?

Generally speaking, when a website uses

javascript:void(0)

or similar as the destination of a link, there is nearly always a script connected to the link that runs when you left-click it. Note that trying to direct that link to a new window or tab often fails because when you do that, the script may not run at all, so you just get the useless placeholder address in the address bar.

Hi Robert, JavaScript is enabled by default. If it were not enabled, half the sites on the web would be blaring out messages to you about it, so most likely you have it enabled. If you want to double-check: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''javas''' and pause while the list is filtered (3) If the '''javascript.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true If that is already set to true, could you provide more information about the circumstances of the problem? Generally speaking, when a website uses javascript:void(0) or similar as the destination of a link, there is nearly always a script connected to the link that runs when you left-click it. Note that trying to direct that link to a new window or tab often fails because when you do that, the script may not run at all, so you just get the useless placeholder address in the address bar.
Was this helpful to you? 4
Quote

Question owner

Many thanks for the response and this is on an airline site and I am trying to book selected flights. Maybe it is just this specific website that has an error in right now and it also give a unresponsive script message. Are these two tied?

Many thanks for the response and this is on an airline site and I am trying to book selected flights. Maybe it is just this specific website that has an error in right now and it also give a unresponsive script message. Are these two tied?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
5899 solutions 48488 answers

An unresponsive script warning can have many causes.

What kind of address does the dialog list? For example:

  • addresses starting with the name of the site usually are features/functions of the page
  • addresses from other sites often (but not always) are advertising networks - using an ad blocking extension can help address issues with slow or dysfunctional ad network scripts
  • addresses starting with chrome:// usually are part of Firefox or of an extension you installed - the Skype extension sometimes causes this problem, for example

We have a general support article addressing potential solutions to this issue: Warning Unresponsive script - What it means and how to fix it.

Another common cause of unresponsive script errors on Windows 7 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

An unresponsive script warning can have many causes. What kind of address does the dialog list? For example: * addresses starting with the name of the site usually are features/functions of the page * addresses from other sites often (but not always) are advertising networks - using an ad blocking extension can help address issues with slow or dysfunctional ad network scripts * addresses starting with chrome:// usually are part of Firefox or of an extension you installed - the Skype extension sometimes causes this problem, for example ---- We have a general support article addressing potential solutions to this issue: [[Warning Unresponsive script - What it means and how to fix it]]. Another common cause of unresponsive script errors on Windows 7 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
Was this helpful to you?
Quote

Question owner

Again thanks and this is the message "A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.

Script: https://book.qantas.com.au/pl/…online.1_170816/wro/ace-frw.js:2"

Then I simple press stop and when I hit the continue nothing happens and a corner pop up states "javascript:void(null).

Robert

Again thanks and this is the message "A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue. Script: https://book.qantas.com.au/pl/…online.1_170816/wro/ace-frw.js:2" Then I simple press stop and when I hit the continue nothing happens and a corner pop up states "javascript:void(null). Robert
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
5899 solutions 48488 answers

The corner popup may be the address of the link/button below the mouse pointer; that's the most common source of those little status messages.

Since the issue is with a script in the website, it's possible that something the script requires of Firefox is disabled or blocked. That's hard to know without a developer putting hands on the page. Next best thing would be to try the general suggestions in my earlier post.

The corner popup may be the address of the link/button below the mouse pointer; that's the most common source of those little status messages. Since the issue is with a script in the website, it's possible that something the script requires of Firefox is disabled or blocked. That's hard to know without a developer putting hands on the page. Next best thing would be to try the general suggestions in my earlier post.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.