Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Netflix Issue

  • 54 replies
  • 11 have this problem
  • 11212 views
  • Last reply by AliceWyman

more options

Hi, Since yesterday (August 19, 2016) Netflix stop working and I get a message at the top of the page saying "Firefox is installing components needed to play audio or video, please try again later". I just called Netflix support and they say that recently they stop using Silverlight and moved to HTML5, they advised me to update Firefox to the latest version, I was running on 47.0.1 but now after installing the update I'm running on 48.0.1 but still get the same error message. I can watch Netflix with Internet Explorer but not with Firefox anymore! For years was working fine I am wondering what's going on, can you help?

Chosen solution

To Adrianva:

If you already have Firefox set to update automatically, then the problem could be that your security software is intercepting the HTTPS request to download the needed components from Mozilla's servers, as reported in this bug report:

Bug 1300633 - Users report Netflix stopped working after Firefox 48 as CDM won't get installed See Bugzilla etiquette before commenting in bug reports.

What security software are you using? You can try to disable the interception of secure connections in your security software settings, as explained in the "Antivirus products" section this article: How to troubleshoot security error codes on secure websites

Read this answer in context 👍 1

All Replies (20)

more options

If a refresh doesn't help, it could be a temporary server issue, which has happened in the past. See Bug 1267495 - Add fallback for GMP downloads if AUS is down (reported 2016-04-25) (Quote) Recently the GMP AUS server went down, and new Firefox installs weren't able to play Netflix or use GMPs. We'd like to harden ourselves against this failure being an issue in future.

See Bugzilla etiquette before commenting in bug reports.

more options

well whatever the issue it also wont let amazon videos play either because when i checked with netflix they told me to check that site so i hope it gets fixed or i will have to start using a different browser

more options

Try this:

  1. Click on the Firefox menu button New Fx Menu in the top right corner and then click on Options.
  2. Choose the Advanced panel on the left and click on the Update tab.
  3. Make sure you have not turned off automatic updates. The page should look like this:
    Fx38WinAdvancedPanel-Update

Go back and try Netflix or Amazon Prime videos to see if the needed components are installed.

Ref: Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox Bug 1156557 - [EME] If updates are disabled, EME UI always shows "Please try again later" notification box)

more options

John99 said

Sorry I do not use Netflix, and do not intend trying, however please note that You Tube has been using HTML5 for a while now. The first post by Adrianva is explaining that Netflix now uses HTML5 so it strikes me it may be worth trying YouTube to see if you can see their HTML5 videos and also trying their test page You should mainly see blue boxes with ticks on that test page. The YouTube test page has support links. If you can get the YouTube video clips to work there is a good chance you will be able to get Netflix to work.

Hey John99 Youtube works fine the issue is with Netflix!

more options

alice wyman thanks for the advice but no it does not work and the button is checked

more options

attaching a screenshot of the addon page

more options

tessiss said

the addons have a yellow message under audio, etc saying it will be installed shortly but when is shortly since its been over a week. its says they are always active but will install shortly

it looks like the required codecs didn't install properly. Can you create a new profile? It may be best to do it this way:

- Type about:profiles in the Firefox location bar - Click the "Create a new profile"' button near the top and create one, name it "Test" for instance - Scroll down on the about:profiles page and choose "Set as default profile" next to the profile created. ("Launch profile in new browser" should be the logical step, but for some reason this doesn't open a fresh instance here in 48.) - Restart Firefox - it should start using the new profile - Check the Add-ons page in this new instance and see if the codes display properly - If so, check if the issue is present for that Firefox/profile instance

If the issue is solved, some steps "at file level" may be needed to fix the issue while retaining all settings in the current profile, and you can switch back to the old profile in the same way when done. Or you can keep using the new profile and move required files as described in Recovering important data from an old profile.

more options

new profile still had the issue

more options

Hi tessiss,

I'm one of the software developers working on Firefox's Netflix support.

Can you please collect some information to help us debug this? Please can you enter about:config in the URL bar, click the "I accept the risks" button, and then right click (anywhere in the page should work) > New > Boolean, enter the name as media.gmp.log.dump, and set it to true.

Then right click > New > Integer, enter the name as media.gmp.log.level, set it to 0.

You should then get something that looks like the attached image.

Then, please try to play a Netflix video.

Once that's failed, can you please press the CTRL SHIFT and J keys all together at the same time. That opens the "browser console". Right click > Select All, and then Right Click > Copy, and paste that in here.

This should give us some information as to what's going on with the installation of the components required to play Netflix.

Thanks!

Chris Pearce.

more options

Hi tessiss,

It would also be useful to know if disabling MalwareBytes and Avast Anti Virus and CCleaner (if that runs a scanning program?) and then trying to play Netflix helps. It's possible that these programs are interfering with the installation of the Widevine CDM, which must be installed for Netflix to work.

Thanks! Chris Pearce.

more options

dont have a clue how to do that

more options

it wont let me paste it says the characters are too many its over the requirement an it wont let me attach a doc file

more options

You can paste the Browser Console logging into https://pastebin.mozilla.org/ and post the link to the pastebin'd content here?

You can also email the logging to me at cpearce@mozilla.com, or take screen shots of the Browser Console, and attach those here.

Thanks very much. This will hopefully help!

Cheers, Chris.

more options

done, thanks

more options

Sorry, did you mean you've sent the log via email, or that you pastebin'd the log? I've not received an email. If you were emailing it, can you please double check that you sent the email to cpearce@mozilla.com? If you've pastebin'd it at https://pastebin.mozilla.org/ and you find the link to your pastebin? It's in the URL bar.

Thanks! Chris.

more options

Is this yours?

https://pastebin.mozilla.org/8907827

It looks like there's something interfering with the certificate checks on the connection to our update server.

Is your computers clock correct?

more options

Do you have VertoSmart installed? If so uninstall it! I think it's interfering with the download of your secure internet connections. We use a secure connection to download the component required to play Netflix.

Note that if you have VertoSmart installed, it looks like it intercepts all your secure Internet connections. For example, your connections to you Internet banking sites(!!). So I recommend you uninstall it immediately if you have it.

more options

yes that paste is mine an i have used verto smart for few years now with no issue

more options

yes my clock is working fine

more options

did not send by email sent it by that paste link

  1. 1
  2. 2
  3. 3