Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I turn off Web Push notifications in Firefox for all sites?

  • 8 replies
  • 14 have this problem
  • Last reply by jscher2000

more options

It's annoying to have to turn this feature off for every site/page that the notification pops-up. Isn't there a global setting?

All Replies (8)

more options

hi, you have to explicitly opt-in before any website can send web push notifications to your browser. you can easily retract the permissions for a single or all sites in the content panel of the firefox preferences.

Web Push notifications in Firefox

more options

I don't want to opt-in to any site. I would like to prevent the notification pop-up from appearing at all.

more options

i'm not sure if we are talking about the same thing ("web push notification") - web push notifications cannot be displayed by any websites unless you give it prior permission to do so. this & how to revoke all those permissions is explained in the article i've linked to before...

if you get unsolicited popups without prior approval, this won't come from "web push notifications", but something else is going on. it may be helpful if you could post a screenshot of such a popup and/or copy your troubleshooting data from about:support and enter it here into a reply into the forum...

more options

Edited to add Mac menu location, apologies for the oversight.

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

There are two different preferences for notifications, a master switch, and one which is specific to background (push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Does that work for you?

Modified by jscher2000

more options

Thank you jscher2000. This "master switch" solution is what I was looking for. It remains to be seen if it works ;)

more options

I used the Do Not Disturb feature Windows 10 on Mozilla. It didn't work. I have no pop ups option selected.

The web push pop up is from Mozilla by Mozilla. without my permission. The Mozilla instructions to block it for each website is absurd, and a rude way to treat users. Mozilla should provide a genuine feature that works to block the very annoying web push completely.

I uninstalled Mozilla and won't be back until that annoying pop up web push feature is either gone or a way to block it completely is provided.

more options

I agree with Asking2017! That "master switch" solution did not work. I still get those annoying pop-ups! Chrome is looking better and better!

more options

Hi kencav and Asking2017, can you post a screenshot showing the message? I want to see whether they are desktop notifications from websites or something else like script-driven popup windows or forced download dialogs.

(If you are referring to messages Firefox generates about updates being available, those are not web notifications.)