Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unity will not install to browser. How can I install it?

  • 2 replies
  • 2 have this problem
  • Last reply by jscher2000

more options

I have been able to use Unity webplayer for a long time. Now it just does not work. I could not use the plugin at all anymore. This does not seem right. As until now I was able to use Unity on Firefox until today when the webpage said 'UNITY IS NOT INSTALLED' (This was on Vega Conflict).

I checked the addons settings and... it was GONE. I tried to re-install the webplayer to the newest version but even though it installed succesfully, the plugin never showed up in the addons as installed. I tried restarting my computer but it still did not work.

This has not happened before. Please help as I cannot figure out why it will not activate in browser after Unity was installed to the computer.

All Replies (2)

more options

You should ask here; Unity - Official Site

more options

Plugin installers can add a plugin to Firefox is a few different ways, for example:

  • Add an entry to the Windows registry under the plugins list
  • Copy the plugin into a shared folder that Firefox checks from time to time

If the plugin does not show up either on the Add-ons page or the Plugin details page (type or paste about:plugins in the address bar and press Enter to load it), then either (i) the Unity installer failed to do one of the above or (ii) Firefox did not discover the Unity plugin.

If a Plugin is not listed on the Add-ons page:

Check for the Physical Presence of the Plugin DLL

{I don't know where Unity installs, so this step would require help from someone who uses it, or the publisher. You could skip this and check the other things first.}

If the file is there... and exiting and starting Firefox back up does not discover it...

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds many plugins from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find the missing plugin there now?

If Firefox is set to scan but still does not find the plugin and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show Folder" button (on Mac: the "Show in Finder" button) to launch a new file manager window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit (on Mac: Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, does the missing plugin finally appear there?