X
Tap here to go to the mobile version of the site.

Support Forum

Firefox no longer warns me when I'm closing multiple tabs. How can I turn on this warning again?

Posted

For whatever reason, my computer crashed and now Firefox refuses to warn me when I close multiple tabs. I'm using 47.0; how can I turn on this warning again?

For whatever reason, my computer crashed and now Firefox refuses to warn me when I close multiple tabs. I'm using 47.0; how can I turn on this warning again?

Chosen solution

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.tabs.warnOnClose and set it to true.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Google Update
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 22.0 r0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
4186 solutions 58430 answers

Chosen Solution

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.tabs.warnOnClose and set it to true.

Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. Type '''browser.tabs.warnOnClose''' and set it to '''true'''.
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156717 answers

You can check the startup setting.

  • Tools > Options > General > Startup: "When Firefox starts":
    "Show my windows and tabs from last time"
    "Show my home page"
    "Show a blank page"

If you use "Show my windows and tabs from last time" then Firefox won't ask for confirmation when you close Firefox. You can select "Show my home page" or "Show a blank page".

You can check the startup setting. *Tools > Options > General > Startup: "When Firefox starts":<br>"Show my windows and tabs from last time"<br>"Show my home page"<br>"Show a blank page" If you use "Show my windows and tabs from last time" then Firefox won't ask for confirmation when you close Firefox. You can select "Show my home page" or "Show a blank page".
canuhelp 1 solutions 11 answers

same problem. new computer, 48 version. both setups already existed, including browser.tabs.warnOnClose and set it to true. it was already set to true. Still warns on old computer but not on new> same version both. win10 home both. New one does not have Anniversary version of win10

same problem. new computer, 48 version. both setups already existed, including browser.tabs.warnOnClose and set it to true. it was already set to true. Still warns on old computer but not on new> same version both. win10 home both. New one does not have Anniversary version of win10

Modified by canuhelp