Search Support

Firefox shows error message when trying to access http:// websites

  • 10 replies
  • 2 have this problem
  • 68 views
  • Last reply by jscher2000

more options

Hello. Some time ago I installed a program on my PC and either Google Chrome or Mozilla Firefox started having problems when trying to access some websites (eg: I go to https://www.google.pt and all is good, but if I remove the "s" from https it don't work; Also I am here posting using Mozilla Firefox because this websits is https). I tried a fix I found on youtube, that was changing the chrome.exe name to something like chrome1.exe, worked, but only for a few days. Tried to reinstall Google Chrome and nothing. Later I installed Google Chrome 64 bits and since then I am not having problems with Chrome, but Firefox is still with problem. Microsoft Edge (I've Windows 10) works perfectly. Now talking a bit more about the problem. Trying to access http://www.tecmundo.com.br/ , http://www.google.pt/ , http://agar.io/ , and lots of other webpages, the uploaded message shows (in portuguese, and I dont know how to change language to english quickly). I think it is maybe some adware or so that I installed with that program that is causing the problem, as it's not affecting Edge, didn't affected Chrome when I changed the exe file name and don't affect 64bit Chrome. What would I do? I tried many fixes that I found in this site and nothing is working, so I thank you for help to fix it. Thanks.

Modified by James

All Replies (10)

more options

Something is wrong with the uploaded image (and with that strange message layout) so here's the image: http://prntscr.com/big2oy

Modified by Benur21

more options

Can you translate the message to English, please?

Some time ago I installed a program on my PC and either Google Chrome or Mozilla Firefox started having problems when trying to access some websites (eg: I go to https://www.google.pt and all is good, but if I remove the "s" from https it don't work; Also I am here posting using Mozilla Firefox because this websits is https). I tried a fix I found on youtube, that was changing the chrome.exe name to something like chrome1.exe, worked, but only for a few days. Tried to reinstall Google Chrome and nothing. Later I installed Google Chrome 64 bits and since then I am not having problems with Chrome, but Firefox is still with problem. Microsoft Edge (I've Windows 10) works perfectly.

Now talking a bit more about the problem. Trying to access http://www.tecmundo.com.br/ , http://www.google.pt/ , http://agar.io/ , and lots of other webpages, the uploaded message shows (in portuguese, and I dont know how to change language to english quickly).

I think it is maybe some adware or so that I installed with that program that is causing the problem, as it's not affecting Edge, didn't affected Chrome when I changed the exe file name and don't affect 64bit Chrome.

What would I do? I tried many fixes that I found in this site and nothing is working, so I thank you for help to fix it.
more options

What is the program you think caused the problem?


Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district are selected.

Language Packs https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack

or

Download Firefox For All languages And Systems {web link}

more options

FredMcD said

What is the program you think caused the problem?
   KMSpico http://kmspico10.com/

It's now uninstalled like every program that this took to my computer.

   And that thing to change the language doesn't change anything even on browser restart. http://prntscr.com/bigkfj
   Translation for the error message:
"

Connection has not been established

Firefox cannot estabilish connection with the server in (http:// website).

.The website may be temporarily unavaiable or busy. Try again later.
.If you cannot load any page, make sure that your computer is connected to the internet.
.If your computer and your network are protected by firewall or proxy, make sure that Firefox has permission to access Web.

Button: Try again

"

Modified by Benur21

more options

Sounds suspicious. Legitimate programs can update the registry without having you disable your security software...

Have you reviewed your Firefox connection settings?

You can do that here (apologies that I only know the English wording):

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced, then on the right side select the Network mini-tab at the top. Click the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" settings, but you could try "No proxy" to see whether that works better.

Have you done a thorough malware clean-out? Our support article lists free cleaning programs as well as specialized forums should the need arise: Troubleshoot Firefox issues caused by malware.

more options

jscher2000 said

Sounds suspicious. Legitimate programs can update the registry without having you disable your security software... Have you reviewed your Firefox connection settings? You can do that here (apologies that I only know the English wording): "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced, then on the right side select the Network mini-tab at the top. Click the "Settings" button. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" settings, but you could try "No proxy" to see whether that works better. Have you done a thorough malware clean-out? Our support article lists free cleaning programs as well as specialized forums should the need arise: Troubleshoot Firefox issues caused by malware.
   Nothing of that fixed the problem and I already tried to use 

SUPERAntiSpyware and some other programs to fix it and nothing.

more options

Someone can help me plz? I need to use firefox on http websites!

Modified by Benur21

more options

I updated Firefox and now idk why it is in English, so here's the message that shows when trying to access agar.io : http://image.prntscr.com/image/d3c4e59e2ec64d9f98cfa6014de0253a.png

   Also I tried to change the firefox.exe to firefoxe.exe and it works good that way, like Google Chrome.
more options
more options

Benur21 said

I tried to change the firefox.exe to firefoxe.exe and it works good that way, like Google Chrome.

That's a great test. It sounds like a firewall or some other software is blocking "firefox.exe". Our most relevant support article might be this one: Firefox can't load websites but other browsers can.