X
Tap here to go to the mobile version of the site.

Support Forum

The "Download Complete" arrow animation stops before it disappears.

Posted

I realize this may only be something cosmetic, but it is something that shouldn't happen. I've only noticed it in the past couple of days, since I upgraded to v47.0 (on a Slack64 v14.1 system). Everything, except that arrow, still seems to work as it always has. I'm not talking about the arrow on the "Downloads" button itself, but the animated arrow that shows a download has completed. It used to appear small, grow larger, and then disappear. Now, it does everything but disappear. Parts of it disappear if I hover over buttons it is covering. It disappears completely if I right click on the toolbar and select "Customize", or if I restart Firefox; I find both of those options to be a bit much.

I realize this may only be something cosmetic, but it is something that shouldn't happen. I've only noticed it in the past couple of days, since I upgraded to v47.0 (on a Slack64 v14.1 system). Everything, except that arrow, still seems to work as it always has. I'm not talking about the arrow on the "Downloads" button itself, but the animated arrow that shows a download has completed. It used to appear small, grow larger, and then disappear. Now, it does everything but disappear. Parts of it disappear if I hover over buttons it is covering. It disappears completely if I right click on the toolbar and select "Customize", or if I restart Firefox; I find both of those options to be a bit much.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers

Application

  • Firefox 47.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
  • Support URL: https://support.mozilla.org/1/firefox/47.0/Linux/en-US/

Extensions

  • Adblock Plus 2.7.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello 1.3.2 (loop@mozilla.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • NoScript 2.9.0.4 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Pocket 1.0.2 (firefox@getpocket.com)
  • Re-Pagination 2015.10.11 ({6072cb90-a0bd-11da-a746-0800200c9a66})
  • SaveFrom.net - helper 5.90 (helper-sig@savefrom.net)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce GT 610/PCIe/SSE2
  • adapterDeviceID: GeForce GT 610/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 4.5.0 NVIDIA 352.30
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'CairoUseXRender': 0, u'AzureContentBackend': u'cairo'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Failed to create H264 decoder
  • webglRenderer: NVIDIA Corporation -- GeForce GT 610/PCIe/SSE2
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4258 solutions 59623 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there

Question owner

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there

That solved it! Thank you, very much! :)

''FredMcD [[#answer-886268|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there </blockquote> That solved it! Thank you, very much! :)
FredMcD
  • Top 10 Contributor
4258 solutions 59623 answers

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode%20Safe%20Mode Safe Mode]''' is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. ----------- Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11289 answers

terlen64 said

I realize this may only be something cosmetic, but it is something that shouldn't happen. I've only noticed it in the past couple of days, since I upgraded to v47.0 (on a Slack64 v14.1 system). Everything, except that arrow, still seems to work as it always has. I'm not talking about the arrow on the "Downloads" button itself, but the animated arrow that shows a download has completed. It used to appear small, grow larger, and then disappear. Now, it does everything but disappear. Parts of it disappear if I hover over buttons it is covering. It disappears completely if I right click on the toolbar and select "Customize", or if I restart Firefox; I find both of those options to be a bit much.

Are you using the default Firefox theme or a full complete theme?

Are you using a GTK 3 theme?. Firefox as of 46.0 and newer needs GTK 3.4 (three.four) or preferably newer to run and as a result needs GTK 3 themes to theme Firefox. Firefox can look unthemed or potentially have gui glitches if a GTK 2 theme is in use.

''terlen64 [[#question-1126663|said]]'' <blockquote> I realize this may only be something cosmetic, but it is something that shouldn't happen. I've only noticed it in the past couple of days, since I upgraded to v47.0 (on a Slack64 v14.1 system). Everything, except that arrow, still seems to work as it always has. I'm not talking about the arrow on the "Downloads" button itself, but the animated arrow that shows a download has completed. It used to appear small, grow larger, and then disappear. Now, it does everything but disappear. Parts of it disappear if I hover over buttons it is covering. It disappears completely if I right click on the toolbar and select "Customize", or if I restart Firefox; I find both of those options to be a bit much. </blockquote> Are you using the default Firefox theme or a full complete theme? Are you using a GTK 3 theme?. Firefox as of 46.0 and newer needs GTK 3.4 (three.four) or preferably newer to run and as a result needs GTK 3 themes to theme Firefox. Firefox can look unthemed or potentially have gui glitches if a GTK 2 theme is in use.

Modified by James

Marcool 0 solutions 3 answers

Hi, Same problem for me. Seems to correspond more or less to the 47.0 version update. I have tried safe mode and this does indeed resolve the issue, so this is not a core problem. Hardware acceleration is off, and the selected (and only) theme is the default. I will say though, that it is not systematic... Sometimes a download will complete without causing the glitch. I haven't had any luck determining what exactly will set it off. It could be dependent on plug-ins, as safemode stops it (I have Adblock plus, HTTPSeverywhere, Distill and a few others for instance).

Hi, Same problem for me. Seems to correspond more or less to the 47.0 version update. I have tried safe mode and this does indeed resolve the issue, so this is not a core problem. Hardware acceleration is off, and the selected (and only) theme is the default. I will say though, that it is not systematic... Sometimes a download will complete without causing the glitch. I haven't had any luck determining what exactly will set it off. It could be dependent on plug-ins, as safemode stops it (I have Adblock plus, HTTPSeverywhere, Distill and a few others for instance).
FredMcD
  • Top 10 Contributor
4258 solutions 59623 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Marcool 0 solutions 3 answers

I think I have the culprit: Distill. It is a monitoring addon to keep track of changes in webpages. I ran a few tests with it on and off, and it would seem that it is indeed causing the bug. Not sure if you have the same one terlen64? Maybe if you don't you could go through the same procedure as me, testing with a few addons on and off to find which one is causing this in your browser? Or you could list which addons you have running – if you don't mind doing so — and someone might see a link between Distill and one of yours.

I think I have the culprit: [https://addons.mozilla.org/en-US/firefox/addon/alertbox/ Distill]. It is a monitoring addon to keep track of changes in webpages. I ran a few tests with it on and off, and it would seem that it is indeed causing the bug. Not sure if you have the same one terlen64? Maybe if you don't you could go through the same procedure as me, testing with a few addons on and off to find which one is causing this in your browser? Or you could list which addons you have running – if you don't mind doing so — and someone might see a link between Distill and one of yours.

Modified by Marcool

Question owner

Marcool said

I think I have the culprit: Distill. It is a monitoring addon to keep track of changes in webpages. I ran a few tests with it on and off, and it would seem that it is indeed causing the bug. Not sure if you have the same one terlen64? Maybe if you don't you could go through the same procedure as me, testing with a few addons on and off to find which one is causing this in your browser? Or you could list which addons you have running – if you don't mind doing so — and someone might see a link between Distill and one of yours.

Never even heard of Distill until now. I run AdBlock Plus, NoScript, and SaveFrom.net Helper. I will do some testing.

''Marcool [[#answer-890912|said]]'' <blockquote> I think I have the culprit: [https://addons.mozilla.org/en-US/firefox/addon/alertbox/ Distill]. It is a monitoring addon to keep track of changes in webpages. I ran a few tests with it on and off, and it would seem that it is indeed causing the bug. Not sure if you have the same one terlen64? Maybe if you don't you could go through the same procedure as me, testing with a few addons on and off to find which one is causing this in your browser? Or you could list which addons you have running – if you don't mind doing so — and someone might see a link between Distill and one of yours. </blockquote> Never even heard of Distill until now. I run AdBlock Plus, NoScript, and SaveFrom.net Helper. I will do some testing.
Marcool 0 solutions 3 answers

And... nope. Just happened again. It is not Distill, but that means I have no idea what in the world is causing this bug to happen sometimes, and not others. It could even be that it is not addon related, and that if we ran safe-mode long enough and downloaded enough times it would happen then also. :/

And... nope. Just happened again. It is not Distill, but that means I have no idea what in the world is causing this bug to happen sometimes, and not others. It could even be that it is not addon related, and that if we ran safe-mode long enough and downloaded enough times it would happen then also. :/

Modified by Marcool