X
Tap here to go to the mobile version of the site.

Support Forum

I keep getting an internet connection failure. Can someone help me repair this. It won't let me view certain pages.

Posted

This is what I keep getting on various sites lately:

Secure Connection Failed

An error occurred during a connection to hcde.centurylink.com. Peer using unsupported version of security protocol. Error code: SSL_ERROR_UNSUPPORTED_VERSION

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I have W7; DSL with Century Link who tried to fix it but couldn't. I can't seem to find the answer. I tried typing in about:config but got the Secure Connection Failed message. Grrrr! Help!

This is what I keep getting on various sites lately: Secure Connection Failed An error occurred during a connection to hcde.centurylink.com. Peer using unsupported version of security protocol. Error code: SSL_ERROR_UNSUPPORTED_VERSION The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. I have W7; DSL with Century Link who tried to fix it but couldn't. I can't seem to find the answer. I tried typing in about:config but got the Secure Connection Failed message. Grrrr! Help!

Chosen solution

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

You can check the ssl and tls prefs on the about:config page. If any ssl or tls pref is bold (user set) then right-click that pref and choose "Reset" to reset the pref to the default value. Paste this regular expression in the Search bar at the top of the about:config page:

  • /security.*ssl|security.*tls/

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Plug-in for detecting Nero Kwik Media.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

FredMcD
  • Top 10 Contributor
4314 solutions 60576 answers
There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' https://support.mozilla.org/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.
cor-el
  • Top 10 Contributor
  • Moderator
17694 solutions 160089 answers

Chosen Solution

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

You can check the ssl and tls prefs on the about:config page. If any ssl or tls pref is bold (user set) then right-click that pref and choose "Reset" to reset the pref to the default value. Paste this regular expression in the Search bar at the top of the about:config page:

  • /security.*ssl|security.*tls/

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 You can check the <b>ssl</b> and <b>tls</b> prefs on the about:config page. If any ssl or tls pref is bold (user set) then right-click that pref and choose "Reset" to reset the pref to the default value. Paste this regular expression in the Search bar at the top of the about:config page: *<b>/security.*ssl|security.*tls/</b> You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

THANK YOU Cor-el! It WORKED! I am thrilled to say the least. Now I can view my bills and do what is needed.

Now I have one other question that seems to be problematic recently. My Outlook2010 is not displaying images like it used to. It seems to have happened at the same time that the problems above occurred. I just checked again to see after having reset the ssl security but to no avail. Any ideas?

Thanks again.

THANK YOU Cor-el! It WORKED! I am thrilled to say the least. Now I can view my bills and do what is needed. Now I have one other question that seems to be problematic recently. My Outlook2010 is not displaying images like it used to. It seems to have happened at the same time that the problems above occurred. I just checked again to see after having reset the ssl security but to no avail. Any ideas? Thanks again.
cor-el
  • Top 10 Contributor
  • Moderator
17694 solutions 160089 answers

You can check the Web Console ("3-bar" menu button or Tools > Web Developer) if there are error messages about images being blocked.

Do you see any icons at the left end of the location/address bar like a shield (tracking protection) or a padlock with an exclamation mark (mixed content)?

You can see a special padlock at the left end of the location/address bar.

  • a padlock with a strike through means that mixed active content is blocked.
  • a padlock with an exclamation mark attached means that mixed passive content (e.g. images) is present, but not blocked.

The shield icon, previously used for mixed active content, is now used for Tracking Protection.

You can check the Web Console ("3-bar" menu button or Tools > Web Developer) if there are error messages about images being blocked. *https://developer.mozilla.org/Tools/Web_Console Do you see any icons at the left end of the location/address bar like a shield (tracking protection) or a padlock with an exclamation mark (mixed content)? You can see a special padlock at the left end of the location/address bar. *a padlock with a strike through means that mixed active content is blocked. *a padlock with an exclamation mark attached means that mixed passive content (e.g. images) is present, but not blocked. The shield icon, previously used for mixed active content, is now used for Tracking Protection. *https://support.mozilla.org/kb/mixed-content-blocking-firefox *https://support.mozilla.org/kb/control-center-site-privacy-and-security-firefox *https://developer.mozilla.org/Security/MixedContent