X
Tap here to go to the mobile version of the site.

Support Forum

Firefox hangs trying to access Office365 Mail, Contacts etc but IE is OK

Posted

After successfully logging in to Office365 (work), an attempt to click MAIL or CONTACTS results in a hang and blank screen. This does not happen in IE. After letting FireFox sit for a minute or two, the BACK arrow display shows a long list of "continue" entries as if in a loop. I have tried starting FireFox with AddIns disabled (safe mode) and get same result.

Any clue?

After successfully logging in to Office365 (work), an attempt to click MAIL or CONTACTS results in a hang and blank screen. This does not happen in IE. After letting FireFox sit for a minute or two, the BACK arrow display shows a long list of "continue" entries as if in a loop. I have tried starting FireFox with AddIns disabled (safe mode) and get same result. Any clue?

Chosen solution

Oops, in the above reply, please also clear cookies for office.com in addition to office365.com since your "realm" is on that server.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Zeon PDF Plugin For Mozilla
  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • NPWLPG
  • A component of your photo software powered by RocketLife
  • Shockwave Flash 21.0 r0
  • iTunes Detector Plug-in

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • 1Password 4.5.1 (onepassword4@agilebits.com)
  • Firefox Hello Beta 1.3.2 (loop@mozilla.org)
  • Live HTTP headers 0.17.1-signed.1-signed ({8f8fe09b-0bd3-4470-bc1b-8cad42b8203a})
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Skype 8.3.0.9150 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Bitdefender Wallet 2.1 (bdwteffv19@bitdefender.com) (Inactive)
  • iCloud Bookmarks 1.4.22 (firefoxdav@icloud.com) (Inactive)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 2600 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300 ] D [ Gamma: 2600 Pixel Structure: B ClearType Level: 0 Enhanced Contrast: 400 ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 5-27-2015
  • driverDate2:
  • driverVersion: 9.17.10.4229
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

I am not sure, but I suspect the browser is going into a program loop. For example: Line 1 = GoTo Line 1

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

This file tells Firefox what to do with what type of file. The computer system also has a file like this. The wrong entry here could create the loop problem.

I am not sure, but I suspect the browser is going into a program loop. For example: Line 1 = GoTo Line 1 Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''mimeTypes.rdf''' file. Then rename or delete it. Restart Firefox. This file tells Firefox what to do with what type of file. The computer system also has a file like this. The wrong entry here could create the loop problem.

Question owner

Thanks for the quick reply. Unfortunately, this made no difference.

One other possible issue: The failing link is to Office365 (work) and I'm wondering since the URL contains specific account information if there is an issue with the MS Office suite on my computer (not downloaded from that account) vs. the office suite I downloaded to the account owner's PC. In other words, does an attempt to access email online at Office365 try to verify the desktop apps belong to the online account? Even if so, why would IE work and not FireFox?

BTW, the "BACK" list again shows a large number of "Continue" entries.

Thanks for the quick reply. Unfortunately, this made no difference. One other possible issue: The failing link is to Office365 (work) and I'm wondering since the URL contains specific account information if there is an issue with the MS Office suite on my computer (not downloaded from that account) vs. the office suite I downloaded to the account owner's PC. In other words, does an attempt to access email online at Office365 try to verify the desktop apps belong to the online account? Even if so, why would IE work and not FireFox? BTW, the "BACK" list again shows a large number of "Continue" entries.

Question owner

https://login.microsoftonline.com/login.srf?wa=wsignin1.0&rpsnv=4&ct=1465236757&rver=6.6.6556.0&wp=MBI_SSL&wreply=https%3a%2f%2foutlook.office.com%2fowa%2f%3frealm%3dxxxxxxxxx.com&id=999999&whr=xxxxxxxxx.com&CBCXT=out&msafed=0#wa=wsignin1.0 This is the URL (with domain and ID altered) It is definitely in a loop as the number of "continues" keep growing.

Modified by nazbuster

jscher2000
  • Top 10 Contributor
8765 solutions 71703 answers

Helpful Reply

Sounds like a cookie problem. Could you try:

(1) Make sure cookie settings are liberal for testing purposes. See: Websites say cookies are blocked - Unblock them

(2) Remove existing cookies for microsoftonline.com AND office365.com -- assuming you do not have any unsaved work pending on the system (based on your symptoms, I suspect not). Either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog. Edit that to microsoftonline.com to list that site's cookies, and then remove them individually. Repeat with office365.com.

Then try logging in again and see whether the redirect is successful.

Sounds like a cookie problem. Could you try: (1) Make sure cookie settings are liberal for testing purposes. See: [[Websites say cookies are blocked - Unblock them]] (2) Remove existing cookies for microsoftonline.com AND office365.com -- assuming you do not have any unsaved work pending on the system (based on your symptoms, I suspect not). Either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog. Edit that to microsoftonline.com to list that site's cookies, and then remove them individually. Repeat with office365.com. Then try logging in again and see whether the redirect is successful.
jscher2000
  • Top 10 Contributor
8765 solutions 71703 answers

Chosen Solution

Oops, in the above reply, please also clear cookies for office.com in addition to office365.com since your "realm" is on that server.

Oops, in the above reply, please also clear cookies for office.com in addition to office365.com since your "realm" is on that server.

Question owner

SUCCESS! I just cleared ALL my cookies and it all loaded up just fine.

Thank you so much for the suggestion.

SUCCESS! I just cleared ALL my cookies and it all loaded up just fine. Thank you so much for the suggestion.