X
Tap here to go to the mobile version of the site.

Support Forum

Vertical scroll bar behavior

Posted

When i left-click in the vertical scroll bar area, the bar jumps right to the position where the mouse is at. If i right-click in the vertical scroll bar area the page srolls one page at a time. I want to reverse this.

So, i want: left click = jump one page down/up. right click = bar to mouse click position

Thanx

When i left-click in the vertical scroll bar area, the bar jumps right to the position where the mouse is at. If i right-click in the vertical scroll bar area the page srolls one page at a time. I want to reverse this. So, i want: left click = jump one page down/up. right click = bar to mouse click position Thanx

Chosen solution

I have fixed this (im using linux mint)

Create this ~/.config/gtk-3.0/settings.ini and add [Settings] gtk-primary-button-warps-slider = false

Now left mouse-click does not couse the bar to warp to mouse location but jumps one page at a time, that is the way i want.

I would like to see bar warping on right-click but that is something to look into.

Apparently that left-click warp is a new feature of GTK3. I dont know why that was changed. It's not consistent with other applications behavior.

Anyway. Problem solved.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • Nexus Personal Plug-Ins
  • The Videos 3.10.1 plugin handles video and audio streams.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15591 solutions 141164 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if that makes a difference.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions ("3-bar" menu button or Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: "3-bar" menu button or Tools > Add-ons > Appearance *Do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if that makes a difference. *https://www.mozilla.org/en-US/firefox/all/

Chosen Solution

I have fixed this (im using linux mint)

Create this ~/.config/gtk-3.0/settings.ini and add [Settings] gtk-primary-button-warps-slider = false

Now left mouse-click does not couse the bar to warp to mouse location but jumps one page at a time, that is the way i want.

I would like to see bar warping on right-click but that is something to look into.

Apparently that left-click warp is a new feature of GTK3. I dont know why that was changed. It's not consistent with other applications behavior.

Anyway. Problem solved.

I have fixed this (im using linux mint) Create this ~/.config/gtk-3.0/settings.ini and add [Settings] gtk-primary-button-warps-slider = false Now left mouse-click does not couse the bar to warp to mouse location but jumps one page at a time, that is the way i want. I would like to see bar warping on right-click but that is something to look into. Apparently that left-click warp is a new feature of GTK3. I dont know why that was changed. It's not consistent with other applications behavior. Anyway. Problem solved.