Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I keep getting an "unexpected error" trying to sign up for Sync(i.e. create an account), any ideas on how to fix that?

  • 2 replies
  • 2 have this problem
  • 195 views
  • Last reply by sandman1

more options

So I went to https://accounts.firefox.com/signup, entered my email and password, hit Sign Up and got the little red box at the top informing me of an "unexpected error", which doesn't really tell me anything. How do I fix this?

Update Okay, so apparently there's something wrong with my one computer. I tried signing up from my other one and it worked just fine. I still have no idea what could be the reason for the error on my first computer though. I do have adblock and noscript installed on Firefox, but made sure to try allowing everything for a session, but that didn't help either. Well whatever, I got it working by trying to do it on another computer.

Modified by sandman1

Chosen solution

Hello sandman1,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hello sandman1,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks for the help. So I figured out the problem was because of my NoScript add-on. There was a blockable script I had missed. When I went to the sign-up or sign-in page for firefox accounts I allowed all scripts, however, once I'd pushed the sign-up or sign-in button and received the error message, there were 1 or 2 additional scripts to allow that I had missed last time this happened: oauth.accounts and profile.accounts on the firefox.com domain. Allowed these and it worked fine. So that was it.

How it worked on my other computer, where I have the same add-on installed and followed the exact same steps in allowing scripts, and not on this one I do not know.