X
Tap here to go to the mobile version of the site.

Support Forum

With FF as default browser, from TB click on link asks to close FF?

Posted

Windows 10 FF 46.0.1 TB 45 When clicking on a link in TB, an error is passed stating to: "Firefox is already running, but not responding. The old Firefox must be closed to open a new window" See alarm screen.jpg

Windows 10 FF 46.0.1 TB 45 When clicking on a link in TB, an error is passed stating to: "Firefox is already running, but not responding. The old Firefox must be closed to open a new window" See alarm screen.jpg
Attached screenshots

Chosen solution

I had two e-mail accounts that I manage with TB One account had the ProfilerSwitcher extension in it with this variable unchecked (It is checked by default). It worked. by clicking on a link in an email, FF opened it up just fine. However, the other e-mail account didn't have this extension installed and didn't work posting the original error message. Once I installed ProfileSwitcher and deslected the MO_NO_REMOTE parameter this account then worked

Windows 10 TB 45.1.1 FF 47.0

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • McAfee MSC FF plugin DLL
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Plug-in for Workspace utilities
  • Shockwave Flash 21.0 r0
  • Plug-in for Workspace Webmail

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40161 answers
Are you 'playing with' Profiles in Firefox? https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

Question owner

Did some testing and it doesn't seem to be from profiles I start up in "safe" mode and didn't help

Did some testing and it doesn't seem to be from profiles I start up in "safe" mode and didn't help
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).

Question owner

I'm not quite understanding you. Would this switch be set on install or update? I've attached screen shots of what I think you're referring to.

thanks in advance.

I'm not quite understanding you. Would this switch be set on install or update? I've attached screen shots of what I think you're referring to. thanks in advance.
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40161 answers

No - not from the installation or from an update, it would be something the user set. The environment variable MOZ_NO_REMOTE=1 was deprecated years ago in lieu of a command line 'switch' of -no-remote for Firefox. Either of those could cause that message.

Check the full list in System variables for MOZ_NO_REMOTE=1 - scroll down.

No - not from the installation or from an update, it would be something the user set. ''The environment variable MOZ_NO_REMOTE=1 was deprecated years ago in lieu of a command line 'switch' of -no-remote for Firefox. Either of those could cause that message.'' Check the full list in '''System variables''' for MOZ_NO_REMOTE=1 - scroll down.

Question owner

O.k so I added the MOZ_NO_REMOTE=1 to System Vars exited out of FF and attempted to open link again and got same error

O.k so I added the MOZ_NO_REMOTE=1 to System Vars exited out of FF and attempted to open link again and got same error
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

You shouldn't use MOZ_NO_REMOTE=1 as that will cause this error as well, so please undo this action.

The most likely cause of this error is still that the -no-remote switch is active somehow, so check all the shortcuts you use to start Firefox and maybe also try to search the Windows Registry for this switch.

You shouldn't use MOZ_NO_REMOTE=1 as that will cause this error as well, so please undo this action. The most likely cause of this error is still that the -no-remote switch is active somehow, so check all the shortcuts you use to start Firefox and maybe also try to search the Windows Registry for this switch.

Question owner

I kind of understand you. New computer Windows 10 I don't know how to get at the registry little alone find and fix these issues any direction will help

I kind of understand you. New computer Windows 10 I don't know how to get at the registry little alone find and fix these issues any direction will help

Question owner

Can anyone please help me?

Can anyone please help me?

Question owner

Can someone help me please? I really don't like to use IE

Can someone help me please? I really don't like to use IE
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40161 answers

It sounds like you did something to Firefox or in Windows10 which created that problem; namely either the desktop shortcut for Firefox has the -no-remote command line switch or you added (and haven't yet removed) the MOZ_NO_REMOTE=1 from System Variables.

Did you inspect the "Target:" line for that -no-remote switch in the Firefox desktop shortcut? Did you delete that System Variable?

It sounds like you did something to Firefox or in Windows10 which created that problem; namely either the desktop shortcut for Firefox has the -no-remote command line switch or you added ''(and haven't yet removed)'' the MOZ_NO_REMOTE=1 from System Variables. Did you inspect the "Target:" line for that -no-remote switch in the Firefox desktop shortcut? Did you delete that System Variable?

Question owner

I don't see anything with the shortcut "Target:"

 "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

I also don't see the MOZ_NO_REMOTE=1 in the System Variables.

I don't see anything with the shortcut "Target:" "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" I also don't see the MOZ_NO_REMOTE=1 in the System Variables.

Question owner

Can someone please help me?

Can someone please help me?
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40161 answers

How about that MOZ_NO_REMOTE=1 System Variable?

As you posted in the screenshot.

How about that MOZ_NO_REMOTE=1 System Variable? ''As you posted in the screenshot.''

Question owner

There is an add-on to TB that has this variable The "Profile Switcher" https://addons.mozilla.org/en-US/thunderbird/addon/profileswitcher/?src=ss The default is checked but I have unchecked it. But still have the same problem Note that this is not part of the system VARS

There is an add-on to TB that has this variable The "Profile Switcher" https://addons.mozilla.org/en-US/thunderbird/addon/profileswitcher/?src=ss The default is checked but I have unchecked it. But still have the same problem Note that this is not part of the system VARS
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40161 answers

Maybe your problem is with Thunderbird, and possibly with that Profile Switcher extension in Thunderbird?

Have you searched the Windows Registry for that System Variable? I can't help you with that as I haven't 'messed with' the Registry since the days of Win98. http://www.tenforums.com/

Maybe your problem is with Thunderbird, and possibly with that Profile Switcher extension in Thunderbird? Have you searched the Windows Registry for that System Variable? ''I can't help you with that as I haven't 'messed with' the Registry since the days of Win98.'' http://www.tenforums.com/

Chosen Solution

I had two e-mail accounts that I manage with TB One account had the ProfilerSwitcher extension in it with this variable unchecked (It is checked by default). It worked. by clicking on a link in an email, FF opened it up just fine. However, the other e-mail account didn't have this extension installed and didn't work posting the original error message. Once I installed ProfileSwitcher and deslected the MO_NO_REMOTE parameter this account then worked

Windows 10 TB 45.1.1 FF 47.0

I had two e-mail accounts that I manage with TB One account had the ProfilerSwitcher extension in it with this variable unchecked (It is checked by default). It worked. by clicking on a link in an email, FF opened it up just fine. However, the other e-mail account didn't have this extension installed and didn't work posting the original error message. Once I installed ProfileSwitcher and deslected the MO_NO_REMOTE parameter this account then worked Windows 10 TB 45.1.1 FF 47.0