X
Tap here to go to the mobile version of the site.

Support Forum

Fonts in FireFox are blocky (no antialias)

Posted

Hi

I've suddenly noticed that my fonts in FireFox are very blocky (no antialias). I'm sure this happened after a restart but not sure why.

I've checked the zoom factor of the page and I can confirm that this is at 100% / Reset

When I went to check my version it updated so this problem exists across 4.6 and 4.5.? (didn't catch the last number before it updated).

I've check windows (all fonts are fine)

I've check another browser (Chrome at the same page.. this is fine).

I'm posting this question/request for help as other posts I've found related do not quite match my issue.

Please find attached a screen shot of the issue (FireFox is to the left and Chrome to the right)

(Upload seems to be caught up, I'll reply to this msg if it doesn't show)

Many thanks J

Hi I've suddenly noticed that my fonts in FireFox are very blocky (no antialias). I'm sure this happened after a restart but not sure why. I've checked the zoom factor of the page and I can confirm that this is at 100% / Reset When I went to check my version it updated so this problem exists across 4.6 and 4.5.? (didn't catch the last number before it updated). I've check windows (all fonts are fine) I've check another browser (Chrome at the same page.. this is fine). I'm posting this question/request for help as other posts I've found related do not quite match my issue. Please find attached a screen shot of the issue (FireFox is to the left and Chrome to the right) (Upload seems to be caught up, I'll reply to this msg if it doesn't show) Many thanks J

Chosen solution

NVidia Drivers are now at the latest version 364.72, problem sorted but it doesn't seem to be drivers. I re-applied the clearFont in windows and recalibrated the font output too.

Strange things are happening with Windows 10 for me at the moment as default browser cannot be set. Perhaps there's a gremlin in here running around :/

Thanks very much

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • LastPass Plugin
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • iTunes Detector Plug-in

Application

  • Firefox 46.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0/WINNT/en-GB/

Extensions

  • Firebug 2.0.16 (firebug@software.joehewitt.com)
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • iCloud Bookmarks 1.4.14.1-signed.1-signed (firefoxdav@icloud.com)
  • LastPass 3.3.1 (support@lastpass.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • pwgen - Password Generator 0.5.2.1-signed.1-signed (pwgen@alouche.net)
  • Web Developer 1.2.5.1-signed.1-signed ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Avira Browser Safety 1.9.0.621 (abs@avira.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 560 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1200
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 35151458
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 7-13-2015
  • driverDate2:
  • driverVersion: 10.18.13.5354
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

Thought so, the image didn't upload. Here it is again

Thought so, the image didn't upload. Here it is again
FredMcD
  • Top 10 Contributor
4299 solutions 60388 answers

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html
jscher2000
  • Top 10 Contributor
8837 solutions 72221 answers

Helpful Reply

Could you check whether any font rendering preferences have been modified from their default values:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste font_r and pause while the list is filtered

(3) If any are bolded and "user set" you can right-click > Reset them

You probably need to exit and start Firefox back up again to see any difference.


Blocky character edges can point to a change to the gfx.font_rendering.cleartype_params.rendering_mode preference. Here's my understanding of what the numbers do (as of Firefox 45):

//     -1 or 0 = use default for font & size;
//     4 = Natural;
//     5 = Natural Symmetric
=> Sub-pixel anti-aliasing/positioning
//     1 = aliased;
//     2 = GDI Classic;
=> GDI emulation (whole pixel rendering)
//     3 = GDI Natural Widths;
=> GDI emulation with natural widths (?)
Could you check whether any font rendering preferences have been modified from their default values: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''font_r''' and pause while the list is filtered (3) If any are bolded and "user set" you can right-click > Reset them You probably need to exit and start Firefox back up again to see any difference. ---- Blocky character edges can point to a change to the '''gfx.font_rendering.cleartype_params.rendering_mode''' preference. Here's my understanding of what the numbers do (as of Firefox 45): // -1 or 0 = use default for font & size; // 4 = Natural; // 5 = Natural Symmetric => Sub-pixel anti-aliasing/positioning // 1 = aliased; // 2 = GDI Classic; => GDI emulation (whole pixel rendering) // 3 = GDI Natural Widths; => GDI emulation with natural widths (?)

Question owner

Hi FredMcD

The setting you suggested was already set. I'm not sure about the links, they look like they are for Mac OS?

Hi jscher2000

I've looked at the information on the about:config but everything you have suggested seems to be set.

Thanks Any other suggestions?

Hi FredMcD The setting you suggested was already set. I'm not sure about the links, they look like they are for Mac OS? Hi jscher2000 I've looked at the information on the about:config but everything you have suggested seems to be set. Thanks Any other suggestions?

Question owner

Just noticed this problem seems to be reflected in Thunderbird too

I hope that helps narrows it down

Just noticed this problem seems to be reflected in Thunderbird too I hope that helps narrows it down
jscher2000
  • Top 10 Contributor
8837 solutions 72221 answers

Helpful Reply

The Graphics report under your Question Details > More System Details looks good, so it's hard to understand the source of the problem. Everything seems to be in place for Firefox to apply ClearType to the downloadable web font (Open Sans) used on this site.

Are there problems with other webfonts? For example:

Roboto: https://www.google.com/fonts/specimen/Roboto

The Graphics report under your Question Details > More System Details looks good, so it's hard to understand the source of the problem. Everything seems to be in place for Firefox to apply ClearType to the downloadable web font (Open Sans) used on this site. Are there problems with other webfonts? For example: Roboto: https://www.google.com/fonts/specimen/Roboto

Question owner

Roboto looks a bit choppy too. If I go to https://www.google.com/fonts and look down the list they all look choppy but the "add to collection" button font looks fine.

Looking at the top of firefox it looks like its spread up there too.

Baring in mind that other browsers are fine and windows system fonts all look good this seems to be effecting only firefox in a massive way.

Thanks jscher2000 for getting back to me. At this point I'd probably be looking at reinstall but thunderbird is the same so how can something have an effect globally across mozilla products.

Roboto looks a bit choppy too. If I go to https://www.google.com/fonts and look down the list they all look choppy but the "add to collection" button font looks fine. Looking at the top of firefox it looks like its spread up there too. Baring in mind that other browsers are fine and windows system fonts all look good this seems to be effecting only firefox in a massive way. Thanks jscher2000 for getting back to me. At this point I'd probably be looking at reinstall but thunderbird is the same so how can something have an effect globally across mozilla products.
jscher2000
  • Top 10 Contributor
8837 solutions 72221 answers

It could be a compatibility glitch with your Nvidia driver software. When accelerated features do not work correctly, but do not cause crashes, it may fail to be noticed during testing.

You may want to check whether graphics card/chipset driver updates are available for your system. This article suggests safe ways to do that: Upgrade your graphics drivers to use hardware acceleration and WebGL.

It could be a compatibility glitch with your Nvidia driver software. When accelerated features do not work correctly, but do not cause crashes, it may fail to be noticed during testing. You may want to check whether graphics card/chipset driver updates are available for your system. This article suggests safe ways to do that: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]].

Question owner

NVidia driver is on 353.54 with an update to 364.72 available. I'll download and install and report back

NVidia driver is on 353.54 with an update to 364.72 available. I'll download and install and report back

Chosen Solution

NVidia Drivers are now at the latest version 364.72, problem sorted but it doesn't seem to be drivers. I re-applied the clearFont in windows and recalibrated the font output too.

Strange things are happening with Windows 10 for me at the moment as default browser cannot be set. Perhaps there's a gremlin in here running around :/

Thanks very much

NVidia Drivers are now at the latest version 364.72, problem sorted but it doesn't seem to be drivers. I re-applied the clearFont in windows and recalibrated the font output too. Strange things are happening with Windows 10 for me at the moment as default browser cannot be set. Perhaps there's a gremlin in here running around :/ Thanks very much
FredMcD
  • Top 10 Contributor
4299 solutions 60388 answers
https://www.bing.com/search?q=change+default+browser+windows+10&pc=MOZI&form=MOZSBR