X
Tap here to go to the mobile version of the site.

Support Forum

Fonts on Google Docs and some Gmail look pixelated on Windows 7

Posted

Recently the fonts on my Google Docs and on some Gmail are looking pixelated. I did a lot of troubleshooting including safe mode, refresh firefox, clean reinstall. What I did was I copied the profile folder (with the long string for a name) to desktop and deleted the folder in firefox program files. I then added in piece by piece back into the profile until I isolated the problem. It is clear the the issue is in the PREF file. However I have no idea what there is in the file to change short of deleting it (and losing all my settings, extension settings etc.) which I do not want to do. Is there a particular change I can make to the pref file to rectify the matter? I am attaching a sample of what I am seeing in the font. I will also attach a sample of what it looks like in Chrome (which is what it should look like) Well the upload of the images is not working so I will submit the question without it.

Recently the fonts on my Google Docs and on some Gmail are looking pixelated. I did a lot of troubleshooting including safe mode, refresh firefox, clean reinstall. What I did was I copied the profile folder (with the long string for a name) to desktop and deleted the folder in firefox program files. I then added in piece by piece back into the profile until I isolated the problem. It is clear the the issue is in the PREF file. However I have no idea what there is in the file to change short of deleting it (and losing all my settings, extension settings etc.) which I do not want to do. Is there a particular change I can make to the pref file to rectify the matter? I am attaching a sample of what I am seeing in the font. I will also attach a sample of what it looks like in Chrome (which is what it should look like) Well the upload of the images is not working so I will submit the question without it.

Chosen solution

Google Sheets use a "canvas" element, which bypasses some of Firefox's normal font smoothing. However, you can improve the rendering significantly if you can enabled hardware acceleration. I am attaching a screen shot of mine showing it is better, but still not perfect.

I don't know whether hardware acceleration is disabled on your Firefox because Firefox is no longer compatible with your Nvidia driver software, and/or because you experienced stability problems, or as part of troubleshooting this or other issues.

I suggest checking for updated drivers. This support article suggests safe ways to do that (since there is a lot of malware out there targeted to people downloading drivers from random sites): Upgrade your graphics drivers to use hardware acceleration and WebGL.

Can you get hardware acceleration working? Firefox's general on/off setting is here:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, with the "General" mini-tab active, find the box for "Use hardware acceleration when available".

Note: any change takes effect the next time you exit Firefox and start it up again.

To see whether it's actually in effect, you can check the Troubleshooting Information page to check on that. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics header and check the following table for GPU Accelerated Windows which is a ratio of accelerated to total windows. If the top is 0, HA is not running, while if the numerator equals the denominator, HA is running.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Application

  • Firefox 45.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Amazon Price Tracker - Keepa.com 2.29 (amptra@keepa.com)
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • Gmail™ Notifier (restartless) 0.6.2 (jid0-GjwrPchS3Ugt7xydvqVK4DQk8Ls@jetpack)
  • Avast Online Security 10.3.3.39 (wrc@avast.com) (Inactive)
  • Avast SafePrice 10.3.5.39 (sp@avast.com) (Inactive)
  • NoScript 2.6.9.37 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)
  • RAMBack 1.0.1-signed (ramback@pavlov.net) (Inactive)
  • Webmail Ad Blocker 4.29 (gmailnoads@mywebber.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 610
  • adapterDescription2:
  • adapterDeviceID: 0x104a
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 104a10b0
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 5-19-2014
  • driverDate2:
  • driverVersion: 9.18.13.3788
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

OK the upload worked now, You can see the two images of the Google Doc, one from Firefox which is pixelated, and one from Chrome (the first one) which is good. The images didn't post here the greatest but it gives you an idea of what the issue is.

Also one more thing: I set "gfx.use_text_smoothing_setting" to true, the problem still persisted as you can see in the images below.

OK the upload worked now, You can see the two images of the Google Doc, one from Firefox which is pixelated, and one from Chrome (the first one) which is good. The images didn't post here the greatest but it gives you an idea of what the issue is. Also one more thing: I set "gfx.use_text_smoothing_setting" to true, the problem still persisted as you can see in the images below.

Modified by ygreenes

jscher2000
  • Top 10 Contributor
8793 solutions 71936 answers

Chosen Solution

Google Sheets use a "canvas" element, which bypasses some of Firefox's normal font smoothing. However, you can improve the rendering significantly if you can enabled hardware acceleration. I am attaching a screen shot of mine showing it is better, but still not perfect.

I don't know whether hardware acceleration is disabled on your Firefox because Firefox is no longer compatible with your Nvidia driver software, and/or because you experienced stability problems, or as part of troubleshooting this or other issues.

I suggest checking for updated drivers. This support article suggests safe ways to do that (since there is a lot of malware out there targeted to people downloading drivers from random sites): Upgrade your graphics drivers to use hardware acceleration and WebGL.

Can you get hardware acceleration working? Firefox's general on/off setting is here:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, with the "General" mini-tab active, find the box for "Use hardware acceleration when available".

Note: any change takes effect the next time you exit Firefox and start it up again.

To see whether it's actually in effect, you can check the Troubleshooting Information page to check on that. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics header and check the following table for GPU Accelerated Windows which is a ratio of accelerated to total windows. If the top is 0, HA is not running, while if the numerator equals the denominator, HA is running.

Google Sheets use a "canvas" element, which bypasses some of Firefox's normal font smoothing. However, you can improve the rendering significantly if you can enabled hardware acceleration. I am attaching a screen shot of mine showing it is better, but still not perfect. I don't know whether hardware acceleration is disabled on your Firefox because Firefox is no longer compatible with your Nvidia driver software, and/or because you experienced stability problems, or as part of troubleshooting this or other issues. I suggest checking for updated drivers. This support article suggests safe ways to do that (since there is a lot of malware out there targeted to people downloading drivers from random sites): [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]. Can you get hardware acceleration working? Firefox's general on/off setting is here: "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced. On the right side, with the "General" mini-tab active, find the box for "Use hardware acceleration when available". Note: any change takes effect the next time you exit Firefox and start it up again. To see whether it's actually in effect, you can check the Troubleshooting Information page to check on that. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter Scroll down to the Graphics header and check the following table for '''GPU Accelerated Windows''' which is a ratio of accelerated to total windows. If the top is 0, HA is not running, while if the numerator equals the denominator, HA is running.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

What font is Firefox using?

You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

What font is Firefox using? You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Are there any 'font' prefs user set (bold) on the about:config page?

You can open the about:config page via the location/address bar and search for prefs font. You can reset user set (bold) pref(s) on the about:config page via the right-click context menu to the default value.

Are there any 'font' prefs user set (bold) on the <b>about:config</b> page? You can open the <b>about:config</b> page via the location/address bar and search for prefs <b>font</b>. You can reset user set (bold) pref(s) on the <b>about:config</b> page via the right-click context menu to the default value.