X
Tap here to go to the mobile version of the site.

Support Forum

I keep getting SEC_ERROR_BAD_SIGNATURE in Firefox when same url is OK in chrome

Posted

Firefox is my default browser, and Google.co.uk is my home page - every time I startup Firefox the url redirects to https://www.google.co.uk/?gws_rd=ssl and I get the SEC_ERROR_BAD_SIGNATURE problem. The message seems to happen on other https:// urls within Firefox but the same pages are easily accessed when using Chrome browser. I am using Bullguard internet security. Thanks in advance. Dave S

Firefox is my default browser, and Google.co.uk is my home page - every time I startup Firefox the url redirects to https://www.google.co.uk/?gws_rd=ssl and I get the SEC_ERROR_BAD_SIGNATURE problem. The message seems to happen on other https:// urls within Firefox but the same pages are easily accessed when using Chrome browser. I am using Bullguard internet security. Thanks in advance. Dave S

Chosen solution

hi daveslatter, can you see if the steps from this link make a difference?: https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_bullguard

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.4.154
  • 5.1.41212.0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23468 answers

Chosen Solution

hi daveslatter, can you see if the steps from this link make a difference?: https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_bullguard

hi daveslatter, can you see if the steps from this link make a difference?: https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_bullguard