X
Tap here to go to the mobile version of the site.

Support Forum

Secure Connection Failed / authenticity of the received data could not be verified

Posted

I am receiving this error on a few sites, but only one that I can list at the moment: https://www.flexjobs.com

Secure Connection Failed The connection to www.flexjobs.com was interrupted while the page was loading. -The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. -Please contact the website owners to inform them of this problem.

Firefox cannot access this site from multiple locations (both my home and my work). I did an SSL checkup of the site and they get a "Grade A" and looks like it supports all of the correct "current" signatures: https://www.ssllabs.com/ssltest/analyze.html?d=www.flexjobs.com

I am receiving this error on a few sites, but only one that I can list at the moment: https://www.flexjobs.com Secure Connection Failed The connection to www.flexjobs.com was interrupted while the page was loading. -The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. -Please contact the website owners to inform them of this problem. Firefox cannot access this site from multiple locations (both my home and my work). I did an SSL checkup of the site and they get a "Grade A" and looks like it supports all of the correct "current" signatures: https://www.ssllabs.com/ssltest/analyze.html?d=www.flexjobs.com

Chosen solution

Found it already actually. For some reason "security.tls.version.max" was set to 1.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • SAFARI Montage Info 1.0.0
  • SAFARI Montage Player 5.9.0
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.3.183
  • 5.1.41212.0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5347 solutions 23608 answers

hi syntax53, i'm not able to replicate this issue. please try to refresh firefox and see if this can address the issue...

hi syntax53, i'm not able to replicate this issue. please try to [[Reset Firefox – easily fix most problems|refresh firefox]] and see if this can address the issue...

Question owner

If I just do "safe mode" it still does not work-- so it's not an add-on problem. However, if I do a refresh it work until my profile syncs with Firefox sync. I assume it's some setting in the about:config causing it. How can I go about figuring out which one it is?

If I just do "safe mode" it still does not work-- so it's not an add-on problem. However, if I do a refresh it work until my profile syncs with Firefox sync. I assume it's some setting in the about:config causing it. How can I go about figuring out which one it is?
philipp
  • Top 25 Contributor
  • Moderator
5347 solutions 23608 answers

obvious candidates would be any custom (=shown in bold) preferences starting with "network." or "security."

obvious candidates would be any custom (=shown in bold) preferences starting with "network." or "security."

Chosen Solution

Found it already actually. For some reason "security.tls.version.max" was set to 1.

Found it already actually. For some reason "security.tls.version.max" was set to 1.
PArmstrong 0 solutions 3 answers

I'm having the same Secure Connection Failed issue with https://apps.texas.aaa.com/aceapps/authenticate/login?area=email_enterprise_profileregister

I called AAA. The woman I spoke with says that she can click the register button and the web page comes up. She thinks it's a problem with my computer and/or Firefox configuration. I did the SSL Lab Test and the site's overall rating is B. The certificates appear to be secure. Is there some setting that I need to make in Firefox? Cache and cookies are cleared.

I'm having the same Secure Connection Failed issue with https://apps.texas.aaa.com/aceapps/authenticate/login?area=email_enterprise_profileregister I called AAA. The woman I spoke with says that she can click the register button and the web page comes up. She thinks it's a problem with my computer and/or Firefox configuration. I did the SSL Lab Test and the site's overall rating is B. The certificates appear to be secure. Is there some setting that I need to make in Firefox? Cache and cookies are cleared.

Question owner

PArmstrong said

I'm having the same Secure Connection Failed issue with https://apps.texas.aaa.com/aceapps/authenticate/login?area=email_enterprise_profileregister I called AAA. The woman I spoke with says that she can click the register button and the web page comes up. She thinks it's a problem with my computer and/or Firefox configuration. I did the SSL Lab Test and the site's overall rating is B. The certificates appear to be secure. Is there some setting that I need to make in Firefox? Cache and cookies are cleared.

This site does not work for me either.

''PArmstrong [[#answer-910107|said]]'' <blockquote> I'm having the same Secure Connection Failed issue with https://apps.texas.aaa.com/aceapps/authenticate/login?area=email_enterprise_profileregister I called AAA. The woman I spoke with says that she can click the register button and the web page comes up. She thinks it's a problem with my computer and/or Firefox configuration. I did the SSL Lab Test and the site's overall rating is B. The certificates appear to be secure. Is there some setting that I need to make in Firefox? Cache and cookies are cleared. </blockquote> This site does not work for me either.