X
Tap here to go to the mobile version of the site.

Support Forum

How can I disable autofocus for the input tag?

Posted

Some abusive Google AdWords ads exploit the input tag's autofocus attribute to override links to internal anchors deep in the page.

When I follow a link such as: http://www.example.com/page.html#paragraph5

This should set the top of the page as the internal link with name (HTML4 or less) or id (HTML5) "paragraph5". This has been the case pretty much since the invention of HTML.

Unfortunately, HTML5 introduced the attribute "autofocus" to the input tag. Some abusive advertisers have noticed that they can exploit this to override the behavior of the actual website, and scroll the page to focus on the advertisement instead of the site's content.

Here is an example of an obnoxious, abusive AdWord advertisement from Adobe: https://s0.2mdn.net/ads/richmedia/studio/pv2/40930760/20160126194122120/AdobeStock728x90.html?e=69&renderingType=2&leftOffset=0&topOffset=0&c=8dPnUcilTf&t=1

Google AdWords is not going to police this abusive behavior. Google likes it when people view its advertisements instead of actual site content.

It is possible for the owner of a website to individually ban certain advertisements from his website. However, there is no way for an individual who does not own a website to ban certain Google AdWords advertisements from a website he frequents.

I find the "autofocus" attribute to be completely useless for normal browsing and highly obnoxious when misused by abusive advertisers. It is very likely that more and more advertisers will use this trick to break websites. Therefore, I would like a way to completely disable / ignore the "autofocus" attribute within Firefox.

How can I do this? Is there a configuration I can change? Is there an Add-On I can install?

Some abusive Google AdWords ads exploit the input tag's autofocus attribute to override links to internal anchors deep in the page. When I follow a link such as: http://www.example.com/page.html#paragraph5 This should set the top of the page as the internal link with name (HTML4 or less) or id (HTML5) "paragraph5". This has been the case pretty much since the invention of HTML. Unfortunately, HTML5 introduced the attribute "autofocus" to the input tag. Some abusive advertisers have noticed that they can exploit this to override the behavior of the actual website, and scroll the page to focus on the advertisement instead of the site's content. Here is an example of an obnoxious, abusive AdWord advertisement from Adobe: https://s0.2mdn.net/ads/richmedia/studio/pv2/40930760/20160126194122120/AdobeStock728x90.html?e=69&renderingType=2&leftOffset=0&topOffset=0&c=8dPnUcilTf&t=1 Google AdWords is not going to police this abusive behavior. Google likes it when people view its advertisements instead of actual site content. It is possible for the owner of a website to individually ban certain advertisements from his website. However, there is no way for an individual who does not own a website to ban certain Google AdWords advertisements from a website he frequents. I find the "autofocus" attribute to be completely useless for normal browsing and highly obnoxious when misused by abusive advertisers. It is very likely that more and more advertisers will use this trick to break websites. Therefore, I would like a way to completely disable / ignore the "autofocus" attribute within Firefox. How can I do this? Is there a configuration I can change? Is there an Add-On I can install?

Chosen solution

You can set browser.autofocus to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.13
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 19.0 r0
  • VLC media player Web Plugin 2.1.3
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17339 solutions 156760 answers

Chosen Solution

You can set browser.autofocus to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can set <b>browser.autofocus</b> to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Helpful Reply

Thanks! That seemed to solve the issue -- at least for Firefox.

Thanks! That seemed to solve the issue -- at least for Firefox.