X
Tap here to go to the mobile version of the site.

Support Forum

Flash content is not loading on Firefox 44 with Windows 10, how can I fix this?

Posted

I'm using Windows 10 x64 Build 14271

I have tried the following with no success: Refreshed Firefox, Uninstalled Flash, restarted PC, installed Flash, restarted PC, Launched Firefox, Restarted Firefox

I uninstalled Flash from Control PanelI even uninstalled Flash using: https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

I have downloaded the latest version of Flash from: https://www.adobe.com/products/flashplayer/distribution3.html

I used the following Mozilla website to check that Flash is updated: https://www.mozilla.org/en-US/plugincheck/ which says that I have the latest version of Flash

However, when I use Adobe's website to check if I have Flash, it says I have version 20.0.0.306 (which is the latest version) but the yellow box that displays the success message with a green checkmark is empty and the Flash animation that should play if you have Flash doesn't play (it shows as a static image) https://helpx.adobe.com/flash-player.html

I think this may have something to do with me using the latest fast ring build of Windows 10 but I'm not sure if that is what's causing the issue.

I'm using Windows 10 x64 Build 14271 I have tried the following with no success: Refreshed Firefox, Uninstalled Flash, restarted PC, installed Flash, restarted PC, Launched Firefox, Restarted Firefox I uninstalled Flash from Control PanelI even uninstalled Flash using: https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html I have downloaded the latest version of Flash from: https://www.adobe.com/products/flashplayer/distribution3.html I used the following Mozilla website to check that Flash is updated: https://www.mozilla.org/en-US/plugincheck/ which says that I have the latest version of Flash However, when I use Adobe's website to check if I have Flash, it says I have version 20.0.0.306 (which is the latest version) but the yellow box that displays the success message with a green checkmark is empty and the Flash animation that should play if you have Flash doesn't play (it shows as a static image) https://helpx.adobe.com/flash-player.html I think this may have something to do with me using the latest fast ring build of Windows 10 but I'm not sure if that is what's causing the issue.

Modified by guitarjorge24

Chosen solution

jscher2000 said

It could be an issue for Adobe to fix.

This issue has been finally fixed on the latest version of Adobe Flash Player!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.14
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 20.0 r0
  • Plugin for Wacom tablets.
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Use the uninstall link again. Then use it again until there is no flash detected.

Then reinstall the latest version.

Flash Player Version Version: 20.0.0.306
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users should download the ‘’’active_x’’’ for “Internet Explorer,” and the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox).

Note: Windows 8 and Windows 10 have built in flash players and Adobe will cause a conflict. Install the ’’’plugin’’’ only. Not the ’’’active_x’’’.

Adobe still offers Flash 18.0.0.326 as its extended support release further down

Use the uninstall link again. Then use it again until there is no flash detected. Then reinstall the latest version. Flash Player '''Version Version: 20.0.0.306<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' should download the ‘’’active_x’’’ for “Internet Explorer,” '''and''' the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox). Note: Windows 8 and Windows 10 have built in flash players and Adobe will cause a conflict. Install the ’’’plugin’’’ only. Not the ’’’active_x’’’. Adobe still offers Flash 18.0.0.326 as its extended support release further down

Question owner

FredMcD said

Use the uninstall link again. Then use it again until there is no flash detected. Then reinstall the latest version. Flash Player Version Version: 20.0.0.306
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users should download the ‘’’active_x’’’ for “Internet Explorer,” and the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox). Note: Windows 8 and Windows 10 have built in flash players and Adobe will cause a conflict. Install the ’’’plugin’’’ only. Not the ’’’active_x’’’. Adobe still offers Flash 18.0.0.326 as its extended support release further down

I have already uninstalled it and checked that no flash was detected. I also downloaded the plugin version for Firefox and installed it but it's not working. The interesting thing is that Flash on Firefox is not working on my laptop but it is working on my Desktop PC. The only difference I think is relevant, is that on my laptop I have the latest fast ring build of Win 10 and on my PC I have an older version of the fast ring build

''FredMcD [[#answer-848625|said]]'' <blockquote> Use the uninstall link again. Then use it again until there is no flash detected. Then reinstall the latest version. Flash Player '''Version Version: 20.0.0.306<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' should download the ‘’’active_x’’’ for “Internet Explorer,” '''and''' the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox). Note: Windows 8 and Windows 10 have built in flash players and Adobe will cause a conflict. Install the ’’’plugin’’’ only. Not the ’’’active_x’’’. Adobe still offers Flash 18.0.0.326 as its extended support release further down </blockquote> I have already uninstalled it and checked that no flash was detected. I also downloaded the plugin version for Firefox and installed it but it's not working. The interesting thing is that Flash on Firefox is not working on my laptop but it is working on my Desktop PC. The only difference I think is relevant, is that on my laptop I have the latest fast ring build of Win 10 and on my PC I have an older version of the fast ring build
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

guitarjorge24 said

However, when I use Adobe's website to check if I have Flash, it says I have version 20.0.0.306 (which is the latest version) but the yellow box that displays the success message with a green checkmark is empty and the Flash animation that should play if you have Flash doesn't play (it shows as a static image)
https://helpx.adobe.com/flash-player.html

Flash must be running because you can't get the final part of the version number with Flash awaiting activation (attached screen shot).

As for particular content not loading or not displaying properly, what if you load the yellow box SWF in its own tab?

https://helpx.adobe.com/content/dam/help/en/flash-player/assets/externalinterface.swf

If that loads stand-alone but would not load in the page, hmm, why would that be...

''guitarjorge24 [[#question-1111624|said]]'' <blockquote> However, when I use Adobe's website to check if I have Flash, it says I have version 20.0.0.306 (which is the latest version) but the yellow box that displays the success message with a green checkmark is empty and the Flash animation that should play if you have Flash doesn't play (it shows as a static image)<br> https://helpx.adobe.com/flash-player.html </blockquote> Flash must be running because you can't get the final part of the version number with Flash awaiting activation (attached screen shot). As for particular content not loading or not displaying properly, what if you load the yellow box SWF in its own tab? https://helpx.adobe.com/content/dam/help/en/flash-player/assets/externalinterface.swf If that loads stand-alone but would not load in the page, hmm, why would that be...

Question owner

jscher2000 said

Flash must be running because you can't get the final part of the version number with Flash awaiting activation (attached screen shot). As for particular content not loading or not displaying properly, what if you load the yellow box SWF in its own tab? https://helpx.adobe.com/content/dam/help/en/flash-player/assets/externalinterface.swf If that loads stand-alone but would not load in the page, hmm, why would that be...

I have Flash set to "Always Activate" in Firefox's add-on options. I tried loading the SWF from the link you provided but it looks just the same as the Flash Check Page. It's just a yellow box without the green checkmark and congratulation message. I'm starting to think that this is only a Windows 10 Fast Ring Build issue since I see some other people complaining about the same thing on the Windows 10 Feedback app Here is a link to the Windows Feedback submission

My question now is: Is this an issue that Microsoft is going to fix? or is it something new on Windows 10 that MS is not going to change, meaning that Mozilla will have to fix it?

''jscher2000 [[#answer-849206|said]]'' <blockquote> Flash must be running because you can't get the final part of the version number with Flash awaiting activation (attached screen shot). As for particular content not loading or not displaying properly, what if you load the yellow box SWF in its own tab? https://helpx.adobe.com/content/dam/help/en/flash-player/assets/externalinterface.swf If that loads stand-alone but would not load in the page, hmm, why would that be... </blockquote> I have Flash set to "Always Activate" in Firefox's add-on options. I tried loading the SWF from the link you provided but it looks just the same as the Flash Check Page. It's just a yellow box without the green checkmark and congratulation message. I'm starting to think that this is only a Windows 10 Fast Ring Build issue since I see some other people complaining about the same thing on the Windows 10 Feedback app Here is a [http://Windows-Feedback:?contextid=213&feedbackid=7d892c1b-d630-45be-afd8-46cb071b50c5&form=1&src=2 link to the Windows Feedback submission] My question now is: Is this an issue that Microsoft is going to fix? or is it something new on Windows 10 that MS is not going to change, meaning that Mozilla will have to fix it?
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

Helpful Reply

It could be an issue for Adobe to fix. But it shows normally in Edge and/or Chrome?

It could be an issue for Adobe to fix. But it shows normally in Edge and/or Chrome?

Question owner

jscher2000 said

It could be an issue for Adobe to fix. But it shows normally in Edge and/or Chrome?

Yes I get the green checkmark and flash animation on Chrome, Internet Explorer, and Edge.

''jscher2000 [[#answer-849562|said]]'' <blockquote> It could be an issue for Adobe to fix. But it shows normally in Edge and/or Chrome? </blockquote> Yes I get the green checkmark and flash animation on Chrome, Internet Explorer, and Edge.

Chosen Solution

jscher2000 said

It could be an issue for Adobe to fix.

This issue has been finally fixed on the latest version of Adobe Flash Player!

''jscher2000 [[#answer-849562|said]]'' <blockquote> It could be an issue for Adobe to fix. </blockquote> This issue has been finally fixed on the latest version of Adobe Flash Player!