Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to select "TLS1.0" version?

  • 4 replies
  • 3 have this problem
  • 12 views
  • Last reply by ideato

more options

i wish to update the mozilla browser for"TLS1.0" but no option for "Encryption" is available after Tools-option-Advanced

plz guide

i wish to update the mozilla browser for"TLS1.0" but no option for "Encryption" is available after Tools-option-Advanced plz guide

All Replies (4)

more options

Hello, change the security.tls.version.max to 1 in about:config.

http://kb.mozillazine.org/Security.tls.version.*

thank you

more options

It is best to leave security.tls.version.max and security.tls.version.min at their defaults.

What issues do you have that you need TLS 1.0?

The website may try to fallback to a lower TLS version in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the full domain () to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). There should only be domains separated by a comma in the Value column (example.com,www.example.com).

If this helps then you can contact this website and ask them to look into this and update their security.

Modified by cor-el

more options

Firefox 37.0 and newer views TLS 1.0 as obsolete.

more options

James said

Firefox 37.0 and newer views TLS 1.0 as obsolete.

Confirm, James is correct, Bug 1084025 - Disable insecure TLS version fallback (status-firefox37:fixed )

try cor-el's suggestion above, IT IS you solution.

thank you and sorry for the inconvenience