Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am not seeing a purple mask when I open a private window. How can I fix this?

  • 1 reply
  • 5 have this problem
  • 170 views
  • Last reply by cor-el

more options

I've followed all the suggested fixes. Adding '-private' to the target line in properties prompted this message: Problem with Shortcut The name "C:\Program Files (x86)\Mozilla Firefox\firefox.exe-private" specified in the Target box is not valid. Make sure the path and file name are correct. Open to other reasonable suggestions. Thanks

Chosen solution

You need to leave a space before a command line switch like -private and place the switch outside the path that is enclosed between quotes.

  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -private

But if you start Firefox that way in a Private Browsing mode session then you won't see the purple mask. You only get a purple mask and the about:privatebrowsing page in a new window when you start Firefox in normal mode and open a New Private Window to distinguish a PB mode window from a normal window.

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

You need to leave a space before a command line switch like -private and place the switch outside the path that is enclosed between quotes.

  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -private

But if you start Firefox that way in a Private Browsing mode session then you won't see the purple mask. You only get a purple mask and the about:privatebrowsing page in a new window when you start Firefox in normal mode and open a New Private Window to distinguish a PB mode window from a normal window.