X
Tap here to go to the mobile version of the site.

Support Forum

Why is the Roboform toolbar missing in Firefox but not in IE11 in a Windows 10 Standard user account but not in the Administrator account?

Posted

Upgrading from Windows 7 to Windows 10 went fine, but I notice that the Roboform toolbar is missing in Firefox in my wife's Standard User local account (but it IS there in IE11). The toolbar shows up as normal in both browsers in my Admistrative local user account. In Firefox, clicking on View/Toolbars does not show Roboform as an option. I've tried uninstalling Roboform and re-installing the most recent version but the same thing occurs.

Can anyone provide a solution to get the toolbar to show up?

Upgrading from Windows 7 to Windows 10 went fine, but I notice that the Roboform toolbar is missing in Firefox in my wife's Standard User local account (but it IS there in IE11). The toolbar shows up as normal in both browsers in my Admistrative local user account. In Firefox, clicking on View/Toolbars does not show Roboform as an option. I've tried uninstalling Roboform and re-installing the most recent version but the same thing occurs. Can anyone provide a solution to get the toolbar to show up?

Chosen solution

This problem was solved through suggestions from Roboform Support:

Making the missing Roboforn icon appear in the taskbar: (1) Clicking Start/All Apps/Roboform/Taskbar Icon as suggested did not work: nothing happens. (2) In IE11 (where the toolbar appears) in Roboform/Options/General, Show Roboform Icon in Taskbar was unchecked; checking it restore the taskbar icon. GOOD!!

Firefox/Add-ons/Extensions: (1) Does not show Roboform at all. (2) From the Roboform taskbar icon, opening Options/Browser Integration, clicking the Firefox-based browsers button and dragging the green puzzle piece into the Firefox Extensions window makes the Roboform Toolbar extension show up. GOOD!!

IE11 Enhanced Protected Mode: (1) In my Administrative account, disabling this as suggested allows the Roboform toolbar to show up. (2) In my wife's Standard account, the toolbar show up even with EPM enabled. ????? Verdict: puzzling, but everything is working as before and the Roboform toolbar is showing up everywhere. Since we don't use IE11 as our default browser, this is not a problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 20.0 r0

Application

  • Firefox 43.0.4
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.4/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterPrivacy 1.69 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • RoboForm Toolbar 7.9.16.9 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Screengrab (fix version) 0.98.11c ({02450914-cdd9-410f-b1da-db004e18c671})
  • Norton Identity Safe 2016.5.6.90 ({C1A2A613-35F1-4FCF-B27F-2840527B6556}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 635
  • adapterDescription2:
  • adapterDeviceID: 0x1280
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 103210de
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 8-7-2015
  • driverDate2:
  • driverVersion: 10.18.13.5382
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 635 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4255 solutions 59597 answers

Did you check the Add-ons Manager?

This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox

https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

Did you check the Add-ons Manager? This will disable add-on signature enforcement; Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

Question owner

This did not fix my problem. Even if it had worked, it would remove an important security feature.

Sadly, this response from Roboform Support did not work either:

"Please try reinstalling the extension in Firefox following these steps: 1) First, properly disable RoboForm's extension in Firefox: Tools > Add-ons > Extensions. 2) Click the RoboForm taskbar icon in system tray > Options > Browser Integration and uncheck all Firefox related options. Note: please do not enable 'Attach RoboForm to Firefox even if adapter is not installed', this option should be enabled for portable applications only. 3) Install the latest RoboForm version https://www.roboform.com/dist/RoboForm-Setup.exe and be sure to check Firefox checkbox in Browser Integration window of RF installer. 4) Click the RoboForm taskbar icon in system tray > Options > Browser Integration and check the Firefox option if it is not checked. Also Make sure "RoboForm Toolbar for Firefox " is enabled in Firefox Add-ons: - In Firefox select Tools > Add-ons > Extensions. - Click RoboForm Toolbar addon, click Enable if it is disabled. - Restart Firefox browser. 5) Show Roboform toolbar in Firefox: - Select View > Toolbars > RoboForm. - If only RoboForm Toolbar button shows, then click it and full toolbar will appear."

Can anyone else help with this?

This did not fix my problem. Even if it had worked, it would remove an important security feature. Sadly, this response from Roboform Support did not work either: "Please try reinstalling the extension in Firefox following these steps: 1) First, properly disable RoboForm's extension in Firefox: Tools > Add-ons > Extensions. 2) Click the RoboForm taskbar icon in system tray > Options > Browser Integration and uncheck all Firefox related options. Note: please do not enable 'Attach RoboForm to Firefox even if adapter is not installed', this option should be enabled for portable applications only. 3) Install the latest RoboForm version https://www.roboform.com/dist/RoboForm-Setup.exe and be sure to check Firefox checkbox in Browser Integration window of RF installer. 4) Click the RoboForm taskbar icon in system tray > Options > Browser Integration and check the Firefox option if it is not checked. Also Make sure "RoboForm Toolbar for Firefox " is enabled in Firefox Add-ons: - In Firefox select Tools > Add-ons > Extensions. - Click RoboForm Toolbar addon, click Enable if it is disabled. - Restart Firefox browser. 5) Show Roboform toolbar in Firefox: - Select View > Toolbars > RoboForm. - If only RoboForm Toolbar button shows, then click it and full toolbar will appear." Can anyone else help with this?
FredMcD
  • Top 10 Contributor
4255 solutions 59597 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Chosen Solution

This problem was solved through suggestions from Roboform Support:

Making the missing Roboforn icon appear in the taskbar: (1) Clicking Start/All Apps/Roboform/Taskbar Icon as suggested did not work: nothing happens. (2) In IE11 (where the toolbar appears) in Roboform/Options/General, Show Roboform Icon in Taskbar was unchecked; checking it restore the taskbar icon. GOOD!!

Firefox/Add-ons/Extensions: (1) Does not show Roboform at all. (2) From the Roboform taskbar icon, opening Options/Browser Integration, clicking the Firefox-based browsers button and dragging the green puzzle piece into the Firefox Extensions window makes the Roboform Toolbar extension show up. GOOD!!

IE11 Enhanced Protected Mode: (1) In my Administrative account, disabling this as suggested allows the Roboform toolbar to show up. (2) In my wife's Standard account, the toolbar show up even with EPM enabled. ????? Verdict: puzzling, but everything is working as before and the Roboform toolbar is showing up everywhere. Since we don't use IE11 as our default browser, this is not a problem.

This problem was solved through suggestions from Roboform Support: Making the missing Roboforn icon appear in the taskbar: (1) Clicking Start/All Apps/Roboform/Taskbar Icon as suggested did not work: nothing happens. (2) In IE11 (where the toolbar appears) in Roboform/Options/General, Show Roboform Icon in Taskbar was unchecked; checking it restore the taskbar icon. GOOD!! Firefox/Add-ons/Extensions: (1) Does not show Roboform at all. (2) From the Roboform taskbar icon, opening Options/Browser Integration, clicking the Firefox-based browsers button and dragging the green puzzle piece into the Firefox Extensions window makes the Roboform Toolbar extension show up. GOOD!! IE11 Enhanced Protected Mode: (1) In my Administrative account, disabling this as suggested allows the Roboform toolbar to show up. (2) In my wife's Standard account, the toolbar show up even with EPM enabled. ????? Verdict: puzzling, but everything is working as before and the Roboform toolbar is showing up everywhere. Since we don't use IE11 as our default browser, this is not a problem.
FredMcD
  • Top 10 Contributor
4255 solutions 59597 answers

That was very good work. Well Done.

That was very good work. Well Done.
Cruel.Puppet 0 solutions 1 answers

FredMcD said

Did you check the Add-ons Manager? This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

FredMcD said

Did you check the Add-ons Manager? This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

THANK YOU THANK YOU! U are awesome. I followed it and doggone if it didn't return my roboform toolbar. A Million and one thank you's.

CP

''FredMcD [[#answer-842216|said]]'' <blockquote> Did you check the Add-ons Manager? This will disable add-on signature enforcement; Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47” </blockquote> ''FredMcD [[#answer-842216|said]]'' <blockquote> Did you check the Add-ons Manager? This will disable add-on signature enforcement; Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47” </blockquote> THANK YOU THANK YOU! U are awesome. I followed it and doggone if it didn't return my roboform toolbar. A Million and one thank you's. CP
FredMcD
  • Top 10 Contributor
4255 solutions 59597 answers

Just remember, this option is removed in ver 47, but could be delayed.

Just remember, this option is removed in ver 47, but could be delayed.