Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why aren't my passwords being displayed after resetting logins.json (successfully)?

  • 3 replies
  • 1 has this problem
  • 8 views
  • Last reply by FredMcD

more options

My passwords stopped loading, I reloaded the logins.json file, but they aren't being pulled up yet, though it does save new entries. I reset signon.importedFromSqlite as well.

Details:

1) My passwords and userids stopped autofilling.

2) I've used steps here to reload the logins.json file and reset signon.importedFromSqlite : https://support.mozilla.org/en-US/questions/1045127

3) The old file with my old data is now loaded. In Options, security, saved passwords... I can see my passwords (it was empty before I followed those steps to reload it.)

So that corrected that now if I enter a password on a site, it asks to save it, and it does save it.

4) THE PROBLEM: HOWEVER it's not pulling in all those all passwords that are in the logins.json file. I see them in the logins file but they don't load when I bring up the site. I've opened and closed FF a few times.

Could it be that I didn't delete the key file (but the passwords show when in Options... show passwords). In about:config I did a reset on signon.importedFromSqlite and it reads userset boolean true

Thank you!!


=

Additional info

- I had just updated Java. It was working after that.

- I updated FF a few days ago, but it was working after that.

- I had done a harddrive disk check using windows vista. It took way too long but found no errors. It stopped working after that. But I have the logins file back, so that's not it.

- None of my plugins have been a conflict with this in the recent past (or ever).

My passwords stopped loading, I reloaded the logins.json file, but they aren't being pulled up yet, though it does save new entries. I reset signon.importedFromSqlite as well. Details: 1) My passwords and userids stopped autofilling. 2) I've used steps here to reload the logins.json file and reset signon.importedFromSqlite : https://support.mozilla.org/en-US/questions/1045127 3) The old file with my old data is now loaded. In Options, security, saved passwords... I can see my passwords (it was empty before I followed those steps to reload it.) So that corrected that now if I enter a password on a site, it asks to save it, and it does save it. 4) THE PROBLEM: HOWEVER it's not pulling in all those all passwords that are in the logins.json file. I see them in the logins file but they don't load when I bring up the site. I've opened and closed FF a few times. Could it be that I didn't delete the key file (but the passwords show when in Options... show passwords). In about:config I did a reset on signon.importedFromSqlite and it reads userset boolean true Thank you!! =========== Additional info - I had just updated Java. It was working after that. - I updated FF a few days ago, but it was working after that. - I had done a harddrive disk check using windows vista. It took way too long but found no errors. It stopped working after that. But I have the logins file back, so that's not it. - None of my plugins have been a conflict with this in the recent past (or ever).

Modified by curls

Chosen solution

Your passwords are stored in the key3.db and logins.json files. Make sure they have the same date/time stamp.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Your passwords are stored in the key3.db and logins.json files. Make sure they have the same date/time stamp.

more options

Multiple efforts later and it's working again.

Apparently they don't have to have the same time stamp, but around the same time. (so they are a pair).

The steps I used above brought back files from 2014 so the contents were old. I then restored from a backup from a month ago, and that worked. I copied both files (logins.json & key.db).

I'm not sure why I have two profiles but the one I have marked as "old" is the active profile. So now that I know that, it's much easier to overwrite files in the right profile.

So, thank you, your comment gave me enough info to know what I needed to focus on and how it works... and so then I found the solution!

more options

Glad to help. Safe Surfing.