Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

intl.locale.matchOS setting not changing UI language in accordance to OS locale on Windows 7

  • 2 replies
  • 6 have this problem
  • 1878 views
  • Last reply by bsam

more options

Hi there,

On my Firefox, I have the intl.locale.matchOS setting set to true. When I switch my OS language and region settings from English to Japanese or Japanese to English, I am expecting after a reboot of the machine, that my Firefox's UI language will also switch with my OS, however, with this setting set to True, I am also getting the English UI language.

I have installed the Japanese Language Pack to my English install of Firefox. The version of Firefox I am using is 31.0 and I've got the corresponding language pack of that version as well. My OS is Windows 7.

I'm just wonder what specific Windows settings are used to determine the OS locale?

Currently, when I change between English and Arabic, I change the following settings:

 - Current location under the Location tab in Region and Language settings; and
 - Display Language under the Keyboards and Languages tab in Region and Language settings.

Thank you. Kind regards, Bryan

Chosen solution

There is a command line switch that you can use to select the UI language.

You can create a desktop shortcut with the "-UILocale xx-xx" switch appended to the command line to start Firefox with a specific locale.

Start > Run: firefox.exe -UILocale en-US
Start > Run: firefox.exe -UILocale ja
Read this answer in context 👍 4

All Replies (2)

more options

Chosen Solution

There is a command line switch that you can use to select the UI language.

You can create a desktop shortcut with the "-UILocale xx-xx" switch appended to the command line to start Firefox with a specific locale.

Start > Run: firefox.exe -UILocale en-US
Start > Run: firefox.exe -UILocale ja
more options

Thank you cor-el. This will work as an alternative for me. Thank you so much for your help.