X
Tap here to go to the mobile version of the site.

Support Forum

Your connection is not secure (HSTS) (Error code: sec_error_unknown_issuer) with google

Posted

First of all, this question is repeated several times, but I wasn't able to respond because I don't have an account, so seems like from some stupid reason I need to open a new question in order to open one account.

Fresh installed Firefox 44 x64 on windows 7 x64.

I realized that somehow www.google.com website wasn't working even though other websites worked perfectly. The same website mentioned above worked correctly on IE.

When I turned off Kaspersky Internet security everything was working perfectly. After some tries I figured out that it was the Web Anti-Virus causing the problem, so what I did was:

Kaspersky > Settings > Web Anti-Virus > Advanced Settings > Configure trusted web sites > add as active:

http://www.google.co.uk/*

https://www.google.co.uk/*

You might need to Uncheck and Check again the "Check URLs" to take effect.

First of all, this question is repeated several times, but I wasn't able to respond because I don't have an account, so seems like from some stupid reason I need to open a new question in order to open one account. Fresh installed Firefox 44 x64 on windows 7 x64. I realized that somehow www.google.com website wasn't working even though other websites worked perfectly. The same website mentioned above worked correctly on IE. When I turned off Kaspersky Internet security everything was working perfectly. After some tries I figured out that it was the Web Anti-Virus causing the problem, so what I did was: Kaspersky > Settings > Web Anti-Virus > Advanced Settings > Configure trusted web sites > add as active: http://www.google.co.uk/* https://www.google.co.uk/* You might need to Uncheck and Check again the "Check URLs" to take effect.
Attached screenshots

Modified by pleat_man

Chosen solution

Fresh installed Firefox 44 x64 on windows 7 x64.

I realized that somehow www.google.com website wasn't working even though other websites worked perfectly. The same website mentioned above worked correctly on IE. When I turned off Kaspersky Internet security everything was working perfectly. After some tries I figured out that it was the Web Anti-Virus causing the problem so what I did was:

Kaspersky > Settings > Web Anti-Virus > Advanced Settings > Configure trusted web sites > add as active: http://www.google.co.uk/* https://www.google.co.uk/* You might need to Uncheck and Check again the "Check URLs" to take effect.

Read this answer in context 13

Additional System Details

Installed Plug-ins

  • 5.1.41212.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

Chosen Solution

Fresh installed Firefox 44 x64 on windows 7 x64.

I realized that somehow www.google.com website wasn't working even though other websites worked perfectly. The same website mentioned above worked correctly on IE. When I turned off Kaspersky Internet security everything was working perfectly. After some tries I figured out that it was the Web Anti-Virus causing the problem so what I did was:

Kaspersky > Settings > Web Anti-Virus > Advanced Settings > Configure trusted web sites > add as active: http://www.google.co.uk/* https://www.google.co.uk/* You might need to Uncheck and Check again the "Check URLs" to take effect.

Fresh installed Firefox 44 x64 on windows 7 x64. I realized that somehow www.google.com website wasn't working even though other websites worked perfectly. The same website mentioned above worked correctly on IE. When I turned off Kaspersky Internet security everything was working perfectly. After some tries I figured out that it was the Web Anti-Virus causing the problem so what I did was: Kaspersky > Settings > Web Anti-Virus > Advanced Settings > Configure trusted web sites > add as active: http://www.google.co.uk/* https://www.google.co.uk/* You might need to Uncheck and Check again the "Check URLs" to take effect.