Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to activate Java

  • 3 replies
  • 1 has this problem
  • 407 views
  • Last reply by ffw62

more options

I need to login onto a forum. When I use Firefox and try to login, there is this javascript:void(0); error at the left bottom of the browser.

So I went on to install Java, so now Java(TM) Platform SE 8 U71 11.71.2.15 is installed.

Still this error. Even after closing Firefox and relaunching it a few times.

When I use Edge, no problem.

Now what?

Why is it so complicated whereas with Edge .. no problems. I need to install Flash, need to install Java, need to check whether Firefox is x64 (how?) This that ... Maybe I should even reboot, I don't know.

I never use anything else than Firefox, but it seems that whenever there is something with Java or Flash, one needs to use Edge or Chrome...

=


=

Attached screenshots

Chosen solution

Many thanks! About the difference (Java<->Javascript): I honestly didn't know that. I have uninstalled Java.


Also thanks for the tip about AdBlock, etc.

I have disabled AdBlockPlus for that specific site and logging in is no problem now! Super...


=

Read this answer in context 👍 0

All Replies (3)

more options

Oh and about:config javascript.enabled = true =

more options

This is an issue with JavaScript and has nothing to do with Java.

Java and JavaScript are different languages. To avoid confusion, see:

href="javascript:void(0);" is a placeholder and the actual action is done via an onclick handler attached to the link. You should see an 'ev' button appended to this element in the Inspector. You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools > Web Developer) with this element selected.


If you use extensions ("3-bar" menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from websites that cause problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Chosen Solution

Many thanks! About the difference (Java<->Javascript): I honestly didn't know that. I have uninstalled Java.


Also thanks for the tip about AdBlock, etc.

I have disabled AdBlockPlus for that specific site and logging in is no problem now! Super...


=