X
Tap here to go to the mobile version of the site.

Support Forum

YouTube does not load properly in Firefox, but does in other browsers.

Posted

Yesterday or the day before, I tried going onto YouTube using Firefox, as I usually do, and this happened (see attached image). I tried clearing the cache and cookies, and restarted my whole computer, and nothing changed. Firefox loads all other websites I frequently use just fine, and Chrome works just fine with YouTube, but for some reason, Firefox and YT are not mixing right now. Anyone have any suggestions?

Yesterday or the day before, I tried going onto YouTube using Firefox, as I usually do, and this happened (see attached image). I tried clearing the cache and cookies, and restarted my whole computer, and nothing changed. Firefox loads all other websites I frequently use just fine, and Chrome works just fine with YouTube, but for some reason, Firefox and YT are not mixing right now. Anyone have any suggestions?

Chosen solution

See also: Adblock Plus • View topic - [fixed][Malware Domains List issue] breaks YouTube layout:

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

Helpful Reply

What is your computer system and Firefox? What happens when you try?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

What is your computer system and Firefox? What happens when you try? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there?

Question owner

Safe Mode appears to have resolved it. I wonder if it is a problem with one of my add-ons?

Safe Mode appears to have resolved it. I wonder if it is a problem with one of my add-ons?

Question owner

Figured out that it was AdblockPlus that was causing it. I wonder how to fix that. I want to keep using ad blockers, but not if it makes YouTube act like shit.

Figured out that it was AdblockPlus that was causing it. I wonder how to fix that. I want to keep using ad blockers, but not if it makes YouTube act like shit.
cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158458 answers
Try: *uBlock Origin: https://addons.mozilla.org/firefox/addon/ublock-origin/
cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158458 answers

Chosen Solution

See also: Adblock Plus • View topic - [fixed][Malware Domains List issue] breaks YouTube layout:

See also: Adblock Plus • View topic - [fixed][Malware Domains List issue] breaks YouTube layout: *https://adblockplus.org/forum/viewtopic.php?f=2&t=43506
FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

Helpful Reply

Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select Disable on <web site>.

Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select '''Disable on <web site>.'''