X
Tap here to go to the mobile version of the site.

Support Forum

Artifacting in youtube with hardware acceleration

Posted

With hardware acceleration turned on I get weird artifacting on the Youtube timeline (see image), it looks like white noise in the real world since the image doesn't show all of them. Without the acceleration the artifacting disappears. Only noticed this on Youtube. In rare cases it used to crash the display driver after switching videos, but I have not experienced this for some time now.

I am running Intel graphics on a Lenovo T450s. Drivers are updated.

With hardware acceleration turned on I get weird artifacting on the Youtube timeline (see image), it looks like white noise in the real world since the image doesn't show all of them. Without the acceleration the artifacting disappears. Only noticed this on Youtube. In rare cases it used to crash the display driver after switching videos, but I have not experienced this for some time now. I am running Intel graphics on a Lenovo T450s. Drivers are updated.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 20.0 r0
  • VLC media player Web Plugin

Application

  • Firefox 43.0.4
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.4/WINNT/en-US/

Extensions

  • Adblock Plus 2.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 5500
  • adapterDescription2:
  • adapterDeviceID: 0x1616
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 503617aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18123
  • driverDate: 9-11-2015
  • driverDate2:
  • driverVersion: 10.18.15.4285
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4220 solutions 58912 answers

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems?

Question owner

It is fine when the setting is off, but the CPU usage on a video becomes 40% instead of 4% which drains the battery very quickly.

I would like to keep it on for that reason. Sometimes it doesn't even work, even though the setting is enabled.

It is fine when the setting is off, but the CPU usage on a video becomes 40% instead of 4% which drains the battery very quickly. I would like to keep it on for that reason. Sometimes it doesn't even work, even though the setting is enabled.
FredMcD
  • Top 10 Contributor
4220 solutions 58912 answers

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''