X
Tap here to go to the mobile version of the site.

Support Forum

Cannot install Lastpass add-on

Posted

Since upgrading to FF42 (now on FF43) I haven't been able to install FF - either from the add-on tab or from lastpass's site. I have done a FF clean install; I have done FF refresh. I can install on Chrome without issue, but firefox is my preferred browser. I have contacted Lastpass and they have tried to resolve the issue, but it installs for them without issue. I am on Windows 7.

The attached powerpoints show the error messages. If I try from the add-on page, I get "There was an error installing lastpass". If I use the link lastpass provided (https://addons.mozilla.org/en-US/firefox/addon/lastpass-password-manager/) I get "LastPass could not be installed because Firefox cannot modify the needed file).

Since upgrading to FF42 (now on FF43) I haven't been able to install FF - either from the add-on tab or from lastpass's site. I have done a FF clean install; I have done FF refresh. I can install on Chrome without issue, but firefox is my preferred browser. I have contacted Lastpass and they have tried to resolve the issue, but it installs for them without issue. I am on Windows 7. The attached powerpoints show the error messages. If I try from the add-on page, I get "There was an error installing lastpass". If I use the link lastpass provided (https://addons.mozilla.org/en-US/firefox/addon/lastpass-password-manager/) I get "LastPass could not be installed because Firefox cannot modify the needed file).

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.1.171
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • 5.1.41105.0

Application

  • Firefox 43.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.2/WINNT/en-US/

Extensions

  • Evernote Web Clipper 6.1 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • WhatsApp Web Messenger 43.3 ({e1ab1333-aff6-42fe-84a5-55be2409491b})
  • WebEx Productivity Tools 2.0 (ocplugin@webex.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 21f917aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 11-15-2013
  • driverDate2:
  • driverVersion: 9.18.10.3359
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox

https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

This will disable add-on signature enforcement; Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

Question owner

Thanks Fred - have just tried this but same result - still cannot install and throws the same error messages.

Thanks Fred - have just tried this but same result - still cannot install and throws the same error messages.
FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

Contact their support site for more help, or a reason for the error.

Contact their support site for more help, or a reason for the error.

Question owner

I did - and they routed me here. They have no idea what is causing it.

I did - and they routed me here. They have no idea what is causing it.
FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.