X
Tap here to go to the mobile version of the site.

Support Forum

Spell check not working?

Posted

My PC (running XP) died recently and since setting up this new one (running Windows 7) I can't get Firefox's spell checker to work.

I have the 'check spelling as I type' ticked in Firefox's advanced settings, and I have also download and installed the British Languge Pack add-on, but still it doesn't work.

The problem seems to be that I don;t have the usual 'Check speling' option when I right click in a text box (see attached)

My PC (running XP) died recently and since setting up this new one (running Windows 7) I can't get Firefox's spell checker to work. I have the 'check spelling as I type' ticked in Firefox's advanced settings, and I have also download and installed the British Languge Pack add-on, but still it doesn't work. The problem seems to be that I don;t have the usual 'Check speling' option when I right click in a text box (see attached)
Attached screenshots

Chosen solution

Do you see this dictionary as one of folders in the extensions folder?

Dictionaries need to be unpacked in order to work properly and you would normally find this folder with the files in the dictionaries folder.

You can use this button to go to the current Firefox profile folder:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59412 answers

Helpful Reply

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. Type: '''layout.spellcheckDefault''' Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes. Also, check the '''spellchecker.dictionary''' entry.

Question owner

Thanks, Fred.

layout.spellcheckDefault is set to 1 and True

And spellchecker.dictionary is set to True

Thanks, Fred. '''layout.spellcheckDefault''' is set to '''1''' and '''True''' And '''spellchecker.dictionary''' is set to '''True'''
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 answers

Do you see the en-GB dictionary in "Add-ons > Dictionaries" as installed and enabled?

Do you see the en-GB dictionary in "Add-ons > Dictionaries" as installed and enabled?

Question owner

Hi, cor-el.

This is strange, I've installed the English (British) Language Pack add-on from the link below, and checked that it was in my add-ons afterwards (I thnk it was in either the Plugins or Services section, but it's now disappeared.

Is there a particular dictionary I should be installing, because when I right click while in a text field and choose Add Dictionaries, it takes me here: https://addons.mozilla.org/en-GB/firefox/language-tools/

cor-el said

Do you see the en-GB dictionary in "Add-ons > Dictionaries" as installed and enabled?

In actual fact, I don't have a Dictionaries section on my add-ons page??

Hi, cor-el. This is strange, I've installed the''' English (British) Language Pack''' add-on from the link below, and checked that it was in my add-ons afterwards (I thnk it was in either the '''Plugins''' or '''Services''' section, but it's now disappeared. Is there a particular dictionary I should be installing, because when I right click while in a text field and choose '''Add Dictionaries''', it takes me here: https://addons.mozilla.org/en-GB/firefox/language-tools/ ''cor-el [[#answer-825541|said]]'' <blockquote> Do you see the en-GB dictionary in "Add-ons > Dictionaries" as installed and enabled? </blockquote> In actual fact, I don't have a '''Dictionaries''' section on my add-ons page??

Modified by OurJud

cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 answers

Chosen Solution

Do you see this dictionary as one of folders in the extensions folder?

Dictionaries need to be unpacked in order to work properly and you would normally find this folder with the files in the dictionaries folder.

You can use this button to go to the current Firefox profile folder:

Do you see this dictionary as one of folders in the extensions folder? Dictionaries need to be unpacked in order to work properly and you would normally find this folder with the files in the dictionaries folder. *marcoagpinto@mail.telepac.pt *https://addons.mozilla.org/en-GB/firefox/addon/british-english-dictionary-2/ You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Thank you very much, cor-el.

Whatever the problem was, installing that add-on in your first link did the trick.

It seems that my suspicion that a particular dictionary had to be installed was the issue.

Thank you very much, cor-el. Whatever the problem was, installing that add-on in your first link did the trick. It seems that my suspicion that a particular dictionary had to be installed was the issue.