Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

certificate problems and websites don't load properly

  • 20 replies
  • 2 have this problem
  • 6230 views
  • Last reply by cor-el

more options

The problem started with Outlook.com not wanting to send attachments all of a sudden. Unfortunately I let somebody from the Microsoft support mess about with my computer through a remote app and now it's gone from bad to worse. On every site I visit, I get the This connection is untrusted error and when I just go through to the site, the website doesn't show properly. I don't get images, just the words as links. I then reset my system a couple of days back through system restore but that didn't help. I have uninstalled Firefox and downloaded a new version. Still the same problem. I have deleted cert8 but that didn't help either. I know the guy did something in Troubleshoot Problems so my guess is that he deleted a certificate of some sort but I don't know how to get it back. My partner uses Firefox and he has the same problem at the moment that Outlook.com can't attach files.

I hope someone can help me as I'm at my wits end at the moment. Thanks. (I'm surfing in Chrome at the moment as Firefox doesn't work)

Chosen solution

So by disabling this, I'm doing myself a favour?

That's something you'll have to decide for yourself. In order to scan the contents of your secured communications ESET will need to be able to decrypt all secure communications, including any account passwords. In my view that imposes a far greater risk than the benefit, if there is any. As far as protection is concerned, Firefox has a built-in malware protection, so I don't see any good reason to let ESET do this. https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work

When your problem has been fixed, can you mark the thread as 'Solved' please? Thank you.

Read this answer in context 👍 0

All Replies (20)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

I've followed all the steps but it doesn't change anything. The only odd thing is that I've cleared all the cookies and cleared the cache but when I type in the search, there are still loads of suggestions there.

This is the message: You have asked Firefox to connect securely to www.google.co.uk, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

more options

nicky25 said

I've followed all the steps but it doesn't change anything. The only odd thing is that I've cleared all the cookies and cleared the cache but when I type in the search, there are still loads of suggestions there.

That is from the built in form filler.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate.

http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

more options

I had seen most of the articles before I posted on the forum. The clock is right and so is the date. I also deleted this cert8 although it didn't say cert8.db, only cert8. I even switched Eset off last night and tried Outlook.com but still the same error. Not sure what to do anymore. It seems rather bizarre that out of the blue, my partner and I both can't attach files (both different laptops and different brands) and with mine it's gone from bad to worse.

Modified by nicky25

more options

Some file extensions are hidden. You can change the file browser setting.

Do you have nvidia's network access manager or forceware network manager software installed? Disable / remove it.


Perform a System File Check to fix corrupted system files Win 7, 8, 10, Vista: https://support.microsoft.com/en-us/kb/929833

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia


Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

Can you post a screenshot of the 'This connection is untrusted error'? There should be a cause given why you get the error.

https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

more options

Let me post some screenshots first and then I'll try the other solutions of Fred as that's quite a long process it seems. I've also posted a screenshot of what I see at the moment. When I search in the top right bar, I get the untrusted message and when I search in the main Mozilla Google window, I can go to a site but don't see the proper layout. I can surf normally in Chrome and IE so it's not a computer issue. There's something wrong in Mozilla and the strange thing is I have downloaded a new copy so who knows.

more options
Perform a System File Check to fix corrupted system files See if there are updates for your graphics drivers

None of these will address your problem, so you'll just waste your time.

Can you connect to https://www.google.co.uk with Internet Explorer?

Modified by christ1

more options

So I can surf ok in Safe Mode. No reports now. This is the copy text to the clipboard: Application Basics


Name: Firefox Version: 43.0.2 Build ID: 20151221130713 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 Multiprocess Windows: 0/1 (default: false) Safe Mode: false

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Graphics


Adapter Drivers: vga framebuf vga256 vga64k Adapter RAM: Unknown Asynchronous Pan/Zoom: none Device ID: 0x0000 Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues. DirectWrite Enabled: false (6.2.9200.17568) GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics card because of unresolved driver issues. Subsys ID: 00000000 Supports Hardware H264 Decoding: No; Failed to create H264 decoder Vendor ID: 0x0000 WebGL Renderer: Blocked for your graphics card because of unresolved driver issues. windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 2 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20151221130713 browser.startup.homepage_override.buildID: 20151221130713 browser.startup.homepage_override.mstone: 43.0.2 browser.tabs.warnOnClose: false browser.urlbar.userMadeSearchSuggestionsChoice: true dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 43.0.2 font.internaluseonly.changed: true gfx.crash-guard.d3d11layers.appVersion: 43.0.2 gfx.crash-guard.d3d11layers.deviceID: 0x9712 gfx.crash-guard.d3d11layers.driverVersion: 8.713.3.0 gfx.crash-guard.d3d11layers.feature-d2d: true gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true gfx.crash-guard.status.d3d11layers: 2 gfx.crash-guard.status.d3d9video: 2 gfx.crash-guard.status.glcontext: 2 gfx.direct2d.disabled: true gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 42.0 gfx.driver-init.deviceID: 0x9712 gfx.driver-init.driverVersion: 8.713.3.0 gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 layers.acceleration.disabled: true media.gmp-eme-adobe.abi: x86-msvc media.gmp-eme-adobe.lastUpdate: 1451305452 media.gmp-eme-adobe.version: 15 media.gmp-gmpopenh264.abi: x86-msvc media.gmp-gmpopenh264.lastUpdate: 1451305453 media.gmp-gmpopenh264.version: 1.5.1 media.gmp-manager.buildID: 20151221130713 media.gmp-manager.lastCheck: 1451408324 media.hardware-video-decoding.failed: true network.auth.allow-subresource-auth: 2 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1450803184 places.history.expiration.transient_current_max_pages: 73687 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npvlc: 2 print.printer_HP_Deskjet_2540_series_(Network).print_bgcolor: false print.printer_HP_Deskjet_2540_series_(Network).print_bgimages: false print.printer_HP_Deskjet_2540_series_(Network).print_colorspace: print.printer_HP_Deskjet_2540_series_(Network).print_command: print.printer_HP_Deskjet_2540_series_(Network).print_downloadfonts: false print.printer_HP_Deskjet_2540_series_(Network).print_duplex: 1515870810 print.printer_HP_Deskjet_2540_series_(Network).print_edge_bottom: 0 print.printer_HP_Deskjet_2540_series_(Network).print_edge_left: 0 print.printer_HP_Deskjet_2540_series_(Network).print_edge_right: 0 print.printer_HP_Deskjet_2540_series_(Network).print_edge_top: 0 print.printer_HP_Deskjet_2540_series_(Network).print_evenpages: true print.printer_HP_Deskjet_2540_series_(Network).print_footercenter: print.printer_HP_Deskjet_2540_series_(Network).print_footerleft: &PT print.printer_HP_Deskjet_2540_series_(Network).print_footerright: &D print.printer_HP_Deskjet_2540_series_(Network).print_headercenter: print.printer_HP_Deskjet_2540_series_(Network).print_headerleft: &T print.printer_HP_Deskjet_2540_series_(Network).print_headerright: &U print.printer_HP_Deskjet_2540_series_(Network).print_in_color: true print.printer_HP_Deskjet_2540_series_(Network).print_margin_bottom: 0.5 print.printer_HP_Deskjet_2540_series_(Network).print_margin_left: 0.5 print.printer_HP_Deskjet_2540_series_(Network).print_margin_right: 0.5 print.printer_HP_Deskjet_2540_series_(Network).print_margin_top: 0.5 print.printer_HP_Deskjet_2540_series_(Network).print_oddpages: true print.printer_HP_Deskjet_2540_series_(Network).print_orientation: 0 print.printer_HP_Deskjet_2540_series_(Network).print_page_delay: 50 print.printer_HP_Deskjet_2540_series_(Network).print_paper_data: 9 print.printer_HP_Deskjet_2540_series_(Network).print_paper_height: 11.00 print.printer_HP_Deskjet_2540_series_(Network).print_paper_name: print.printer_HP_Deskjet_2540_series_(Network).print_paper_size_type: 0 print.printer_HP_Deskjet_2540_series_(Network).print_paper_size_unit: 1 print.printer_HP_Deskjet_2540_series_(Network).print_paper_width: 8.50 print.printer_HP_Deskjet_2540_series_(Network).print_plex_name: print.printer_HP_Deskjet_2540_series_(Network).print_resolution: 1515870810 print.printer_HP_Deskjet_2540_series_(Network).print_resolution_name: print.printer_HP_Deskjet_2540_series_(Network).print_reversed: false print.printer_HP_Deskjet_2540_series_(Network).print_scaling: 1.00 print.printer_HP_Deskjet_2540_series_(Network).print_shrink_to_fit: true print.printer_HP_Deskjet_2540_series_(Network).print_to_file: false print.printer_HP_Deskjet_2540_series_(Network).print_unwriteable_margin_bottom: 0 print.printer_HP_Deskjet_2540_series_(Network).print_unwriteable_margin_left: 0 print.printer_HP_Deskjet_2540_series_(Network).print_unwriteable_margin_right: 0 print.printer_HP_Deskjet_2540_series_(Network).print_unwriteable_margin_top: 0 privacy.donottrackheader.enabled: true privacy.sanitize.migrateClearSavedPwdsOnExit: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 security.disable_button.openCertManager: false security.disable_button.openDeviceManager: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1449395824

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.10 Version in use: 4.10.10

NSS Expected minimum version: 3.20.2 Basic ECC Version in use: 3.20.2 Basic ECC

NSSSMIME Expected minimum version: 3.20.2 Basic ECC Version in use: 3.20.2 Basic ECC

NSSSSL Expected minimum version: 3.20.2 Basic ECC Version in use: 3.20.2 Basic ECC

NSSUTIL Expected minimum version: 3.20.2 Version in use: 3.20.2

Experimental Features


more options

Christ1, yes I can surf normally in IE and Chrome. No issues at all. It's just Mozilla that doesn't work. I have just tried to attach a pdf file on my partner's computer and he still can't send that or a jpeg in Mozilla through Outlook. The only thing that sends is a simple Word document.

Modified by nicky25

more options

The question was whether you can open this particular link with Internet Explorer: https://www.google.co.uk Please confirm.

more options

Ok. Using Internet Explorer, please inspect the certificate by clicking on the lock symbol in the URL bar.

Who's the Certificate issuer? What's the Certification Path? Please provide screenshots.

more options

Here you go. I did disable ESET last night to try and surf that way in Mozilla but that didn't seem to solve the issue.

more options

Follow the instructions to Disable SSL protocol scanning near the bottom of the page. http://support.eset.com/kb3126/

more options

Bingo! That did the trick but what exactly does this mean now? Am I not protected properly by disabling this SSL protocol scanning or shall I re-install ESET?

more options
what exactly does this mean now?

Basically this means that ESET won't intercept your secure connection to the server anymore. And they won't be able to see all your account passwords in the clear anymore when you login to a secure site, because now your Firefox connects to the server directly, and not to the ESET SSL proxy.

If you want the so called 'protection' you'll need to install the ESET root cert in Firefox. Not something I'd want though.

Modified by christ1

more options

So by disabling this, I'm doing myself a favour? Do I understand that correctly? I never realised ESET could see all my account passwords!

Thank you so much for your help by the way. I very much appreciate it.

more options

Chosen Solution

So by disabling this, I'm doing myself a favour?

That's something you'll have to decide for yourself. In order to scan the contents of your secured communications ESET will need to be able to decrypt all secure communications, including any account passwords. In my view that imposes a far greater risk than the benefit, if there is any. As far as protection is concerned, Firefox has a built-in malware protection, so I don't see any good reason to let ESET do this. https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work

When your problem has been fixed, can you mark the thread as 'Solved' please? Thank you.

Modified by christ1

more options