Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How To: Disable the new "Visit what you are typing" in url drop down. FF 43

  • 8 replies
  • 194 have this problem
  • 13658 views
  • Last reply by x4ever

more options

So with the FF 43 update Mozilla is again destroying my work flow. When browsing i I mostly go off of muscle memory. And the new update through up in the top most position of the url drop down the search with option. I disabled that inside of 5 minutes but now instead of that is gives me "Visit "what ever url i may be partially typing" . I'd like this new item disabled and can't seem to find an option for it.

I've never understood why the url bar got enabled for web search when there is already a dedicated search bar.

Chosen solution

You can set this pref to false on the about:config page.

  • browser.urlbar.unifiedcomplete = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


The location bar drop down list can show history items as well as bookmarked pages and websites currently opened in tabs. You can set what suggestions to show when you enter an URL in the location/address bar in "Options/Preferences > Privacy".

  • Tools > Options > Privacy > Location Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
  • browser.urlbar.suggest.history.onlyTyped choice needs to be changed directly via the pref
  • browser.urlbar.suggest.searches choice is present in Firefox 43+ as "Show search suggestions in location bar results" in "Options/Preferences > Search" as part of the search settings
Read this answer in context 👍 114

All Replies (8)

more options

The FF 43 is a horrible update, they have also removed the ability to disable the awful "one search bar" feature they have implemented a while ago.

Please stop adding dubious features and then viciously forcing users to use them by removing options. If i wanted tyrannical software i would use Google Chrome - please stop making Firefox awful.

more options

Chosen Solution

You can set this pref to false on the about:config page.

  • browser.urlbar.unifiedcomplete = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


The location bar drop down list can show history items as well as bookmarked pages and websites currently opened in tabs. You can set what suggestions to show when you enter an URL in the location/address bar in "Options/Preferences > Privacy".

  • Tools > Options > Privacy > Location Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
  • browser.urlbar.suggest.history.onlyTyped choice needs to be changed directly via the pref
  • browser.urlbar.suggest.searches choice is present in Firefox 43+ as "Show search suggestions in location bar results" in "Options/Preferences > Search" as part of the search settings
more options

I think a better name could be used for that option

more options
more options

From the Bonardo blog re this config switch: "This also means old components will shortly be deprecated and won't be maintained anymore."

This means that in the near future the option in about:config to turn back this "new, improved" behavior will not be available any more - just like the elimination, since V.43.0, of the code behind the browser.search.showOneOffButtons option, which allowed us to return to the old, convenient and efficient search engine presentation and selection.

more options

hi

if I type www Firefox opens the dropdown Window and shows all typed and history and bookmarks

If I type www it should not open a dropdown and it should only autofill typed and bookmarks

what must I cange?

before the update everything worked fine

more options

Hi Garga, if you mean the update to Firefox 44, could you start a new question? This one is for a specific behavior added in Firefox 43 and is already marked solved.

You can use this link to start your question. Scroll down past the suggestions to continue with the form:

https://support.mozilla.org/questions/new/desktop/fix-problems

more options

About:Config +cor-el = why I'm still using Firefox. Thank you sooooo much. I can't tell you the share number of times I've had a problem that cor-el covers on here :P.